WD2000: How to Use a Macro to Insert Page Numbers into E-Mail Message

Article translations Article translations
Article ID: 211884 - View products that this article applies to.
This article was previously published under Q211884
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

SUMMARY

When you use Microsoft Word as your e-mail editor, you cannot insert page numbers into your e-mail message. This article describes how to insert page numbers in an e-mail message by using a Microsoft Visual Basic for Applications macro.

MORE INFORMATION

NOTE: The page numbers that you insert into your e-mail message are visible only when you or the recipient is using WordMail and while you or the recipient is using print layout view. The page numbers are printed when you or the recipient prints the e-mail message.
  1. Start Word.
  2. On the Tools menu, point to Macro, and then click Record New Macro.
  3. In the Macro name box, type a name for the macro. For example, type:
    InsertPageNumbers
  4. In the Store macro in list, select All Documents (Normal.dot).
  5. Click OK. The macro recorder starts, and the Stop Recording toolbar appears.
  6. On the View menu, click Header and Footer. The insertion point appears in the header. If you want the page numbers in the footer, click the Switch Between Header and Footer button on the Header and Footer toolbar.
  7. Position the insertion point where you want to place the page number. For example, press the TAB key once if you want the page number to be centered, or press the TAB key two times if you want the page number to be right-aligned.
  8. Type any text you want to appear before the page number, and then click the Insert Page Number button on the Header and Footer toolbar.
  9. Click Close on the Header and Footer toolbar.
  10. Click Stop Recording on the Stop Recording toolbar.

    NOTE: The InsertPageNumbers macro is now stored in the Normal.dot template. It will be available any time you create a document in Word. If you want the macro to be available only to e-mail documents, use the Organizer to move the macro from the Normal.dot template to the E-mail.dot template.
  11. Start Microsoft Outlook and set Word as your e-mail editor:

    1. On the Tools menu, click Options.
    2. On the Mail Format tab, click to select the Use Microsoft Word to edit e-mail messages check box.
    3. Click OK.
  12. Compose your e-mail message.
  13. Insert the page numbers using the recorded macro:

    1. Place the insertion point in the text area of your e-mail message.
    2. On the Tools menu, point to Macro, and then click Macros.
    3. In the Macro box, select the InsertPageNumbers macro, and then click Run.

Properties

Article ID: 211884 - Last Review: February 23, 2014 - Revision: 1.1
APPLIES TO
  • Microsoft Word 2000 Standard Edition
Keywords: 
kbnosurvey kbarchive kbinfo kbmacro kbprogramming KB211884

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com