An Exchange Server 2007 Unified Messaging user cannot play a voice mail if the caller-id of the external caller contains a wildcard character

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Article ID: 2121947 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • User A is a Microsoft Exchange Server 2007 Unified Messaging user.
  • An external caller calls User A and leaves a voice mail.
  • The caller-id of the external caller contains a wildcard (*) character.
In this scenario, User A finds the following results:
  • When User A logs into Outlook Voice Access and then tries to play the voice mail, there is nothing. Or, User A receives the following error message:

    Message cannot be read.
  • User A cannot play the voice mail by using the Play on Phone feature in Microsoft Office Outlook.
  • User A cannot press the Play button of Windows Media Player for the voice mail in Outlook and in Outlook Web Access.
Note Certain third-party gateways add a wildcard character to the caller-id of the external caller.

CAUSE

This problem occurs because the caller-id of the external caller is used for the voice mail file name. However, wildcard characters are invalid for file names.

RESOLUTION

To resolve this problem, install the following update rollup:
2279665 Description of Update Rollup 1 for Exchange Server 2007 Service Pack 3

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 2121947 - Last Review: September 17, 2010 - Revision: 1.0
APPLIES TO
  • Microsoft Exchange Server 2007 Service Pack 3
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbqfe kbfix kbexpertiseinter kbhotfixrollup kbsurveynew KB2121947

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