Word でフィールド コードを使用して目次と索引を作成する方法

文書翻訳 文書翻訳
文書番号: 212346 - 対象製品
Microsoft Word 98 Macintosh Edition については、次の資料を参照してください。190610
Microsoft Word 97 については、次の資料を参照してください。125937
すべて展開する | すべて折りたたむ

目次

概要

この資料では、目次登録フィールド (TC フィールド) を作成して目次を作成する方法と、索引登録フィールド (XE フィールド) を作成して索引を作成する方法について説明します。

目次登録 (TC) フィールドを作成する方法

目次項目を登録する方法には、ユーザー設定のメニュー コマンドを作成する方法とキーボードを使用する方法の 2 とおりがあります。

方法 1 : ユーザー設定のメニュー コマンドを作成する方法

パート A : [挿入] メニューに [目次登録] メニュー コマンドを追加するには、次の手順を実行します。
  1. [ツール] メニューの [ユーザー設定] をクリックし、[ツールバー] タブをクリックします。
  2. [メニュー バー] チェック ボックスをオンにします。

    : このオプションは、デフォルトでオンになっています。
  3. [ユーザー設定] ダイアログ ボックスで、[コマンド] タブをクリックします。
  4. [分類] ボックスの一覧で [すべてのコマンド] をクリックします。
  5. [コマンド] ボックスの一覧の [MarkTableOfContentsEntry] をクリックし、このコマンドを [挿入] メニューにドラッグします。メニュー上のコマンドを表示する場所までドラッグしてから、マウス ボタンを離します。
  6. [ユーザー設定] ダイアログ ボックスで、[閉じる] をクリックします。
パート B : 目次に含めるテキストを登録するには、次の手順を実行します。
  1. 目次に含めるテキストを選択します。
  2. [挿入] メニューの [目次登録] をクリックします。
  3. 選択したテキストとは異なるテキストを目次項目にする場合は、[目次項目] ボックスのテキストを変更します。
  4. [項目の先頭文字] ボックスの一覧で、目次用の [C] をクリックします。
  5. [レベル] ボックスの一覧で、目次項目のレベルを選択します。
  6. [登録] をクリックします。
  7. [閉じる] をクリックします。
  8. 文書内の目次項目ごとに上記の手順 1. 〜 7. を繰り返します。

方法 2 : キーボードを使用する方法

  1. 目次項目として登録するテキストを選択します。
  2. Alt + Shift + O キーを押します。

    [目次項目の登録] ダイアログ ボックスが表示されます。
  3. 選択したテキストとは異なるテキストを目次項目にする場合は、[目次項目] ボックスのテキストを変更します。
  4. [項目の先頭文字] ボックスの一覧で、目次用の [C] をクリックします。
  5. [レベル] ボックスの一覧で、目次項目のレベルを選択します。
  6. [登録] をクリックします。
  7. [閉じる] をクリックします。
  8. 作成する必要のあるすべての目次項目に対して手順 1. 〜 7. を繰り返します。

目次を作成する方法

目次を作成するには、次の手順を実行します。
  1. 目次を配置する場所にカーソルを置きます。
  2. Word 2003 の場合
    [挿入] メニューの [参照] をポイントし、[索引と目次] をクリックします。

    Word 2002 の場合
    [挿入] メニューの [参照] をクリックし、[索引と目次] をクリックします。

    Word 2000 の場合
    [挿入] メニューの [索引と目次] をクリックします。
  3. [目次] タブをクリックし、[オプション] をクリックします。
  4. [目次登録フィールドを使用する] チェック ボックスをオンにします。
  5. [OK] を 2 回クリックします。
カーソルを置いた場所に目次が挿入されます。

索引登録 (XE) フィールドを作成する方法

索引項目を登録するには、次のいずれかの方法を使用します。
  • ユーザー設定のメニュー コマンドを使用する。
  • 標準のメニュー コマンドを使用する。
  • キーボードを使用する。
  • 索引登録ファイルを使用する。

方法 1 : ユーザー設定のメニュー コマンドを使用する方法

パート A : [挿入] メニューに [索引登録] メニュー コマンドを追加するには、次の手順を実行します。
  1. [ツール] メニューの [ユーザー設定] をクリックし、[ツールバー] タブをクリックします。
  2. [メニュー バー] チェック ボックスをオンにします。

    : このオプションは、デフォルトでオンになっています。
  3. [ユーザー設定] ダイアログ ボックスで、[コマンド] タブをクリックします。
  4. [分類] ボックスの一覧で [すべてのコマンド] をクリックします。
  5. [コマンド] ボックスの一覧の [MarkIndexEntry] をクリックし、このコマンドを [挿入] メニューにドラッグします。メニュー上のコマンドを表示する場所までドラッグしてから、マウス ボタンを離します。
  6. [ユーザー設定] ダイアログ ボックスで、[閉じる] をクリックします。
パート B : 索引に含めるテキストを登録するには、次の手順を実行します。
  1. 索引に含めるテキストを選択 (強調表示に) します。
  2. [挿入] メニューの [索引登録] をクリックします。
  3. 選択したテキストとは異なるテキストをメインの索引項目にする場合は、[登録 (メイン)] ボックスのテキストを変更します。[登録 (サブ)] ボックスにテキストを入力し、必要なオプションとページ番号の書式を選択します。
  4. 選択したテキストのみを登録する場合は [登録] をクリックし、選択したテキストが現れるすべての箇所を登録する場合は [すべて登録] をクリックします。
  5. [閉じる] をクリックします。
  6. 作成する必要のあるすべての索引項目に対して手順 1. 〜 5. を繰り返します。

方法 2 : 標準のメニュー コマンドを使用する方法

索引に含めるテキストを登録するには、次の手順を実行します。
  1. Word 2003 の場合
    [挿入] メニューの [参照] をポイントし、[索引と目次] をクリックします。

    Word 2002 の場合
    [挿入] メニューの [参照] をクリックし、[索引と目次] をクリックします。

    Word 2000 の場合
    [挿入] メニューの [索引と目次] をクリックします。
  2. [索引] タブの [索引登録] をクリックします。
  3. [登録 (メイン)] ボックスおよび [登録 (サブ)] ボックスにテキストを入力し、必要なオプションとページ番号の書式を選択します。
  4. [登録] をクリックします。
  5. 作成する必要のあるすべての "索引登録" フィールドに対して上記の手順 3. 〜 4. を繰り返します。
  6. [閉じる] をクリックします。

方法 3 : キーボードを使用する方法

索引に含めるテキストを登録するには、次の手順を実行します。
  1. 索引項目として登録するテキストを選択します。
  2. Alt + Shift + X キーを押します。[索引登録] ダイアログ ボックスが表示されます。
  3. 選択したテキストとは異なるテキストをメインの索引項目にする場合は、[登録 (メイン)] ボックスのテキストを変更します。[登録 (サブ)] ボックスにテキストを入力し、必要なオプションとページ番号の書式を選択します。
  4. 選択したテキストのみを登録する場合は [登録] をクリックし、選択したテキストが現れるすべての箇所を登録する場合は [すべて登録] をクリックします。
  5. [閉じる] をクリックします。
  6. 各 "索引登録" フィールドに対して上記の手順 1. 〜 5. を繰り返します。

方法 4 : 索引登録ファイルを使用する方法

この方法は、どの単語を索引に入れるかがわかっており、それらの単語が現れる、文書内のすべての箇所を索引登録する場合に使用します。

索引登録ファイルを使用して索引を作成するには、次の手順を実行します。
  1. 新規文書に 2 列のテーブルを挿入します。
  2. 左側の列には、文書中の索引登録する単語を入力します。

    ここに入力する単語は、大文字小文字が区別されます。
  3. 右側の列には、左側の列に対応し、索引に表示するテキストを入力します。
  4. この文書を保存して閉じます。
  5. 索引を挿入する文書を開きます。
  6. Word 2003 の場合
    [挿入] メニューの [参照] をポイントし、[索引と目次] をクリックします。

    Word 2002 の場合
    [挿入] メニューの [参照] をクリックし、[索引と目次] をクリックします。

    Word 2000 の場合
    [挿入] メニューの [索引と目次] をクリックします。
  7. [索引] タブをクリックします。
  8. [自動索引登録] をクリックします。
  9. 手順 1. 〜 4. で作成したファイルを選択し、[開く] をクリックします。
文書内の単語が自動的に登録されます。

索引を作成する方法

索引を作成するには、次の手順を実行します。
  1. 索引項目を挿入済みの文書を開き、索引を配置する場所にカーソルを置きます。
  2. Word 2003 の場合
    [挿入] メニューの [参照] をポイントし、[索引と目次] をクリックします。

    Word 2002 の場合
    [挿入] メニューの [参照] をクリックし、[索引と目次] をクリックします。

    Word 2000 の場合
    [挿入] メニューの [索引と目次] をクリックします。
  3. [索引] タブをクリックし、[OK] をクリックします。
カーソルを置いた場所に索引が挿入されます。

プロパティ

文書番号: 212346 - 最終更新日: 2007年2月20日 - リビジョン: 3.0
この資料は以下の製品について記述したものです。
  • Microsoft Office Word 2003
  • Microsoft Word 2002
  • Microsoft Word 2000
キーワード:?
kbhowto kbhowtomaster KB212346
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com