Article ID: 2123563 - Last Review: January 11, 2012 - Revision: 14.0

You cannot open Office file types directly from a server that supports only Basic authentication over a non-SSL connection

System TipThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.

On This Page

Expand all | Collapse all

SYMPTOMS

Consider the following scenario:

You have Microsoft Office 2010 applications or Microsoft Office 2007 applications installed on a client computer. From that client computer, you try to access an Office file that is stored on a web server (for example, a SharePoint server or WebDav server) that is configured for Basic authentication. The connection between your computer and the web server does not use Secure Sockets Layer (SSL). When you try to open or to download the file, you experience the following symptoms:
  • The Office file does not open or download.
  • You do not receive a Basic authentication password prompt when you try to open or to download the file.
  • You do not receive an error message when you try to open the file. The associated Office application starts. However, the selected file does not open.

CAUSE

By default, file operations that use Basic authentication over a non-SSL HTTP connection are disabled in Office 2010 applications. When Basic authentication is disabled, one of the following events occurs:
  • The client application uses a different authentication method. (This occurs if the server supports a different authentication method.)
  • The request fails. (The list in the "Symptoms" section describes what happens when a request fails.)

RESOLUTION

To resolve this problem, the server administrator should enable SSL encryption on the web server (recommended). By default, Office 2010 applications can access and download files from a web server that uses Basic authentication only over an SSL connection. 


WORKAROUND

To work around this problem, let Office 2010 applications connect to a web server by using Basic authentication over a non-SSL connection.

Warning:Enabling Basic Authentication without Secure Sockets Layer (SSL) can be a significant security risk.

Because user credentials are not encrypted for network transmission and are sent over the network in plain text, using Basic authentication over an unsecured HTTP connection is not recommended. For more information, see the "More Information" section. If you want to use Basic authentication, we recommend that you always enable SSL encryption on the server.


To have us work around this problem for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me



To fix this problem automatically, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.


Fix this problem
Microsoft Fix it 50711


Notes
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.



Let me fix it myself


The two steps that follow describe how to enable Office 2010 applications to open Office file types directly from a server that supports only Basic authentication over a non-SSL connection. These steps should be used only if you are confident that the connection between the user and the web server is secure. A direct cable connection or dedicated line would be considered optimal for secure connections.

Note For Office 2010 applications, both steps are required. For other Office applications, only step 1 is required.

Step 1: On the client computer, configure the Web Distributed Authoring and Versioning (WebDAV) Redirector to enable Basic authentication over non-SSL connections.

Note This step is required for Office 2007 and Office 2010 applications.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

Windows XP and Windows Server 2003

To enable Basic authentication on the client computer, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type UseBasicAuth, and then press Enter.
  5. Right-click UseBasicAuth, and then click Modify.
  6. In the Value data box, type 1, and then click OK.

    Note Basic authentication is enabled if the UseBasicAuth registry entry is set to a nonzero value.
    Basic authentication is disabled if the UseBasicAuth registry entry is not present or if the UseBasicAuth
    registry entry is set to 0 (zero).
  7. Exit Registry Editor, and then restart the computer.

Windows Vista and Windows 7

To enable Basic authentication on the client computer, follow these steps:
  1. Click Start, type regedit in the Start Search box, and then press Enter.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type BasicAuthLevel, and then press Enter.
  5. Right-click BasicAuthLevel, and then click Modify.
  6. In the Value data box, type 2, and then click OK.

    Note The mapping is as follows:

    0 - Basic authentication disabled
    1 - Basic authentication enabled for SSL connections only
    2 - Basic authentication enabled for SSL and non-SSL connections
  7. Exit Registry Editor, and then restart the computer.

For more information about how to configure the WebDAV redirector to enable Basic authentication, visit the following Microsoft website:

http://support.microsoft.com/kb/841215 (http://support.microsoft.com/kb/841215) .

Step 2: On the client computer, add the BasicAuthLevel registry key and appropriate value.

Note This step is required for Office 2010 applications.


Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
  1. Start Registry Editor.
    • In Windows 7 or in Windows Vista, click Start, type regedit in the Start Search box, and then press Enter. If you are prompted for an administrator password or for confirmation, type the password or provide confirmation.
    • In Windows XP, click Start, click Run, type regedit, and then click OK.

  2. Locate and then click the following registry subkey:

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type BasicAuthLevel, and then press Enter.
  5. Right-click BasicAuthLevel, and then click Modify.
  6. In the Value data box, type 2, and then click OK.

    NoteThe mapping is as follows: 

    0 - Basic authentication disabled
    1 - Basic authentication enabled for SSL connections only
    2 - Basic authentication enabled for SSL and for non-SSL connections
  7. Exit Registry Editor, and then restart the computer.

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support (http://support.microsoft.com/contactus) .
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me (http://blogs.technet.com/fixit4me/) " blog or send us an email (mailto:fixit4me@microsoft.com?Subject=KB) message.

More Information

Basic authentication is a widely used, industry-standard method for collecting user name and password information. The advantage of Basic authentication is that it is part of the HTTP specification and is supported by most browsers. However, Basic authentication prompts the user for a username and password. This information is then sent unencrypted over the network. The Basic authentication method is not recommended unless you are sure that the connection between the user and the web server is secured (by using SSL or a direct connection, for example). With Basic authentication, the password is sent over the network in plain text. If this password is intercepted over the network by a network sniffer, an unauthorized user can determine the username and password and reuse these credentials. It is because of this security risk that Office 2010 applications disable Basic authentication over a non-SSL connection in the default configuration.



APPLIES TO
  • Microsoft Office Standard 2010
  • Microsoft Office Professional 2010
  • Microsoft Office Professional Plus 2010
  • 2007 Microsoft Office Suite Service Pack 1
  • 2007 Microsoft Office Suite Service Pack 2
Keywords: 
kbfixme kbmsifixme KB2123563