Soubory systému Office nelze otevřít přímo ze serveru, který podporuje pouze základní ověřování prostřednictvím jiného připojení než SSL

ID článku: 2123563
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Může dojít k následující situaci:

V počítači klienta jsou nainstalovány aplikace systému Microsoft Office 2010 nebo Office 2007. Z tohoto počítače klienta se pokusíte o přístup k souboru systému Office, který je uložen na webovém serveru (například na serveru SharePoint nebo WebDav). Pokusíte-li se o otevření nebo stažení souboru, projeví se následující příznaky:
  • Soubor systému Office nelze otevřít nebo stáhnout.
  • Při pokusu o otevření nebo stažení souboru se nezobrazí výzva k zadání hesla pro základní ověřování.
  • Při pokusu o otevření souboru se nezobrazí chybová zpráva. Příslušná aplikace systému Office se spustí. Vybraný soubor se však neotevře.

Příčina

Na serveru je nakonfigurováno základní ověřování. Připojení mezi počítačem a webovým serverem nepoužívá protokol SSL (Secure Sockets Layer).

Ve výchozím nastavení jsou operace se soubory, které využívají základní ověřování prostřednictvím jiného připojení než SSL HTTP, jsou v aplikacích systému Office 2010 zakázány. Je-li zablokováno základní ověřování, dojde k jedné z následujících událostí:
  • Klientská aplikace použije jinou metodu ověřování. (K této situaci dojde, pokud server podporuje jinou metodu ověřování.)
  • Žádost se nezdaří. (Popis toho, co se stane, když se žádost nezdaří, je uveden v seznamu v části Příznaky.)

Řešení

Chcete-li tyto potíže vyřešit, požádejte správce serveru o povolení šifrování SSL na webovém serveru (doporučeno). Ve výchozím nastavení mohou aplikace systému Office 2010 přistupovat k souborům na webovém serveru, který používá základní ověřování pouze přes připojení SSL, a stahovat je.


Jak potíže obejít

Chcete-li vyřešit tyto potíže, umožněte aplikací systému Office 2010 připojit se k webovému serveru s využitím základního ověřování přes připojení SSL.

Upozornění:Povolení základního ověřování bez protokolu SSL (Secure Sockets Layer) může představovat významné bezpečnostní riziko.

Vzhledem k tomu, že pověření uživatele nejsou při síťovém přenosu šifrována a jsou v síti odeslána jako prostý text, použití základního ověřování s nezabezpečeným připojením HTTP se nedoporučuje. Další informace naleznete v části Další informace. Chcete-li použít základní ověřování, doporučujeme, abyste na serveru vždy povolili šifrování SSL.


Chcete-li, abychom tyto potíže vyřešili za vás, přejděte k části Automatická oprava. Chcete-li tyto potíže vyřešit sami, přejděte k části Manuální oprava.

Automatická oprava



Chcete-li tyto potíže odstranit automaticky, klikněte na tlačítko nebo odkaz Opravit. V dialogovém okně Stažení souboru klikněte na položku Spustit a postupujte podle kroků v průvodci opravou.


Fix this problem
Microsoft Fix it 50711


Poznámky
  • Tento průvodce může být k dispozici pouze v angličtině. Tato automatická oprava však funguje i pro ostatní jazykové verze systému Windows.
  • Pokud právě nejste u počítače, který má tyto potíže, můžete opravu uložit na jednotku USB Flash nebo na disk CD a spustit ji v příslušném počítači později.

Poté přejděte k části Byly potíže vyřešeny?.



Manuální oprava

Následující dva kroky popisují, jak aplikacím systému Office 2010 povolit otevírání souborů systému Office přímo ze serveru, který podporuje pouze základní ověřování prostřednictvím jiného připojení než SSL. Tyto kroky byste měli použít pouze v případě, že jste si jisti zabezpečením připojení mezi uživatelem a webovým serverem. Pro zabezpečená připojení se za optimální považují přímé propojení prostřednictvím kabelu nebo vyhrazené linky.

Poznámka: Pro aplikace systému Office 2010 je třeba provést oba kroky. Pro aplikace ostatních systémů Office je vyžadován pouze krok 1.

Krok 1: V klientském počítači nakonfigurujte přesměrovač WebDAV (Web Distributed Authoring and Versioning) tak, aby bylo povoleno základní ověřování prostřednictvím jiných připojení než SSL.

Poznámka: Tentok krok je vyžadován pro aplikace systému Office 2007 a Office 2010.

Důležité: Tato část, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. V případě úpravy registru nesprávným způsobem však mohou nastat závažné problémy. Proto vždy pečlivě kontrolujte, zda postupujete přesně podle těchto kroků. Jako dodatečnou ochranu registr před úpravami zazálohujte. Potom můžete v případě problému registr obnovit. Další informace o zálohování a obnovení registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
322756 Postup zálohování a obnovení registru v systému Windows

Windows XP a Windows Server 2003

Chcete-li povolit základní ověřování v klientském počítači, postupujte následovně:
  1. Klikněte na tlačítko Start, klikněte na příkaz Spustit, zadejte příkaz regedit a potom klikněte na tlačítko OK.
  2. Vyhledejte následující podklíč registru a klikněte na něj:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
  3. V nabídce Úpravy přejděte na příkaz Nový a potom klikněte na příkaz Hodnota DWORD.
  4. Zadejte text UseBasicAuth a pak stiskněte klávesu ENTER.
  5. Klikněte pravým tlačítkem na položku UseBasicAuth a potom klikněte na příkaz Změnit.
  6. Do pole Údaj hodnoty zadejte hodnotu 1 a klikněte na tlačítko OK.

    Poznámka: Základní ověřování je povoleno, je-li položka registru UseBasicAuth nastavena na nenulovou hodnotu.
    Základní ověřování je zakázáno, pokud položka registru UseBasicAuth není k dispozici nebo
    je nastavena na hodnotu 0 (nula).
  7. Ukončete program Editor registru a restartujte počítač.

Windows Vista a Windows 7

Chcete-li povolit základní ověřování v klientském počítači, postupujte následovně:
  1. Klikněte na tlačítko Start, do pole Zahájit hledání zadejte text regedit a stiskněte klávesu ENTER.
  2. Vyhledejte následující podklíč registru a klikněte na něj:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
  3. V nabídce Úpravy přejděte na příkaz Nový a potom klikněte na příkaz Hodnota DWORD.
  4. Zadejte text BasicAuthLevel a pak stiskněte klávesu ENTER.
  5. Klikněte pravým tlačítkem na položku BasicAuthLevel a pak klikněte na příkaz Změnit.
  6. Do pole Údaj hodnoty zadejte hodnotu 2 a klikněte na tlačítko OK.

    Poznámka: Mapování hodnot je následující:

    0 –- základní ověřování je zakázáno
    1 – základní ověřování je povoleno pouze pro připojení SSL
    2 – základní ověřování je povoleno pro připojení SSL i pro připojení jiného typu
  7. Ukončete program Editor registru a restartujte počítač.

Další informace o postupu při konfiguraci přesměrovače WebDAV tak, aby bylo povoleno základní ověřování, naleznete na následujícím webu společnosti Microsoft:

http://support.microsoft.com/kb/841215/cs.

Krok 2: V klientském počítači přidejte klíč registru BasicAuthLevel a příslušnou hodnotu.

Poznámka: Tentok krok je vyžadován pro aplikace systému Office 2010.


Důležité: Tato část, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. V případě úpravy registru nesprávným způsobem však mohou nastat závažné problémy. Proto vždy pečlivě kontrolujte, zda postupujete přesně podle těchto kroků. Jako dodatečnou ochranu registr před úpravami zazálohujte. Potom můžete v případě problému registr obnovit. Další informace o zálohování a obnovení registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
322756 Postup zálohování a obnovení registru v systému Windows
  1. Spusťte Editor registru.
    • V systému Windows 7 nebo Windows Vista klikněte na tlačítko Start, do pole Spustit hledání zadejte příkaz regedit a pak stiskněte klávesu ENTER. Jestliže se zobrazí výzva k zadání hesla správce nebo k potvrzení, zadejte heslo nebo potvrďte akci.
    • V systému Windows XP klikněte na tlačítko Start a na příkaz Spustit, zadejte text regedit a pak klikněte na tlačítko OK.

  2. Vyhledejte následující podklíč registru a klikněte na něj:

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet
  3. V nabídce Úpravy přejděte na příkaz Nový a potom klikněte na příkaz Hodnota DWORD.
  4. Zadejte text BasicAuthLevel a pak stiskněte klávesu ENTER.
  5. Klikněte pravým tlačítkem na položku BasicAuthLevel a pak klikněte na příkaz Změnit.
  6. Do pole Údaj hodnoty zadejte hodnotu 2 a klikněte na tlačítko OK.

    Poznámka: Mapování hodnot je následující:

    0 –- základní ověřování je zakázáno
    1 – základní ověřování je povoleno pouze pro připojení SSL
    2 – základní ověřování je povoleno pro připojení SSL i pro připojení jiného typu
  7. Ukončete program Editor registru a restartujte počítač.

Byly potíže vyřešeny?

  • Ověřte, zda jsou potíže vyřešeny. Pokud ano, v této části již pro vás nejsou žádné potřebné informace. Pokud potíže přetrvávají, můžete kontaktovat podporu.
  • Uvítáme vaše názory. Chcete-li nám sdělit svůj názor nebo nahlásit potíže s tímto řešením, uveďte poznámky v blogu Fix it for me (Automatická oprava) nebo nám odešlete e-mailovou zprávu.

Další informace

Základní ověřování je běžně používaná standardní metoda získávání informací o uživatelském jméně a hesle. Výhoda základního ověřování spočívá v tom, že je součástí specifikace HTTP a je podporováno většinou prohlížečů. Základní ověřování však vyžaduje zadání uživatelského jména a hesla. Tyto informace jsou v rámci sítě odeslány nezašifrovaně. Metoda základního ověřování se nedoporučuje, pokud si nejste jisti, že připojení mezi uživatelem a webovým serverem je zabezpečené (například pomocí protokolu SSL nebo přímého připojení). U základního ověřování je heslo v síti přenášeno jako prostý text. Pokud toto heslo v síti zachytí sledovací program, může neoprávněný uživatel zjistit uživatelské jméno a heslo a využít tato pověření. Toto bezpečnostní riziko je důvodem toho, proč je ve výchozí konfiguraci aplikací systému Office 2010 zakázáno základní ověřování prostřednictvím jiného připojení než SSL.

Další informace o základním ověřování naleznete na následujícím webu společnosti Microsoft:
Základní ověřování
Další informace o protokolu SSL a certifikátech naleznete na následujícím webu společnosti Microsoft:
Protokol SSL a certifikáty

Vlastnosti

ID článku: 2123563 - Poslední aktualizace: 1. prosince 2012 - Revize: 9.1
Klíčová slova: 
kbfixme kbmsifixme kbcip KB2123563

Dejte nám zpětnou vazbu