Файлы Office нельзя открывать напрямую с сервера, поддерживающего только обычную проверку подлинности по соединению, не использующему SSL

Код статьи: 2123563 - Список продуктов, к которым относится данная статья.
Развернуть все | Свернуть все

Проблема

Возможна следующая ситуация:

На компьютере установлены приложения Microsoft Office 2010 или Microsoft Office 2007. И с этого клиентского компьютера вы пытаетесь открыть файл Office, расположенный на веб-сервере (например, на сервере SharePoint или WebDav). При попытке открыть или загрузить файл возникают следующие симптомы.
  • Файл Office не открывается и не загружается.
  • При попытке открыть или загрузить файл не возникает запрос обычной проверки подлинности на ввод пароля.
  • При попытке открыть файл не появляется сообщение об ошибке. Соответствующее приложение Office запускается. При этом выбранный файл не открывается.

Причина

На сервере настроена обычная проверка подлинности. Соединение между вашим компьютером и веб-серверов не защищено протоколом SSL.

По умолчанию операции с файлами, использующие обычную проверку подлинности и HTTP-соединение без SSL, в приложениях Office 2010 отключены. Если обычная проверка подлинности отключена, происходит одно из следующих событий.
  • Клиентское приложение использует другой способ проверки подлинности. (Это происходит, если сервер поддерживает такие способы.)
  • Запрос завершается сбоем. (В разделе "Симптомы" перечислены признаки сбоя запроса.)

Решение

Чтобы устранить проблему, администратор сервера должен включить на веб-сервере шифрование SSL (это — рекомендуемый способ). По умолчанию приложения Office 2010 могут открывать и загружать файлы с веб-сервера только по протоколу SSL, если на нем используется обычная проверка подлинности.


Временное решение

Чтобы обойти эту проблему, разрешите приложениям Office 2010 подключаться к веб-серверам, использующим обычную проверку подлинности без SSL.

Внимание!Включение обычной проверки подлинности без SSL может представлять серьезную угрозу безопасности.

Так как учетные данные пользователей не шифруются при передаче по сети, а передаются в виде обычного текста, использовать обычную проверку подлинности для незащищенных HTTP-соединений не рекомендуется. Дополнительные сведения см. в разделе "Дополнительные сведения". При использовании обычной проверки подлинности на сервере всегда рекомендуется использовать шифрование SSL.


Если для решения проблемы требуется помощь, перейдите к разделу "Помощь в решении проблемы". Чтобы устранить проблему самостоятельно, перейдите к разделу Самостоятельное решение проблемы.

Помощь в решении проблемы



Чтобы устранить проблему автоматически, щелкните ссылку или нажмите кнопку Устранить проблему. Затем в диалоговом окне Загрузка файла нажмите кнопку Выполнить и следуйте инструкциям мастера Fix it.


Fix this problem
Microsoft Fix it 50711


Примечания
  • Мастер может быть доступен только на английском языке. Однако средство автоматического устранения неполадок можно использовать в версиях Windows на любых языках.
  • Решение Fix it можно загрузить на любой компьютер, а затем сохранить на устройстве флэш-памяти или компакт-диске и запустить на нужном компьютере.

Перейдите к разделу Проблема устранена?



Самостоятельное решение проблемы

Далее описано два действия, позволяющих разрешить приложениям Office 2010 напрямую открывать файлы Office с сервера, поддерживающего только обычную проверку подлинности без SSL. Эти действия следует выполнять только в случае, если вы уверены в надежности соединения между пользователем и веб-сервером. Оптимальной с точки зрения безопасности ситуацией будет прямое кабельное подключение или выделенная линия.

Примечание. В приложениях Office 2010 следует выполнить оба действия. В других приложениях Office необходимо только первое действие.

Действие 1. На клиентском компьютере настройте перенаправитель WebDAV, включив обычную проверку подлинности для подключений, не использующих SSL.

Примечание. Это действие необходимо для приложений Office 2007 и Office 2010.

Внимание! В этот раздел, описание метода или задачи включены действия, содержащие указания по изменению параметров реестра. Их неправильное изменение может привести к возникновению серьезных проблем, поэтому следует строго соблюдать инструкции. Чтобы обеспечить дополнительную защиту, создайте резервную копию реестра. Это позволит восстановить реестр при возникновении неполадок. Дополнительные сведения о создании резервной копии и восстановлении реестра см. в следующей статье базы знаний Майкрософт:
322756 Создание резервной копии и восстановление реестра Windows XP

Windows XP и Windows Server 2003

Для включения обычной проверки подлинности выполните следующие действия.
  1. Откройте меню Пуск, выберите пункт Выполнить, введите команду regedit и нажмите кнопку ОК.
  2. Найдите и выделите приведенный ниже раздел реестра.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
  3. В меню Правка выберите пункт Создать, а затем — Параметр DWORD.
  4. Введите UseBasicAuth и нажмите клавишу ВВОД.
  5. Щелкните правой кнопкой мыши раздел UseBasicAuth и выберите команду Изменить.
  6. В поле Значение введите 1, а затем нажмите кнопку ОК.

    Примечание. Если параметр реестра UseBasicAuth имеет ненулевое значение, обычная проверка подлинности включена.
    Если параметр UseBasicAuth отсутствует или равен нулю, обычная проверка подлинности
    отключена.
  7. Закройте редактор реестра и перезагрузите компьютер.

Windows Vista и Windows 7

Для включения обычной проверки подлинности выполните следующие действия.
  1. Нажмите кнопку Пуск, введите regedit в поле поиска в меню "Пуск" и нажмите клавишу ВВОД.
  2. Найдите и выделите приведенный ниже раздел реестра.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
  3. В меню Правка выберите пункт Создать, а затем — Параметр DWORD.
  4. Введите BasicAuthLevel и нажмите клавишу ВВОД.
  5. Щелкните правой кнопкой мыши раздел BasicAuthLevel и выберите команду Изменить.
  6. В поле Значение введите 2, а затем нажмите кнопку ОК.

    Примечание. Сопоставление следующее:

    0 — обычная проверка подлинности отключена;
    1 — обычная проверка подлинности включена только для соединений по SSL;
    2 — обычная проверка подлинности включена для любых соединений.
  7. Закройте редактор реестра и перезагрузите компьютер.

Дополнительные сведения о включении обычной проверки подлинности в перенаправителе WebDAV см. на следующем веб-сайте Майкрософт:

http://support.microsoft.com/kb/841215/ru.

Действие 2. Добавьте на клиентском компьютере параметр реестра BasicAuthLevel с подходящим значением.

Примечание. Это действие необходимо для приложений Office 2010.


Внимание! В этот раздел, описание метода или задачи включены действия, содержащие указания по изменению параметров реестра. Их неправильное изменение может привести к возникновению серьезных проблем, поэтому следует строго соблюдать инструкции. Чтобы обеспечить дополнительную защиту, создайте резервную копию реестра. Это позволит восстановить реестр при возникновении неполадок. Дополнительные сведения о создании резервной копии и восстановлении реестра см. в следующей статье базы знаний Майкрософт:
322756 Создание резервной копии и восстановление реестра Windows XP
  1. Откройте редактор реестра.
    • В Windows 7 или Windows Vista нажмите кнопку "Пуск", введите в поле поиска в меню "Пуск" команду regedit и нажмите клавишу ВВОД. При получении запроса на ввод пароля администратора или подтверждения введите пароль или подтвердите действие.
    • В системе Windows XP выберите в меню Пуск пункт Выполнить, введите команду regedit и нажмите кнопку ОК.

  2. Найдите и выделите приведенный ниже раздел реестра.

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet
  3. В меню Правка выберите пункт Создать, а затем — Параметр DWORD.
  4. Введите BasicAuthLevel и нажмите клавишу ВВОД.
  5. Щелкните правой кнопкой мыши раздел BasicAuthLevel и выберите команду Изменить.
  6. В поле Значение введите 2, а затем нажмите кнопку ОК.

    Примечание. Сопоставление следующее:

    0 — обычная проверка подлинности отключена;
    1 — обычная проверка подлинности включена только для соединений по SSL;
    2 — обычная проверка подлинности включена для любых соединений.
  7. Закройте редактор реестра и перезагрузите компьютер.

Проблема устранена?

  • Проверьте, устранена ли проблема. Если это так, данный раздел можно дальше не читать. Если проблему устранить не удалось, обратитесь в службу поддержки.
  • Мы ценим ваши замечания. Чтобы оставить отзыв или сообщить о проблемах, связанных с этим решением, добавьте комментарий в блог Помощь в решении проблемы или отправьте нам сообщение по электронной почте.

Дополнительная информация

Обычная проверка подлинности — это широко используемый в отрасли метод получения имени пользователя и пароля. Ее преимущество состоит в том, что она входит в спецификацию HTTP и поддерживается большинством браузеров. При этом в ходе такой проверки у пользователя запрашивается имя и пароль. Затем эти данные отправляются по сети без шифрования. Обычную проверку подлинности не следует использовать, если вы не уверены в надежности соединения между пользователем и веб-сервером (например, благодаря использованию SSL или прямого соединения). При обычной проверке подлинности пароль отправляется по сети в обычном тексте. Если анализатор сетевых пакетов перехватит пароль, пользователь-злоумышленник сможет воспользоваться перехваченными учетными данными. Именно поэтому в конфигурации приложений Office 2010 по умолчанию обычная проверка подлинности без SSL отключена.

Дополнительные сведения об обычной проверке подлинности см. на следующем веб-сайте Майкрософт:
Обычная проверка подлинности
Дополнительные сведения об SSL и сертификатах см. на следующем веб-сайте Майкрософт:
SSL и сертификаты

Свойства

Код статьи: 2123563 - Последнее изменение :: 30 ноября 2012 г. - Редакция: 11.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Office Standard 2010
  • Microsoft Office Professional 2010
  • Microsoft Office Professional Plus 2010
  • 2007 Microsoft Office Suite Service Pack 1
  • 2007 Microsoft Office Suite Service Pack 2
Ключевые слова: 
kbfixme kbmsifixme kbcip KB2123563

Отправить отзыв