WD2000: Como inserir uma legenda com alinhamento à direita seguinte para um editor de equações

Traduções de Artigos Traduções de Artigos
Artigo: 212381 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sumário

O Microsoft Word não oferece um método incorporado para automaticamente inserir uma legenda é alinhado à direita da margem direita de um documento. Vários diários científicos requerem objectos de equação para ter um dos seguintes formatos:
  • A equação e a legenda são alinhados à direita

                                            y = mx + b ( 1 )
    						
    - ou -
  • A equação é centrada e a legenda é alinhado à direita,

                          y = mx + b                   ( 1 )
    						
    - ou -
  • A equação é alinhado à esquerda e a legenda é alinhado à direita.

     y = mx + b                                        ( 1 )
    						
Em qualquer dos casos, o número de legenda entre parênteses e alinhado à direita.

Este artigo descreve vários métodos que pode utilizar para formatar objectos de equação destes estilos.

Nota : Este artigo utiliza o termo equação , mas pode utilizar este método para qualquer objecto (como uma figura ou imagem) em que a legenda precisa aparecem na mesma linha que o objecto.

Mais Informação

Siga estes passos para criar uma legenda, conforme descrito na secção "Sumário" deste artigo:

Passo 1: Configurar a legenda

Para criar o rótulo de legenda com os parênteses, siga estes passos:
  1. No Microsoft Word, no menu Inserir , clique em legenda .
  2. Clique em novo nome .
  3. Na caixa nome , introduza um parêntese.
  4. Clique em OK .
  5. Na caixa legenda à direita do número, escreva um espaço e, em seguida, escreva um parêntese de fecho.
  6. Clique em OK .
Depois de criar o formato de legenda, pode inserir legendas adicionais. Para inserir legendas adicionais, siga estes passos:
  1. No menu Inserir , clique em ' legenda '.
  2. Altere a caixa nome para o parêntese de abertura.
  3. Na caixa legenda à direita da legenda existente, escreva um espaço e, em seguida, escreva um parêntese de fecho.
  4. Clique em OK .

Passo 2: Alinhar o Editor de equações e a legenda

Nota : Se tenciona fazer referências cruzadas a legenda, utilizar o método 2, o método 3 ou método 4.

Método 1: Como definir um editor de equações alinhado à direita e número de legenda

  1. No menu Inserir , clique em ' legenda '.
  2. Na lista nome , seleccione os parênteses abertos. Na caixa legenda , introduza um espaço, escreva um parêntese de fecho e, em seguida, clique em OK .
  3. No documento do Word, mova o ponto de inserção para o início da linha, antes da legenda.
  4. Definido para uma tabulação alinhada à direita da margem direita. Por exemplo, se a margem direita seis polegadas da margem esquerda, defina o separador alinhado à direita em seis polegadas efectuando o seguinte procedimento:
    1. No menu Formatar , clique em separadores .
    2. Na caixa de marca de tabulação , escreva 6 .
    3. Em Alinhamento , clique em para a direita e, em seguida, clique em OK .
  5. Prima a tecla TAB para mover a legenda para a extremidade direita da página.
  6. Inserir a equação no documento.

Método 2: Como definir um editor de equações com alinhamento à esquerda

  1. Numa linha de nova em branco, inserir a equação.
  2. Saia Editor de equações clicando em qualquer ponto na área de documentos.
  3. Prima a tecla TAB e, em seguida, insira a legenda.
  4. Seleccione a linha inteira que contém a equação e a legenda. No menu tabela , clique em Converter texto em tabela . A selecção é convertida para uma tabela de duas colunas.
  5. Remova o limite à volta da tabela, efectuando o seguinte procedimento:
    1. Mova o ponto de inserção em qualquer célula da tabela. No menu tabela , aponte para Seleccionar e, em seguida, clique em tabela .
    2. No menu Formatar , clique em limites e sombreado .
    3. Em definições , clique em nenhum .
    4. Clique em OK .
  6. Seleccione a célula de tabela que contém a legenda e, em seguida, clique no botão Alinhar à direita na barra de ferramentas formatação .

Método 3: Como definir um editor de equações Centro de alinhamento

  1. Numa linha de nova em branco, prima a tecla TAB e, em seguida, inserir a equação.
  2. Saia Editor de equações clicando em qualquer ponto na área de documentos.
  3. Prima a tecla TAB e, em seguida, insira a legenda.
  4. Seleccione a linha inteira que contém a equação e a legenda. No menu tabela , clique em Converter texto em tabela . A selecção é convertida para uma tabela com três colunas.
  5. Remova o limite à volta da tabela, efectuando o seguinte procedimento:
    1. Mova o ponto de inserção em qualquer célula da tabela. No menu tabela , aponte para Seleccionar e clique em tabela .
    2. No menu Formatar , clique em limites e sombreado .
    3. Em definições , clique em nenhum .
    4. Clique em OK .
  6. Seleccione a célula de tabela que contém a equação e, clique no botão Centro na barra de ferramentas formatação .
  7. Seleccione a célula de tabela que contém a legenda e, clique no botão Alinhar à direita na barra de ferramentas formatação .

Método 4: Como criar do Microsoft Visual Basic para aplicações macro

Microsoft fornece exemplos de programação ilustração só, sem garantia expressa ou implícita, incluindo, sem limitação, garantias implícitas de comercialização e/ou adequação a um fim específico. Este artigo pressupõe que está familiarizado com a linguagem de programação apresentada e as ferramentas utilizadas para criar e depurar procedimentos. Profissionais de suporte da Microsoft podem ajudar a explicar a funcionalidade de um determinado procedimento, mas não modificarão estes exemplos para proporcionarem funcionalidades adicionais nem criarão procedimentos adaptados às necessidades específicas.
Se dispõe de limitada experiência de programação, poderá contactar um Microsoft Certified Partner ou a serviços de aviso. Para obter mais informações, visite estes Web sites da Microsoft:

Microsoft certificado Partner - https://partner.microsoft.com/global/30000104

Serviços Microsoft aviso - http://support.microsoft.com/gp/advisoryservice

Para obter mais informações sobre as opções de suporte estão disponíveis e sobre como contactar a Microsoft, visite o seguinte Web site da Microsoft: http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS
Para mais informações sobre como utilizar o código de exemplo neste artigo, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
212536OFF2000: Como executar códigos de exemplo a partir de artigos da base de dados de conhecimento da Microsoft
Crie uma macro que lhe permitirá seleccionar entre alinhado à esquerda ou alinhado ao centro conforme descrito no método 2 e método 3. Depois de executar esta macro, inserir a equação na localização apropriada.

Sub CaptionRight()

   Dim Align As Integer
   On Error GoTo Bye

   ' If insertion point is in a table, show message and end macro.
   If Selection.Information(wdWithInTable) Then
      MsgBox "You are in a table. Please move outside of the " _
         & "table to run this macro.", vbInformation
      GoTo Bye
   End If

   ' Ask whether to center or left align equation.
   Align = MsgBox("Would you like the Equation to be " & "centered? " _
      & "(Selecting No will left-align the " & "Equation.)", vbYesNoCancel)

   If Align > 2 Then
      Selection.InsertParagraphAfter
      Selection.Collapse Direction:=wdCollapseEnd
      W = ActiveDocument.PageSetup.PageWidth
      L = ActiveDocument.PageSetup.LeftMargin
      R = ActiveDocument.PageSetup.RightMargin
      RTMarg = W - R - L
      CaptionLabels.Add Name:="("

      If Align = 6 Then
         tblT1 = Selection.Tables.Add(Selection.Range, 1, 3)
      Else
         tblT1 = Selection.Tables.Add(Selection.Range, 1, 2)
      End If

      tblT1.Select

      With Selection
         ' Do this if Center-align selected.
         If Align = 6 Then
            .Columns(1).Cells.Width = 50.4
            .Columns(3).Cells.Width = 50.4
            .Columns(2).Cells.Width = RTMarg - 100.8

            'Represents 1.5" in Points
         Else
         ' Do this if Left-align selected.
            .Columns(2).Cells.Width = 50.4
            .Columns(1).Cells.Width = RTMarg - 50.4
            'Represents .75" in Points
         End If

         .InsertCaption Label:="(", _
            Position:=wdCaptionPositionBelow, Title:=" )"
         .HomeKey unit:=wdLine, Extend:=wdExtend
         .Cut
         .MoveRight unit:=wdCharacter, Extend:=wdExtend
         .Delete
         .MoveLeft unit:=wdCharacter, Count:=2
         .Paste
         .Rows(1).Select

        ' Set the table borders to None.
         For Each x In Selection.Borders
            x.LineStyle = wdLineStyleNone
         Next x

         .Borders.Shadow = False
         .Cells(9 - Align).Select
         .ParagraphFormat.Alignment = wdAlignParagraphRight
         .Cells(1).VerticalAlignment = wdCellAlignVerticalCenter
         .Font.Bold = True
         .Rows(1).Select

         If Align = 6 Then
            .Cells(2).Select
            .ParagraphFormat.Alignment = wdAlignParagraphCenter
            .InlineShapes.AddOLEObject ClassType:="Equation.3", _
               FileName:="", LinkToFile:=True, DisplayAsIcon:=False
         Else
            .Collapse
            .InlineShapes.AddOLEObject ClassType:="Equation.3", _
               FileName:="", LinkToFile:=True, DisplayAsIcon:=False
         End If
      End With
   End If

Bye:

End Sub
				
Existem vários métodos para inserir legendas. Legenda automática insere uma legenda acima ou abaixo de um objecto incorporado; inseridas manualmente as legendas são colocadas acima ou abaixo do objecto quando o objecto é seleccionado ou à direita imediata quando o ponto de inserção está à direita do objecto.

Referências

Para obter informações adicionais, clique nos números de artigo existentes abaixo para visualizar os artigos na Microsoft Knowledge Base:
212623WD2000: Recursos de programação de macro
226118OFF2000: Recursos de programação do Visual Basic for Applications

Propriedades

Artigo: 212381 - Última revisão: 23 de novembro de 2006 - Revisão: 1.3
A informação contida neste artigo aplica-se a:
  • Microsoft Word 2000 Standard Edition
Palavras-chave: 
kbmt kbdtacode kbfield kbhowto kbinfo kblayout kbusage KB212381 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 212381

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com