WD2000: Jak vytvořit a zobrazit vlastní dialogové

Překlady článku Překlady článku
ID článku: 212596 - Produkty, které se vztahují k tomuto článku.
Tento článek byl archivován. Je nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

Tento článek obsahuje podrobné pokyny pro vytváření a zobrazení jazyka pro vlastní dialogovém aplikace (User Form).

Další informace

Společnost Microsoft poskytuje ukázky programování pouze pro ilustraci, bez žádné záruky výslovně uvedené nebo odvozené,. včetně, bez omezení, odvozených záruk vztahujících se k obchodovatelnosti nebo vhodnosti pro určitý účel. Tento článek předpokládá, že uživatel je obeznámen s programovacím jazykem, který je předmětem ukázky, a s nástroji použitými pro vytvoření a ladění skriptu. Pracovníci technické podpory společnosti Microsoft mohou vysvětlit funkce určitého postupu, nemohou však následující příklady rozšířit o další funkce nebo konstrukce podle konkrétních požadavků uživatele.

Vytváření formuláře uživatele

Následující ukázka vytvoří formulář uživatele s ovládací prvky TextBox a dva prvky CommandButton (tlačítko "OK" a "Storno" tlačítko).

Vytvoření formuláře pomocí následujících kroků:
  1. V nabídce Nástroje přejděte na příkaz makro a potom klepněte na příkaz Editor jazyka.
  2. V okně projektu jazyka klepněte na možnost Normální.

    Klepnutím na Normální zpřístupníte formuláře pro všechny dokumenty. Chcete-li vytvořit formulář uživatele vlastní šablonu, zkontrolujte, zda je aktuálně otevřena šablona a vyberte název šablony projektu namísto Normální. Například pokud "Moje šablona" je název vlastní šablonu, v okně projektu jazyka vyberte TemplateProject(My Template). Formulář uživatel k dispozici pouze při vlastní šablona je otevřené, jako doplněk k dispozici nebo připojena k otevření dokumentu.
  3. V nabídce Vložit klepněte na tlačítko UserForm.
  4. Klepněte na panelu nástrojů Ovládací prvky TextBox a klepněte na formulář.

    Ovládací prvek TextBox se zobrazí v výchozí velikost. Přetáhněte úchyt tak, aby velikost ovládacího prvku nebo přetáhněte ovládací prvek přesunout do nového umístění.
  5. Klepněte na ovládací prvek CommandButton na panelu nástrojů a potom klepněte na formulář.

    Ovládací prvek CommandButton se zobrazí v výchozí velikost. Přetáhněte úchyt tak, aby velikost ovládacího prvku nebo přetáhněte ovládací prvek přesunout do nového umístění.

    Opakujte tento krok přidat druhý ovládací prvek CommandButton.
  6. Vyberte první ovládací prvek CommandButton a v nabídce Zobrazit klepněte na Kód.
  7. V okně Kód zadejte Selection.TypeText TextBox1.Text, aby váš kód vypadá takto:
    Private Sub CommandButton1_Click ()
       Selection.TypeText TextBox1.Text
    End sub
    						
    Poznámka: Po klepnutí na toto tlačítko na formuláři obsah textového pole vložili do aktivního dokumentu na místě kurzoru.
  8. V nabídce Zobrazit klepněte na tlačítko Object vrátit do formuláře.
  9. Vyberte druhý ovládací prvek CommandButton a v nabídce Zobrazit klepněte na Kód.
  10. V okně Kód zadejte Konec, aby váš kód vypadá takto:
    Private Sub CommandButton2_Click ()
       End
    End sub
    						
    při na toto tlačítko po klepnutí na první tlačítko příkazu, zavření formuláře. Pokud klepnutím na toto tlačítko namísto první příkazové tlačítko ve formuláři zrušena.
  11. V nabídce soubor klepněte na příkaz Uložit normálně.

Zobrazení formuláře

Zobrazit formuláře, přepněte do aplikace Word a potom proveďte následující:
  1. V nabídce Nástroje přejděte na příkaz makro a potom klepněte na příkaz makra.
  2. V seznamu Název makra zadejte FillInForm a potom klepněte na tlačítko vytvořit.
  3. V okně Kód zadejte UserForm1.Show, aby váš kód vypadá takto:
    Sub FillInForm()
       UserForm1.Show
    End Sub
    						
  4. V nabídce soubor klepněte na příkaz Uložit normálně.
  5. V nabídce soubor klepněte na tlačítko Zavřít a návrat do aplikace Word. Spuštěním makra FillinForm nyní můžete spustit makro z aplikace Word zobrazit formulář.
Pokud chcete výchozí text se zobrazí v poli text vytvořit událost "Inicializace" UserForm objekt. Postup je následující:
  1. V editoru jazyka poklepejte na formulář.
  2. Ze seznamu objektů vyberte UserForm.
  3. Ze seznamu procedur vyberte inicializovat.
  4. V okně Kód zadejte následující kód:
    Private Sub UserForm_Initialize()
       TextBox1.Text = "<default text>"
    End Sub
    						
    kde < výchozí text > je text, který se zobrazí textové pole, která se zobrazí ve formuláři.
Další informace o uživatelských formulářů v editoru jazyka klepněte v nabídce Nápověda pro Microsoft Visual Basic zadejte UserForm v Pomocníkovi Office nebo průvodce a klepněte na tlačítko Hledat zobrazíte příslušné téma.
Další informace o způsobu použití ukázkového kódu v tomto článku naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
212536OFF2000: Jak spustit ukázkový kód z článků znalostní báze

Odkazy

Další informace o získání nápovědy s jazyka pro aplikace naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
226118OFF2000: Programové prostředky pro Visual Basic pro aplikace

Vlastnosti

ID článku: 212596 - Poslední aktualizace: 28. února 2014 - Revize: 3.2
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Word 2000 Standard Edition
Klíčová slova: 
kbnosurvey kbarchive kbmt kbdtacode kbinfo kbprogramming KB212596 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:212596

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com