Identificativo articolo: 213367 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

In questo articolo vengono descritti due metodi che è possibile utilizzare per confrontare dati in due colonne del foglio di lavoro di Microsoft Excel e ricerca delle voci duplicate.

Informazioni

Metodo 1: utilizzare una formula del foglio di lavoro

Utilizzare una formula del foglio di lavoro per confrontare i dati in due colonne, attenersi alla seguente procedura:
  1. Avviare Excel.
  2. In un nuovo foglio di lavoro immettere i seguenti dati (colonna di congedo B vuota):
    A1: 1   B1:     C1: 3
    A2: 2   B2:     C2: 5
    A3: 3   B3:     C3: 8
    A4: 4   B4:     C4: 2
    A5: 5   B5:     C5: 0
    					
  3. Digitare la seguente formula nella cella B1:
    =IF(ISERROR(MATCH(A1,$C$1:$C$5,0)),"",A1)
  4. Selezionare le celle B1: B5.
  5. In Microsoft Office Excel 2003 e nelle versioni precedenti di Excel, scegliere Riempimento su Verrà visualizzata la finestra di dialogo Modifica menu, quindi fare clic su Verso il basso.

    In Microsoft Office Excel 2007 ed Excel 2010, fare clic suRiempimento nelModifica gruppo e quindi fare clic su Verso il basso.

    I numeri duplicati vengono visualizzati nella colonna B, come illustrato nell'esempio riportato di seguito:
       A1: 1   B1:     C1: 3
       A2: 2   B2: 2   C2: 5
       A3: 3   B3: 3   C3: 8
       A4: 4   B4:     C4: 2
       A5: 5   B5: 5   C5: 0
    					

Metodo 2: utilizzare una macro di Visual Basic

Microsoft fornisce esempi di programmazione puramente a scopo illustrativo, senza alcuna garanzia espressa o esplicita. Questo include, ma non è limitato a, le garanzie implicite di commerciabilità o idoneità per uno scopo particolare. In questo articolo si presuppone che si abbia familiarità con il linguaggio di programmazione in questione e con gli strumenti utilizzati per creare ed eseguire il debug di procedure. I tecnici del supporto tecnico Microsoft possono spiegare la funzionalità di una particolare procedura. Tuttavia, essi non modificheranno questi esempi per fornire funzionalità aggiuntive o creare procedure atte a soddisfare specifiche esigenze. Utilizzare una macro di Visual Basic per confrontare i dati in due colonne, utilizzare la procedura descritta nell'esempio riportato di seguito:
  1. Avviare Excel.
  2. Premere ALT + F11 per avviare l'editor di Visual Basic.
  3. Nel Inserisci menu, fare clic su Modulo.
  4. Immettere il codice seguente in un foglio modulo:
    Sub Find_Matches()
        Dim CompareRange As Variant, x As Variant, y As Variant
        ' Set CompareRange equal to the range to which you will
        ' compare the selection.
        Set CompareRange = Range("C1:C5")
        ' NOTE: If the compare range is located on another workbook
        ' or worksheet, use the following syntax.
        ' Set CompareRange = Workbooks("Book2"). _
        '   Worksheets("Sheet2").Range("C1:C5")
        '
        ' Loop through each cell in the selection and compare it to
        ' each cell in CompareRange.
        For Each x In Selection
            For Each y In CompareRange
                If x = y Then x.Offset(0, 1) = x
            Next y
        Next x
    End Sub
    					
  5. Premere ALT + F11 per tornare a Excel.
  6. Immettere i seguenti dati (lasciare vuota la colonna B):
    A1: 1   B1:     C1: 3
    A2: 2   B2:     C2: 5
    A3: 3   B3:     C3: 8
    A4: 4   B4:     C4: 2
    A5: 5   B5:     C5: 0
    					
  7. Selezionare l'intervallo A1:A5.
  8. In Excel 2003 e nelle versioni precedenti di Excel, scegliere Macro su Verrà visualizzata la finestra di dialogo Strumenti menu, quindi fare clic su Macro.

    In Excel 2007 ed Excel 2010, scegliere ilSviluppatori scheda e quindi fare clic suMacro nel Codice gruppo.
  9. Fare clic Find_Matches, quindi fare clic su Eseguire.
I numeri duplicati vengono visualizzati nella colonna B. La corrispondenza i numeri verranno inseriti accanto alla prima colonna, come illustrato di seguito:
   A1: 1   B1:     C1: 3
   A2: 2   B2: 2   C2: 5
   A3: 3   B3: 3   C3: 8
   A4: 4   B4:     C4: 2
   A5: 5   B5: 5   C5: 0
				

Proprietà

Identificativo articolo: 213367 - Ultima modifica: lunedì 20 maggio 2013 - Revisione: 14.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Excel 2010
  • Microsoft Office Excel 2007
  • Microsoft Office Excel 2003
Chiavi: 
kbdtacode kbhowto kbprogramming kbmt KB213367 KbMtit
Traduzione automatica articoli
IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l?obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 213367
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com