Jak programově kopírovat všechny názvy oblastí v aplikaci Excel

Překlady článku Překlady článku
ID článku: 213389 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Souhrn

V Office Excel můžete vytvořit pro makro (VBA) můžete zkopírovat všechny názvy oblast z aktivního sešitu do jiného sešitu Microsoft Visual Basic.

Další informace

Společnost Microsoft poskytuje ukázky programování pouze pro ilustraci, bez žádné záruky výslovně uvedené nebo odvozené,. včetně, bez omezení, odvozených záruk vztahujících se k obchodovatelnosti nebo vhodnosti pro určitý účel. Tento článek předpokládá, že uživatel je obeznámen s programovacím jazykem, který je předmětem ukázky, a s nástroji použitými pro vytvoření a ladění skriptu. Pracovníci technické podpory společnosti Microsoft mohou vysvětlit funkce určité procedury,. nemohou však následující příklady rozšířit o další funkce nebo vytvářet procedury podle konkrétních požadavků uživatele.

Vytvoření a použití makra zkopírovat všechny názvy oblast z aktivního sešitu do jiného sešitu, použijte postup v následujícím příkladu:
  1. Spusťte aplikaci Excel a v novém sešitu klepněte na tlačítko vyberte buňky A1.
  2. Proveďte některou z následujících akcí:
    • V aplikaci Microsoft Office Excel 2007 klepněte na kartu vzorce a potom klepněte na tlačítko Definovat název ve skupině Definované názvy.
    • V dřívějších verzích aplikace Microsoft Excel a Microsoft Office Excel 2003 v přejděte na příkaz název v nabídce Vložit a potom klepněte na tlačítko definovat.
  3. V dialogovém okně Definovat jména v poli názvy v sešitu zadejte Oblast1 a potom klepněte na tlačítko OK.
  4. Vyberte buňky B1.
  5. Proveďte některou z následujících akcí:
    • V aplikaci Excel 2007 klepněte na kartu vzorce a potom klepněte na tlačítko Definovat název ve skupině Definované názvy.
    • V aplikaci Excel 2003 a starších verzích aplikace Excel přejděte na příkaz název v nabídce Vložit a potom klepněte na tlačítko definovat.
  6. V dialogovém okně Definovat jména v poli názvy v sešitu zadejte Range2 a potom klepněte na tlačítko OK.
  7. Stisknutím kombinace kláves ALT+F11 spusťte aplikaci Visual Basic Editor.
  8. V nabídce Vložit klepněte na modul.
  9. Na listu modulu zadejte následující kód:
    Sub Copy_All_Defined_Names()
       ' Loop through all of the defined names in the active
       ' workbook.
         For Each x In ActiveWorkbook.Names
          ' Add each defined name from the active workbook to
          ' the target workbook ("Book2.xls" or "Book2.xlsm").
          ' "x.value" refers to the cell references the
          ' defined name points to.
          Workbooks("Book2.xls").Names.Add Name:=x.Name, _
             RefersTo:=x.Value
       Next x
    End Sub
  10. Stisknutím kombinace kláves ALT+F11 se vraťte zpět do aplikace Excel.
  11. Proveďte některou z následujících akcí:
    • V aplikaci Excel 2007 klepněte na Tlačítko Office, přejděte na příkaz Uložit jako, klepněte na příkaz Excel Macro-Enabled sešitu a sešit uložit jako Book1.xlsm.
    • V aplikaci Excel 2003 a starších verzích aplikace Excel v nabídce soubor klepněte na tlačítko Uložit a potom sešit uložit jako Sešit1.xls.
  12. Proveďte některou z následujících akcí:
    • V aplikaci Excel 2007 klepněte na Tlačítko Office, klepněte na příkaz Nový, klepněte na Prázdný sešit a potom klepněte na tlačítko vytvořit.
    • V aplikaci Excel 2003 v nabídce soubor klepněte na příkaz Nový a klepněte na tlačítko prázdný sešit v podokno úloh New Workbook.
    • V aplikaci Excel 2002 a dřívějších verzích aplikace Excel klepněte v nabídce soubor na příkaz Nový, klepněte na sešit a klepněte na tlačítko OK.
  13. Proveďte některou z následujících akcí:
    • V aplikaci Excel 2007 klepněte na Tlačítko Office, přejděte na příkaz Uložit jako, klepněte na příkaz Excel Macro-Enabled sešitu a sešit uložit jako Book2.xlsm.
    • V aplikaci Excel 2003 a starších verzích aplikace Excel klepněte v nabídce soubor na příkaz Uložit jako a uložte sešit jako Book2.xls.
  14. Přepnout Sešit1.

    Poznámka: Pravděpodobně Minimalizace nebo obnovení Book2 naleznete Sešit1 tlačítko.
  15. Proveďte některou z následujících akcí:
    • V aplikaci Excel 2007 klepněte na kartu Vývojář a potom klepněte na příkaz makra.

      Poznámka: Pokud není karta Vývojář zobrazen, klepněte na Tlačítko Office, klepněte na tlačítko Možnosti aplikace Excel, klepněte na položku Oblíbené, klepnutím zaškrtněte políčko Zobrazit kartu Vývojář na pásu a potom klepněte na tlačítko OK.
    • V aplikaci Excel 2003 a dřívějších verzích aplikace Excel přejděte v nabídce Nástroje na příkaz makro a potom klepněte na příkaz makra.
  16. V seznamu název makraCopy_All_Defined_Names klepněte a potom klepněte na příkaz Spustit.
  17. Přepněte Book2 a Poznámka názvem oblast1 buňku A1 a buňka B1 názvem Range2.

Vlastnosti

ID článku: 213389 - Poslední aktualizace: 21. března 2007 - Revize: 5.1
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Office Excel 2007
  • Microsoft Office Excel 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
Klíčová slova: 
kbmt kbmacro kbautomation kbvba kbexpertisebeginner kbdtacode kbhowto kbprogramming kbualink97 KB213389 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:213389

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com