XL2000: Jak spouštět makra WordBasic z makro Microsoft Excel

Překlady článku Překlady článku
ID článku: 213430 - Produkty, které se vztahují k tomuto článku.
Tento článek byl archivován. Je nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

V aplikaci Excel 2000 můžete vytvořit pomocí programu Visual Basic for Applications makro, které používá Dynamic Data Exchange (DDE) nebo automatizaci s aplikací Word 2000 spustit makra WordBasic. Tento článek demonstruje tyto metody pro spuštění makra WordBasic z aplikace Excel.

Další informace

Ukázky programů jsou společností Microsoft poskytovány pouze pro ilustraci bez žádné záruky výslovně uvedené ani předpokládané, včetně předpokládaných záruk vztahujících se k obchodovatelnosti nebo vhodnosti pro určitý účel. Tento článek předpokládá, že uživatel je obeznámen s programovacím jazykem, který je předmětem ukázky, a s nástroji použitými pro vytvoření a ladění skriptu. Pracovníci technické podpory společnosti Microsoft mohou vysvětlit funkce určitého postupu, nemohou však následující příklady rozšířit o další funkce nebo konstrukce podle konkrétních požadavků uživatele.
Pokud máte zkušenosti s programováním omezený, můžete kontaktovat partnera s certifikátem Microsoft nebo služby Advisory. Na další informace těchto webech společnosti Microsoft:

Microsoft Certified Partner - https://partner.microsoft.com/global/30000104

Služba Microsoft zpravodaje - http://support.microsoft.com/gp/advisoryservice

Další informace o možnostech podpory, které jsou k dispozici a o možnostech kontaktování společnosti Microsoft na následujícím webu společnosti Microsoft: http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

Dynamic Data Exchange metoda

  1. Spustit Microsoft Word 2000 a potom stiskněte klávesu ALT + 11 spusťte Editor jazyka.
  2. V nabídce Vložit klepněte na modul.
  3. V novém listu modulu zadejte následující makro:
    Sub macro1()
       MsgBox "Word macro"
    End Sub
    					
  4. Stiskněte ALT + F11 se vraťte do aplikace Word 2000.
  5. V nabídce soubor klepněte na příkaz Uložit jako a uložte dokument jako C:\Wordtest.doc.
  6. Spustit Excel 2000 a potom stiskněte klávesu ALT + F11 spusťte Editor jazyka.
  7. V nabídce Vložit klepněte na modul.
  8. V novém listu modulu zadejte následující makro:
    Sub RunWordMacro_DDE()
    Dim chan
    
       ' Initiate a channel with Microsoft Word.
       chan = DDEInitiate("Winword", "System")
    
       ' Execute a command on the channel to run the Wordbasic macro.
       DDEExecute chan, "[Toolsmacro.name=""Macro1"",.Run]"
    
       ' Terminate the channel.
       DDETerminate chan
    
    End Sub
    					
  9. Stisknutím kombinace kláves ALT+F11 se vraťte zpět do aplikace Excel.
  10. Stiskněte ALT + F8 otevřete dialogové okno makro.
  11. RunWordMacro_DDE klepněte v seznamu název makra a potom klepněte na příkaz Spustit.
Makro spustí aplikaci Word 2000 a zobrazí se zpráva "Word makro".

Metoda automatizace

  1. Postupujte podle kroků 1-5 metodu DDE.
  2. V aplikaci Excel stiskněte ALT + F11 otevřete Editor jazyka.
  3. V nabídce Vložit klepněte na modul.
  4. V novém listu modulu zadejte následující makro:
    Sub RunWordMacro_Automation()
      Dim WordApp As Word.Application
      Dim WordDoc As Word.Document
      Set WordApp = CreateObject("Word.Application")
      Set WordDoc = WordApp.Documents.Open _
          ("C:\Wordtest.doc")
      WordApp.Visible = True
      WordApp.Run "macro1"
    
      ' Uncomment the next line of code to print the document.
      ' WordDoc.PrintOut Background:=False
    
      ' Uncomment the next line of code to save the modified document.
      ' WordDoc.Save
    
      WordApp.Quit SaveChanges:=wdDoNotSaveChanges
      Set WordApp = Nothing
    End Sub
    					
  5. V nabídce Nástroje klepněte na odkazy.
  6. Klepněte na položku Microsoft Word 9.0 Object Library v dialogovém okně Dostupné odkazy a potom klepněte na tlačítko OK.
  7. Stisknutím kombinace kláves ALT+F11 se vraťte zpět do aplikace Excel.
  8. Stiskněte ALT + F8 otevřete dialogové okno makro. RunWordMacro_Automation vyberte ze seznamu název makra a potom klepněte na příkaz Spustit.
Makro spustí aplikaci Word 2000 a zobrazí se zpráva "Word makro".

Poznámka: je nutné uložit dokument aplikace Word 2000 jako C:\Wordtest.doc.

Odkazy

Další informace o automatizaci klepněte na číslo článku níže % 2 % 2 článku databáze Microsoft Knowledge Base:
212890Jak spustit makra Microsoft Word 2000 použití automatizace

Vlastnosti

ID článku: 213430 - Poslední aktualizace: 3. února 2014 - Revize: 3.5
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Excel 2000 Standard Edition
Klíčová slova: 
kbnosurvey kbarchive kbmt kbhowto kbprogramming KB213430 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:213430

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com