Como gravar uma macro usando referências de célula relativas no Excel

Traduções deste artigo Traduções deste artigo
ID do artigo: 213740 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sumário

Ao contrário das versões do Microsoft Excel anteriores ao Microsoft Excel 97, não há nenhum comando de menu para gravar uma macro que usa referências relativas de célula nas versões do Excel listados no começo deste artigo. No entanto, você pode clicar em Referência relativa na barra de ferramentas Parar gravação .

Mais Informações

Microsoft fornece exemplos de programação apenas para ilustração, sem garantia expressa ou implícita, incluindo, mas não se limitando às garantias implícitas de comercialização e/ou adequação a uma finalidade específica. Este artigo presume que você esteja familiarizado com a linguagem de programação demonstrada e as ferramentas usadas para criar e depurar procedimentos. Profissionais de suporte da Microsoft podem ajudar a explicar a funcionalidade de um determinado procedimento, mas eles não modificarão esses exemplos para fornecer funcionalidades adicionais ou construir procedimentos para atender às suas necessidades específicas.
Se você não tenha muita experiência de programação, talvez queira em contato com um Microsoft Certified Partner ou Microsoft Advisory Services. Para obter mais informações, visite da Microsoft:

Microsoft Certified Partners - https://partner.microsoft.com/global/30000104

Comunicado de Microsoft Services - http://support.microsoft.com/gp/advisoryservice

Para obter mais informações sobre as opções de suporte estão disponíveis e sobre como entrar em contato com a Microsoft, visite o seguinte site: http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMSPara gravar uma macro que usa referências relativas de célula, clique em referência relativa na barra de ferramentas Parar gravação . Clicando em Referência relativa uma segunda vez desativa a gravação relativa.

Observação A dica de tela para Referência relativa não é alterado para indicar se gravação relativa já está disponível. A única indicação de que relativo gravação foi iniciado é a aparência do botão Referência relativa . Quando o botão tem uma aparência tridimensional pressionada ou baixo relevo, gravação relativa foi iniciado.

Se a barra de ferramentas Parar gravação não aparece quando você começa a gravar uma macro, você deve exibi-la. Para exibir a barra de ferramentas Parar gravação , aponte para barras de ferramentas no menu Exibir e, em seguida, clique em Parar gravação . Quando você fizer isso, Microsoft Excel insere uma linha extra de código em sua macro. Observe que, quando você executa a macro gravada, a barra de ferramentas Parar gravação é exibida.

Para evitar exibir a barra de ferramentas Parar gravação , execute estas etapas:
  1. No menu Ferramentas , aponte para macro e, em seguida, clique em macros .
  2. Na lista Nome da macro , clique no nome da macro que você registrou e, em seguida, clique em Editar .

    Esta etapa inicia o Editor do Visual Basic.
  3. Na janela código , digite um apóstrofo (') no início da linha de código a seguir:
    Application.CommandBars("Stop Recording").Visible = True
    					
  4. No menu arquivo , clique em Fechar e voltar para Microsoft Excel .
Observação : se você ativar a gravação relativa, Microsoft Excel não preserva a configuração para a próxima sessão do Microsoft Excel.

Gravação absoluto e relativo

Por padrão, macros gravadas usam referência absoluta de célula, que significa que localizações de célula exata são registradas para a macro. A macro só funciona com os endereços de células exata que você usar ao gravar a macro.

Quando você grava uma macro com referência a células relativas, as ações registradas na macro são relativas ao local de célula inicial.

Os exemplos a seguir gravar a mesma ação com referência de célula absoluta e, em seguida, relativa.

Gravação com referenciar de célula absoluta

Para gravar uma macro com referência de célula absoluta, execute estas etapas:
  1. Crie uma nova pasta de trabalho no Microsoft Excel e, em seguida, selecione a célula C1 na planilha.
  2. No menu Ferramentas , aponte para macro e, em seguida, clique em Gravar nova macro .
  3. Na caixa nome da macro , digite Absolute_Recording e, em seguida, clique em OK .
  4. Na barra de ferramentas Parar gravação , verificar a aparência do botão Referência relativa . Se o botão Referência relativa estiver pressionado, clique nele para desativar a gravação relativa.
  5. Digite test e clique em ENTER (a marca de seleção verde na barra de fórmulas).
  6. No menu Editar , clique em Copiar e, em seguida, selecione a célula C3. No menu Editar , clique em Colar .
  7. Na barra de ferramentas Parar gravação , clique em Parar gravação .
  8. Para exibir o conteúdo da macro gravada, aponte para macro no menu Ferramentas e, em seguida, clique em macro . Na lista de nome da macro , clique em Absolute_Recording e, em seguida, clique em Editar .

    Esta etapa inicia o Editor do Visual Basic.

    A macro é semelhante à seguinte:
    Sub Absolute_Recording()
    '
    ' Absolute_Recording Macro
    ' Macro recorded 12/17/99 by <your username>
    '
    '
        ActiveCell.FormulaR1C1 = "test"
        Selection.Copy
        Range("C3").Select
        ActiveSheet.Paste
    End Sub
    						
    esta macro insere a palavra "teste" (sem as aspas) na célula ativa. Em seguida, a macro copia e cola a entrada digitada na célula C3, independentemente do local a célula ativa quando você iniciou a macro.
  9. Quando tiver terminado de visualizar a macro, clique em Fechar e voltar para o Microsoft Excel no menu arquivo .

Gravação com referenciar relativa de célula

Para gravar uma macro com referência de célula relativa, execute estas etapas:
  1. Crie uma nova pasta de trabalho no Microsoft Excel e, em seguida, selecione a célula C1 na planilha.
  2. No menu Ferramentas , aponte para macro e, em seguida, clique em Gravar nova macro .
  3. Na caixa nome da macro , digite Relative_Recording e, em seguida, clique em OK .
  4. Na barra de ferramentas Parar gravação , verificar a aparência do botão Referência relativa . Se no botão Referência relativa não parece ser pressionado, clique nela para Ativar gravação relativa.
  5. Digite test e clique em ENTER (a marca de seleção verde na barra de fórmulas).
  6. No menu Editar , clique em Copiar , selecione a célula C3 e, em seguida, clique em Colar no menu Editar .
  7. Na barra de ferramentas Parar gravação , clique em Parar gravação .
  8. Aponte para macro no menu Ferramentas e, em seguida, clique em macro . Na lista de nome da macro , clique em Relative_Recording e, em seguida, clique em Editar .

    Esta etapa inicia o Editor do Visual Basic.

    A macro é semelhante à seguinte:
    Sub Relative_Recording()
    '
    ' Relative_Recording Macro
    ' Macro recorded 12/17/99 by <your username>
    '
    '
        ActiveCell.FormulaR1C1 = "test"
        Selection.Copy
        ActiveCell.Offset(2,0).Range("A1").Select
        ActiveSheet.Paste
    End Sub
    						
    esta macro insere a palavra "teste" (sem as aspas) na célula ativa. Em seguida, a macro copia e cola a entrada digitada para um local de célula duas linhas para baixo da célula ativa.

Referências

Para obter mais informações sobre gravação de macros, clique em Ajuda do Microsoft Excel no menu Ajuda , digite gravar uma macro no Assistente do Office ou no Assistente de resposta e, em seguida, clique em Pesquisar para exibir o tópico.

Propriedades

ID do artigo: 213740 - Última revisão: quarta-feira, 24 de janeiro de 2007 - Revisão: 3.7
A informação contida neste artigo aplica-se a:
  • Microsoft Excel 2004 for Mac
  • Microsoft Excel X para Macintosh
  • Microsoft Excel 2001 para Mac
  • Microsoft Office 98 for Macintosh
  • Microsoft Office Excel 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
Palavras-chave: 
kbmt kbdtacode kbhowto kbprogramming kbui KB213740 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 213740

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com