Description de formules permettant de compter les occurrences de texte, de caractères et de mots dans Excel

Traductions disponibles Traductions disponibles
Numéro d'article: 213889 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Résumé

Cet article contient et décrit des formules qui calculent les éléments suivants :
  • le nombre d'occurrences d'une chaîne de texte dans une plage de cellules ;
  • le nombre d'occurrences d'un caractère dans une cellule ;
  • le nombre d'occurrences d'un caractère dans une plage de cellules ;
  • le nombre de mots (ou de chaînes de texte) séparés par un caractère dans une cellule.

Plus d'informations

Formule permettant de compter le nombre d'occurrences d'une chaîne de texte dans une plage

= SOMME(NBCAR(plage)-NBCAR(SUBSTITUE(plage,"texte","")))/NBCAR("texte")
plage est la plage de cellules en question et "texte" est remplacé par la chaîne de texte spécifique que vous souhaitez compter.

Remarque La formule ci-dessus doit être entrée en tant que formule matricielle. Pour entrer une formule en tant que matrice dans Excel pour Windows, appuyez sur CTRL+MAJ+ENTRÉE. Pour entrer une formule en tant que matrice dans Excel pour Macintosh, appuyez sur COMMANDE+RETOUR.

La formule doit être divisée par la longueur de la chaîne de texte car la somme de la longueur de caractères de la plage est réduite par un multiple de chaque occurrence de la chaîne de texte. Cette formule peut remplacer toutes les formules citées ultérieurement dans cet article, sauf celle permettant de compter le nombre de mots dans une cellule.

Exemple 1 : Pour compter le nombre d'occurrences d'une chaîne de texte dans une plage

  1. Démarrez Excel, puis ouvrez un nouveau classeur.
  2. Tapez les données suivantes dans Feuil1 :
    A1 : Fruit
    A2 : pomme, pomme
    A3 : orange
    A4 : pomme, orange
    A5 : raisin
    A6 : orange, raisin
    A7 : raisin, pomme
    A8 : =SOMME(NBCAR(A2:A7)-NBCAR(SUBSTITUE(A2:A7,"pomme","")))/NBCAR("pomme")
    					
La valeur de la cellule A8 est 4 parce que le texte « pomme » apparaît à quatre reprises dans la plage.

Formule permettant de compter le nombre d'occurrences d'un caractère dans une cellule

=NBCAR(réf_cell)-NBCAR(SUBSTITUE(réf_cell,"a",""))
réf_cell est la référence de la cellule et « a » est remplacé par le caractère que vous souhaitez compter.

Remarque Il n'est pas nécessaire d'entrer cette formule comme formule matricielle.

Exemple 2 : Pour compter le nombre d'occurrences d'un caractère dans une cellule

Utilisez les données de l'exemple précédent ; supposons que vous souhaitez compter le nombre d'occurrences du caractère « p » dans A7. Tapez la formule suivante dans la cellule A9 :
A9 : =NBCAR(A7)-NBCAR(SUBSTITUE(A7,"p",""))
La valeur de la cellule A9 est 1 parce que le caractère « p » apparaît une fois dans A7.

Formule permettant de compter le nombre d'occurrences d'un caractère dans une plage

=SOMME(NBCAR(plage)-NBCAR(SUBSTITUE(plage,"a","")))
plage est la plage de cellules en question et « a » est remplacé par le caractère que vous souhaitez compter.

Remarque La formule ci-dessus doit être entrée en tant que formule matricielle. Pour entrer une formule en tant que formule matricielle dans Excel, appuyez sur CTRL+MAJ+ENTRÉE.

Exemple 3 : Pour compter le nombre d'occurrences d'un caractère dans une plage

Utilisez les données de l'exemple précédent ; supposons que vous souhaitez compter le nombre d'occurrences du caractère « p » dans A2:A7. Tapez la formule suivante dans la cellule A10 :
A10 : =SOMME(NBCAR(A2:A7)-NBCAR(SUBSTITUE(A2:A7,"p","")))
Remarque La formule ci-dessus doit être entrée en tant que formule matricielle. Pour entrer une formule en tant que formule matricielle dans Excel, appuyez sur CTRL+MAJ+ENTRÉE.

La valeur de la cellule A10 est 4 parce que le caractère « p » apparaît quatre fois dans A2:A7.

Formule permettant de compter le nombre de mots séparés par un caractère dans une cellule

=SI(NBCAR(SUPPRESPACE(réf_cell))=0,0,NBCAR(réf_cell)-NBCAR(SUBSTITUE(réf_cell,caractère,""))+1)
réf_cell est la référence de cellule et caractère est le caractère qui sépare les mots.

Remarque La formule ci-dessus ne contient pas d'espaces ; elle est tapée sur plusieurs lignes à des fins de lisibilité dans ce document. N'incluez pas d'espaces lorsque vous la tapez dans la cellule. Il n'est pas nécessaire d'entrer cette formule comme formule matricielle.

Exemple 4 : Pour compter le nombre de mots séparés par un espace dans une cellule

Pour compter le nombre de mots d'une cellule dans laquelle les mots sont séparés par un espace, procédez comme suit :
  1. Démarrez Excel, puis ouvrez un nouveau classeur.
  2. Tapez les données suivantes dans Feuil1 :
    A1 : La voiture roulait rapidement
    A2 : =SI(NBCAR(SUPPRESPACE(A1))=0,0,NBCAR(SUPPRESPACE(A1))-NBCAR(SUBSTITUE(A1," ",""))+1)
La formule de la cellule A2 renvoie la valeur 4 car la chaîne contient quatre mots séparés par des espaces. Le résultat ne varie pas si les mots sont séparés par plusieurs espaces ou s'ils commencent ou se terminent par un espace. La fonction SUPPRESPACE supprime les caractères espace supplémentaires et les caractères espace de début ou de fin du texte de la cellule.

Dans Excel, vous pouvez également utiliser une macro pour compter les occurrences d'un caractère spécifique dans une cellule ou une plage de cellules.

Références

Pour plus d'informations sur la façon de compter des occurrences de texte, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
89794 Comment faire pour utiliser Visual Basic pour Applications pour compter les occurrences d'un caractère dans une sélection dans Excel

Propriétés

Numéro d'article: 213889 - Dernière mise à jour: mercredi 13 juin 2007 - Version: 5.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office Excel 2003
  • Microsoft Excel 2002
  • Microsoft Excel 2000 Standard
  • Microsoft Excel 97 Standard
  • Microsoft Excel 2004 for Mac
  • Microsoft Excel X pour Mac
  • Microsoft Excel 2001 pour Mac
  • Microsoft Excel 98 pour Macintosh
Mots-clés : 
kbformula kbhowto kbinfo KB213889
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com