Formules voor het tellen van tekst, tekens en woorden in Excel

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 213889
Alles uitklappen | Alles samenvouwen

Op deze pagina

Samenvatting

In dit artikel worden formules beschreven waarmee het volgende kan worden berekend:
  • Het aantal keren dat een tekstreeks voorkomt in een celbereik.
  • Het aantal keren dat een teken voorkomt in één cel.
  • Het aantal keren dat een teken voorkomt in een celbereik.
  • Het aantal woorden (of tekstreeksen) met een teken als scheidingsteken in een cel.

Meer informatie

Formule voor het berekenen van het aantal keren dat een tekstreeks voorkomt in een bereik

=SOM(LENGTE(bereik)-LENGTE(SUBSTITUEREN(bereik,"tekst","")))/LENGTE("tekst")
waarbij bereik het desbetreffende celbereik is en "tekst" wordt vervangen door de specifieke tekstreeks die u wilt tellen.

Opmerking De bovenstaande formule moet worden ingevoerd als een matrixformule. U kunt een matrixformule invoeren in Excel voor Windows door op CTRL+SHIFT+ENTER te drukken. U kunt een matrixformule invoeren in Excel voor Macintosh door op COMMAND+RETURN te drukken.

De formule moet worden gedeeld door de lengte van de tekstreeks, aangezien van de som van de tekenlengte van het bereik een veelvoud wordt afgetrokken van het aantal keren dat de tekstreeks voorkomt. Deze formule kan alle volgende formules in dit artikel vervangen, behalve de formule waarmee het aantal woorden in een cel wordt geteld.

Voorbeeld 1: tellen hoe vaak een tekstreeks voorkomt in een bereik

  1. Start Excel en open een nieuwe werkmap.
  2. Typ het volgende in werkblad1:
    A1: Vrucht
    A2: appel,appel
    A3: banaan
    A4: appel,banaan
    A5: druif
    A6: banaan,druif
    A7: druif, appel
    A8: =SOM(LENGTE(A2:A7)-LENGTE(SUBSTITUEREN(A2:A7;"appel";"")))/LENGTE("appel")
    					
De waarde van cel A8 is 4, omdat de tekst 'appel' vier keer voorkomt in het bereik.

Formule om te berekenen hoe vaak één teken voorkomt in één cel

=LENGTE(cel_verw)-LENGTE(SUBSTITUEREN(cel_verw,"a",""))
waarbij celverwijzing de celverwijzing is en 'a' wordt vervangen door het teken dat u wilt tellen.

Opmerking Deze formule hoeft niet als een matrixformule te worden ingevoerd.

Voorbeeld 2: tellen hoe vaak een teken voorkomt in één cel

Gebruik dezelfde gegevens als in het voorgaande voorbeeld. Hierbij wordt ervan uitgegaan dat u wilt tellen hoe vaak het teken 'p' voorkomt in A7. Typ de volgende formule in cel A9:
A9: =LENGTE(A7)-LENGTE(SUBSTITUEREN(A7;"p";""))
De waarde van cel A9 is 2, aangezien het teken 'p' twee keer voorkomt in A7.

Formule om te berekenen hoe vaak één teken voorkomt in een bereik

=SOM(LENGTE(bereik)-LENGTE(SUBSTITUEREN(bereik,"a","")))
waarbij bereik het desbetreffende celbereik is en "a" wordt vervangen door het teken dat u wilt tellen.

Opmerking De bovenstaande formule moet worden ingevoerd als een matrixformule. U kunt een matrixformule invoeren in Excel door op CTRL+SHIFT+ENTER te drukken.

Voorbeeld 3: tellen van het aantal keren dat een teken voorkomt in een bereik

Gebruik dezelfde gegevens als in het voorafgaande voorbeeld. We gaan er hier vanuit dat u wilt tellen hoe vaak het teken 'p' voorkomt in A2:A7. Typ de volgende formule in cel A10:
A10: =SOM(LENGTE(A2:A7)-LENGTE(SUBSTITUEREN(A2:A7,"p","")))
Opmerking de bovenstaande formule moet worden ingevoerd als een matrixformule. U kunt een matrixformule invoeren in Excel door op CTRL+SHIFT+ENTER te drukken.

De waarde van cel A10 is 8, aangezien het teken 'p' acht keer voorkomt in A2:A7.

Formule voor het tellen van het aantal woorden dat door een teken is gescheiden in een cel

=ALS(LENGTE(SPATIES.WISSENcel_verw))=0,0,LENGTE(cel_verw)-LENGTE(SUBSTITUEREN(cel_verw,TEKEN,""))+1)
waarbij celverwijzing de celverwijzing is en teken het teken dat de woorden scheidt.

Opmerking De bovenstaande formule bevat geen spaties. Er zijn alleen meerdere regels gebruikt om de formule in dit document in te passen. Neem geen spaties op wanneer u deze formule in de cel typt. Deze formule hoeft niet als een matrixformule te worden ingevoerd.

Voorbeeld 4: het aantal woorden tellen met een spatie als scheidingsteken in een cel

Volg de volgende stappen om het aantal woorden te tellen in een cel waarin de woorden met een spatie van elkaar zijn gescheiden:
  1. Start Excel en open vervolgens een nieuwe werkmap.
  2. Typ het volgende in werkblad1:
    A1: De auto reed hard
    A2: =ALS(LENGTE(SPATIES.WISSEN(A1))=0;0;LENGTE(SPATIES.WISSEN(A1))-LENGTE(SUBSTITUEREN(A1;" ";""))+1)
De formule in cel A2 geeft de waarde 4 als resultaat, wat betekent dat de tekenreeks vier woorden bevat die met spaties van elkaar zijn gescheiden. Als woorden van elkaar zijn gescheiden door meerdere spaties of als woorden beginnen of eindigen met een spatie, maakt dit geen verschil. Met de functie SPATIES.WISSEN worden extra spatietekens en begin- en eindspaties verwijderd uit de tekst van de cel.

In Excel kunt u ook een macro gebruiken om te tellen hoe vaak een specifiek teken voorkomt in een cel of een celbereik.

Referenties

Als u meer informatie wilt over het tellen van tekst, klikt u op het volgende artikelnummer in de Microsoft Knowledge Base:
89794 Het aantal keren dat een teken voorkomt in een selectie in Excel tellen met VBA (Visual Basic for Applications)
Opmerking Dit is een artikel voor snelle publicatie dat rechtstreeks is gemaakt vanuit de ondersteuningsorganisatie van Microsoft. De informatie in dit artikel wordt in de huidige vorm aangeboden in reactie op nieuw geconstateerde problemen. Aangezien artikelen van dit type zeer snel moeten worden gepubliceerd, kan de inhoud typografische fouten bevatten en kan de inhoud zonder voorafgaande kennisgeving worden gewijzigd. Raadpleeg de Gebruiksrechtovereenkomst voor overige aandachtspunten.

Eigenschappen

Artikel ID: 213889 - Laatste beoordeling: dinsdag 30 juli 2013 - Wijziging: 1.0
Trefwoorden: 
kbformula kbhowto kbinfo KB213889

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com