XL: Creazione di un grafico di curva a campana

Traduzione articoli Traduzione articoli
Identificativo articolo: 213930 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

Sommario

Una curva a campana è un diagramma di distribuzione normale di un determinato set di dati. In questo articolo viene descritto come creare un grafico di curva a campana in Microsoft Excel.

Informazioni

Nell'esempio che segue è possibile creare una curva a campana dei dati generati da Excel utilizzando lo strumento di generazione di numeri casuali incluso in Strumenti di analisi. Dopo che in Microsoft Excel è stato generato un set di numeri casuali, è possibile creare un istogramma utilizzando tali numeri e lo strumento istogramma incluso in Strumenti di analisi. A partire dall'istogramma è possibile creare un grafico che rappresenti una curva a campana.

Per creare una curva a campana di esempio, attenersi alla seguente procedura:
  1. Avviare Excel.
  2. Immettere le seguenti intestazioni di colonna in un nuovo foglio di lavoro:
       A1:Original  B1:Average  C1:Bin  D1:Random  E1:Histogram  G1:Histogram
    					
  3. Immettere i seguenti dati nel medesimo foglio di lavoro:
       A2: 23      B2:
       A3: 25      B3: DEV.ST
       A4: 12      B4:
       A5: 24
       A6: 27
       A7: 57
       A8: 45
       A9: 19
    					
  4. Immettere le seguenti formule nel medesimo foglio di lavoro:
       B2:  =MEDIA(A2:A9)
       B3:
       B4:  =DEV.ST(A2:A9)
    						
    Mediante tali formule vengono generate rispettivamente la media e la deviazione standard dei dati originali.
  5. Immettere le seguenti formule per generare l'intervallo della classe per l'istogramma:
       C2: =$B$2-3*$B4
    						
    In questo modo viene generato il limite inferiore dell'intervallo della classe. Questo numero rappresenta tre deviazioni standard inferiori alla media.
       C3: =C2+$B$4
    						
    Questa formula consente di aggiungere una deviazione standard al numero calcolato nella cella precedente.
  6. Selezionare la cella C3, selezionare il quadratino di riempimento, quindi riempire la formula dalla cella C3 alla cella C8.
  7. Per generare i dati casuali che formeranno la base della curva a campana, attenersi alla procedura seguente:
    1. Scegliere l'opzione relativa all'analisi dei dati dal menu Strumenti.
    2. Nella casella degli strumenti d analisi selezionare lo strumento di generazione di numeri casuali, quindi scegliere OK.
    3. Nella casella relativa al numero di variabili digitare 1.
    4. Nella casella relativa alla quantità di numeri casuali digitare 2000.

      NOTA: se si varia questa quantità, viene incrementata o diminuita l'accuratezza della curva a campana.
    5. Nella casella relativa alla distribuzione selezionare l'opzione normale.
    6. Nel riquadro dei parametri, immettere nella casella della media il numero calcolato nella cella B2 (29 nell'esempio).
    7. Nella casella della deviazione standard immettere il numero calcolato nella cella B4 (14,68722).
    8. Lasciare vuota la casella relativa all'inizializzazione casuale.
    9. Nel riquadro delle opzioni di output scegliere l'opzione relativa all'intervallo di output.
    10. Digitare D2 nella casella relativa all'intervallo di output.

      Verranno generati 2.000 numeri casuali adatti a una normale distribuzione.
    11. Scegliere OK.
  8. Per creare un istogramma dei dati casuali, attenersi alla seguente procedura:
    1. Scegliere l'opzione relativa all'analisi dei dati dal menu Strumenti.
    2. Nella casella degli strumenti di analisi selezionare lo strumento istogramma, quindi scegliere OK.
    3. Nella casella relativa all'intervallo di input digitare D2:D2001.
    4. Nella casella relativa all'intervallo della classe digitare C2:C8.
    5. Nel riquadro delle opzioni di output scegliere l'opzione relativa all'intervallo di output.
    6. Digitare E2 nella casella relativa all'intervallo di output.
    7. Scegliere OK.
  9. Per creare un istogramma dei dati originali, attenersi alla seguente procedura:
    1. Scegliere l'opzione relativa all'analisi dei dati dal menu Strumenti.
    2. Scegliere lo strumento istogramma, quindi OK.
    3. Nella casella relativa all'intervallo di input digitare A2:A9.
    4. Nella casella relativa all'intervallo della classe digitare C2:C8.
    5. Nel riquadro delle opzioni di output scegliere l'opzione relativa all'intervallo di output.
    6. Digitare G2 nella casella relativa all'intervallo di output.
    7. Scegliere OK.
  10. Creare le etichette per la legenda del grafico immettendo quanto segue:
       E14: =G1&"-"&G2
       E15: =E1&"-"&F2
       E16: =G1&"-"&H2
    					
  11. Selezionare l'intervallo di celle E2:H10 nel foglio di lavoro.
  12. Scegliere Grafico dal menu Inserisci.
  13. In Tipo di grafico fare clic su Dispers. (XY).
  14. In Scelte disponibili fare clic sul grafico a destra nella riga di mezzo.

    NOTA: al di sotto delle cinque scelte possibili viene visualizzata la seguente descrizione: "Dispersione con coordinate unite da linee smussate e senza indicatori di dati".
  15. Scegliere Avanti.
  16. Fare clic sulla scheda Serie.
  17. Nella casella Nome eliminare il riferimento alla cella, quindi selezionare la cella E15.
  18. Nella casella Valori X eliminare il riferimento all'intervallo, quindi selezionare l'intervallo E3:E10.
  19. Nella casella Valori Y eliminare il riferimento all'intervallo, quindi selezionare l'intervallo F3:F10.
  20. Fare clic su Aggiungi per aggiungere un'altra serie.
  21. Fare clic sulla casella Nome, quindi selezionare la cella E14.
  22. Fare clic sulla casella Valori X, quindi selezionare l'intervallo E3:E10.
  23. Nella casella Valori Y eliminare il valore presente, quindi selezionare l'intervallo G3:G10.
  24. Fare clic su Aggiungi per aggiungere un'altra serie.
  25. Fare clic sulla casella Nome, quindi selezionare la cella E16.
  26. Fare clic sulla casella Valori X, quindi selezionare l'intervallo E3:E10.
  27. Nella casella Valori Y eliminare il valore presente, quindi selezionare l'intervallo H3:H10.
  28. Scegliere Fine.

    Il grafico presenterà due serie a curva e una serie lineare lungo l'asse X.
  29. Fare doppio clic sulla seconda serie, che dovrebbe essere contrassegnata come "- Bin" nella legenda.
  30. Nella finestra di dialogo Formato serie dati scegliere la scheda Asse.
  31. Scegliere Asse secondario, quindi OK.
Il grafico presenta a questo punto il confronto tra un determinato set di dati e una curva a campana.

Riferimenti

Per ulteriori informazioni sulla creazione di grafici, scegliere Guida in linea Microsoft Excel dal menu ?, digitare creazione di un grafico nell'Assistente di Office o nella Ricerca libera, quindi scegliere Cerca per visualizzare l'argomento corrispondente.

Proprietà

Identificativo articolo: 213930 - Ultima modifica: venerdì 3 marzo 2006 - Revisione: 2.0
Le informazioni in questo articolo si applicano a
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
Chiavi: 
kbhowto KB213930
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com