XL: Como criar um gráfico de curva de Gauss

Traduções de Artigos Traduções de Artigos
Artigo: 213930 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Sumário

Uma curva de Gauss (curva em forma de sino) é um gráfico de distribuição normal de um determinado conjunto de dados. Este artigo descreve como pode criar um gráfico de uma curva de Gauss no Microsoft Excel.

Mais Informação

No exemplo que se segue, pode criar uma curva de Gauss de dados gerados pelo Excel utilizando a ferramenta de geração de números aleatórios das ferramentas de análise. Depois de o Microsoft Excel gerar um conjunto de números aleatórios, pode criar um histograma utilizando esses números aleatórios e a ferramenta de histogramas das ferramentas de análise. A partir do histograma, pode criar um gráfico para representar uma curva de Gauss.

Para criar uma curva de Gauss de exemplo, siga estes passos:
  1. Inicie o Excel.
  2. Introduza os seguintes cabeçalhos de coluna numa nova folha de cálculo:
       A1:Original  B1:Média  C1:Bloco  D1:Aleatório  E1:Histograma  G1:Histograma
    					
  3. Introduza os seguintes dados na mesma folha de cálculo:
       A2: 23      B2:
       A3: 25      B3: DESVPAD
       A4: 12      B4:
       A5: 24
       A6: 27
       A7: 57
       A8: 45
       A9: 19
    					
  4. Introduza as seguintes fórmulas na mesma folha de cálculo:
       B2:  =MÉDIA(A2:A9)
       B3:
       B4:  =DESVPAD(A2:A9)
    						
    Estas fórmulas irão gerar a média e o desvio padrão dos dados originais, respectivamente.
  5. Introduza as seguintes fórmulas para gerar o intervalo de blocos para o histograma:
       C2: =$B$2-3*$B4
    						
    Isto gera o limite inferior do intervalo de blocos. Este número representa três desvios padrão inferiores à média.
       C3: =C2+$B$4
    						
    Esta fórmula adiciona um desvio padrão ao número calculado na célula acima.
  6. Seleccione a célula C3 e arraste a alça de preenchimento para preencher as células C3 a C8 com a fórmula.
  7. Para gerar os dados aleatórios que formarão a base para a curva de Gauss, siga estes passos:
    1. No menu Ferramentas, clique em Análise de dados.
    2. Na caixa Ferramentas de análise, clique em Geração de número aleatório e clique em OK.
    3. Na caixa Número de variáveis, escreva 1.
    4. Na caixa Total de números aleatórios, escreva 2000.

      NOTA: a variação deste número aumentará ou diminuirá a exactidão da curva de Gauss.
    5. Na caixa Distribuição, seleccione Normal.
    6. No painel Parâmetros, introduza o número calculado na célula B2 (29 no exemplo) na caixa Média.
    7. Na caixa Desvio-padrão introduza o número calculado na célula B4 (14,68722).
    8. Deixe a caixa Semente aleatória em branco.
    9. No painel Opções de saída, clique em Intervalo de saída.
    10. Escreva D2 na caixa Intervalo de saída.

      Isto irá gerar 2.000 números aleatórios que se enquadram numa distribuição normal.
    11. Clique em OK.
  8. Para criar um histograma para os dados aleatórios, siga estes passos:
    1. No menu Ferramentas, clique em Análise de dados.
    2. Na caixa Ferramentas de análise, seleccione Histograma e clique em OK.
    3. Na caixa Intervalo de entrada, escreva D2:D2001.
    4. Na caixa Intervalo de bloco, escreva C2:C8.
    5. No painel Opções de saída, clique em Intervalo de saída.
    6. Escreva E2 na caixa Intervalo de saída.
    7. Clique em OK.
  9. Para criar um histograma para os dados originais, siga estes passos:
    1. No menu Ferramentas, clique em Análise de dados.
    2. Clique em Histograma e clique em OK.
    3. Na caixa Intervalo de entrada, escreva A2:A9.
    4. Na caixa Intervalo de bloco, escreva C2:C8.
    5. No painel Opções de saída, clique em Intervalo de saída.
    6. Escreva G2 na caixa Intervalo de saída.
    7. Clique em OK.
  10. Crie rótulos para a legenda do gráfico introduzindo o seguinte:
       E14: =G1&"-"&G2
       E15: =E1&"-"&F2
       E16: =G1&"-"&H2
    					
  11. Seleccione o intervalo de células E2:H10, na folha de cálculo.
  12. No menu Inserir, clique em Gráfico.
  13. Em Tipo de gráfico, clique em Dispersão (XY).
  14. Em Subtipo de gráfico, na linha do meio, clique no gráfico da direita.

    NOTA: mesmo abaixo destes 5 subtipos, a descrição indicará "Dispersão com pontos de dados ligados por linhas suavizadas, sem marcadores".
  15. Clique em Seguinte.
  16. Clique no separador Série.
  17. Na caixa Nome, elimine a referência à célula e seleccione a célula E15.
  18. Na caixa Valores de X, elimine a referência ao intervalo e seleccione o intervalo E3:E10.
  19. Na caixa Valores de Y, elimine a referência ao intervalo e seleccione o intervalo F3:F10.
  20. Clique em Adicionar para adicionar outra série.
  21. Clique na caixa Nome e seleccione a célula E14.
  22. Clique na caixa Valores de X e seleccione o intervalo E3:E10.
  23. Na caixa Valores de Y, elimine o valor existente e seleccione o intervalo G3:G10.
  24. Clique em Adicionar para adicionar outra série.
  25. Clique na caixa Nome e seleccione a célula E16.
  26. Clique na caixa Valores de X e seleccione o intervalo E3:E10.
  27. Clique na caixa Valores de Y, elimine o valor existente e seleccione o intervalo H3:H10.
  28. Clique em Concluir.

    O gráfico terá duas séries em curva e uma série plana ao longo do eixo horizontal.
  29. Faça duplo clique na segunda série; deverá ter o rótulo "- Bloco" na legenda.
  30. Na caixa de diálogo Formatar série de dados, clique no separador Eixo.
  31. Clique em Eixo secundário e clique em OK.
Tem agora um gráfico que compara um determinado conjunto de dados com uma curva de Gauss.

Referências

Para obter mais informações sobre como criar dados, clique em Ajuda do Microsoft Excel no menu Ajuda, escreva criar um gráfico no Assistente do Office ou no Assistente de respostas e clique em Procurar para visualizar o tópico.

Propriedades

Artigo: 213930 - Última revisão: 7 de novembro de 2006 - Revisão: 2.0
A informação contida neste artigo aplica-se a:
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
Palavras-chave: 
kbhowto KB213930

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com