WD2000: How to Automatically Open the Last Document Edited

Article translations Article translations
Article ID: 214206 - View products that this article applies to.
This article was previously published under Q214206
Expand all | Collapse all

On This Page

SUMMARY

The bottom of the File menu lists the most recent files that you have saved or opened in chronological order (the last file that you saved or opened appears first). This list of files is commonly referred to as the "Most Recently Used (MRU)" list.

After you start Word, if you want to open the last file that you saved or opened, you can manually click the first file listed on the MRU list on the File menu. Or, you can have Word automatically open the file when you start Word by either modifying the Word command line or by creating an AutoExec macro.

MORE INFORMATION

To automatically open the last document that you edited when you start Word, use one of the following methods.

Method 1: Create a Shortcut Containing a Command-Line Switch

  1. Right-click the Windows desktop, point to New on the menu that appears, and then click Shortcut.
  2. In the Create Shortcut dialog box, click Browse.
  3. Change the Look in box to the following folder:
    C:\Program Files\Microsoft Office\Office
    NOTE: Your installation of Microsoft Word may be in a different location.

  4. Click Winword.exe, and then click Open.
  5. In the Command line box, move the insertion point to the end of the text after the closing quotation mark.
  6. Type a space followed by /mfile1. The command line should now appear similar to the following example:
    C:\Program Files\Microsoft Office\Winword.exe /mfile1
    NOTE: There is no space between the /m and file1.

  7. Click Next.
  8. In the Select a name for the shortcut box, type what you want to call this shortcut, and then click Finish.
Your new Word shortcut to start Word with the last edited file will now appear on the Windows desktop. When you double-click this shortcut, Word will start and automatically open the last file that you edited (changed).

Method 2: Use an AutoExec Macro

Microsoft provides programming examples for illustration only, without warranty either expressed or implied. This includes, but is not limited to, the implied warranties of merchantability or fitness for a particular purpose. This article assumes that you are familiar with the programming language that is being demonstrated and with the tools that are used to create and to debug procedures. Microsoft support engineers can help explain the functionality of a particular procedure, but they will not modify these examples to provide added functionality or construct procedures to meet your specific requirements.
For more information about how to use the sample code in this article, click the article number below to view the article in the Microsoft Knowledge Base:
212536 OFF2000: How to Run Sample Code from Knowledge Base Articles
To create a macro that will automatically open the last file that you edited when you start Word, follow these steps:
  1. On the Tools menu, point to Macro, and then click Macros.
  2. In the Macros dialog box, type AutoExec in the Macro Name box, and then click Create.
  3. In the Microsoft Visual Basic (macro editing) window, type the following macro:
    Sub Autoexec()
       RecentFiles(1).Open
    End Sub
    					
  4. On the File menu, click Close and Return to Microsoft Word.
  5. Quit Microsoft Word.

    NOTE: If you are prompted with the following message, click Yes.
    Changes have been made that affect the global template, Normal.dot. Do you want to save those changes?
When you restart Microsoft Word, Word will automatically open the last file you edited (changed).

REFERENCES

For additional information about controlling how Word starts, click the article number below to view the article in the Microsoft Knowledge Base:
210565 WD: Word Startup (Command-Line) Switches and Their Purpose

Properties

Article ID: 214206 - Last Review: June 17, 2005 - Revision: 2.0
APPLIES TO
  • Microsoft Word 2000 Standard Edition
Keywords: 
kbinfo kbmacro KB214206

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com