Một số ứng dụng khách email không thể giải mã email được gửi từ Outlook 2010

ID c?a bài: 2142236 - Xem s?n ph?m mà bài này áp d?ng vào.
Bung t?t c? | Thu g?n t?t c?

TRI?U CH?NG

Khi gửi thư đã mã hoá từ Microsoft Office Outlook 2010 đến người nhận bằng ứng dụng khách email của bên thứ ba, chẳng hạn như Lotus Notes, Entrust, SeaMonkey hoặc Thunderbird, người nhật có thể không đọc được thư đã mã hoá. Trong trường hợp sử dụng ứng dụng khách Thunderbirdemail, ứng dụng khách này có thể hiển thị thông báo sau trong phần thân của thư khi mở:

Thunderbird không th? gi?i mã thư này

Người gửi đã mã hoá thư này cho bạn bằng cách sử dụng một trong những chứng chỉ số của bạn, tuy nhiên Thunderbird đã không thể tìm thấy chứng chỉ này và khoá cá nhân tương ứng.

Gi?i pháp có th?:

  • N?u b?n có m?t th? thông minh, hãy đút thẻ vào ngay bây gi?.
  • Nếu bạn đang sử dụng một máy mới hoặc nếu bạn đang sử dụng hồ sơ mới trên Thunderbird, bạn cần khôi phục chứng chỉ và khoá cá nhân của mình từ bản sao lưu. Việc sao lưu ch?ng ch? thư?ng k?t thúc trong ".P12".

Ứng dụng khách Thunderbird có th? hi?n th? c?nh báo sau:

Bảo mật Thư

Thư Không có Ch? ký Điện tử

Thư này không có ch? ký đi?n t? c?a ngư?i g?i. Thiếu chữ ký điện tử nghĩa là thư có thể được gửi bởi ai đó giả mạo địa chỉ email này. Cũng có thể thư đã bị thay đổi trong quá trình chuyển qua mạng. Tuy nhiên, không ch?c r?ng m?t trong hai s? ki?n đã x?y ra.

Thư Không th? Gi?i mã được

Thư này đã được mã hoá trước khi chuyển cho bạn nhưng không thể giải mã được. Có các v?n đ? không xác định với thư được mã hoá này.

Đồng thời, Microsoft Entourage 2008 (có trong Microsoft Office 2008 dành cho Mac) và Microsoft Outlook 2011 dành cho Mac không thể giải mã thư email được gửi từ Outlook 2010. Bạn có thể thấy lỗi sau trong Outlook 2011 dành cho Mac:

Không thể kiểm tra bảo mật của thư này do bị lỗi.

NGUYÊN NHÂN

Cú pháp Thư Mật mã (CMS) được ghi lại trong RFC 5652. Sự định rõ đó cho phép sử dụng subjectKeyIdentifier hoặc issuerAndSerialNumber làm SignerIdentifier. Phiên bản phát hành (RTM) của Outlook 2010 sử dụng subjectKeyIdentifier làm SignerIdentifier, trong khi đó phiên bản trước đó sử dụng issuerAndSerialNumber. Nếu phần mở rộng subjectKeyIdentifier không được xác định trong chứng chỉ, Outlook 2010 RTM sẽ tạo một phần mở rộng. Một số ứng dụng email khách hoặc hệ điều hành của bên thứ ba không thể sử dụng subjectKeyIdentifier do Outlook tạo. Điều này khiến người nhận không thể giải mã và đọc thư.

GI?I PHÁP

Sự cố này được khắc phục trong Microsoft Office 2010 Gói Dịch vụ 1 (SP1). Để biết thêm thông tin, hãy bấm vào số bài viết sau để xem bài viết trong Cơ sở Kiến thức Microsoft:

2460049Mô t? về Office 2010 SP1

Sau khi cài đặt SP1, nếu phần mở rộng subjectKeyIdentifier không có trong chứng chỉ, Outlook sẽ hoàn nguyên về sử dụng issuerAndSerialNumber làm SignerIdentifier.

Giải pháp

Nếu không thể cài đặt Microsoft Office 2010 Gói Dịch vụ 1, bạn có thể sử dụng giải pháp sau.

Để yêu cầu chúng tôi khắc phục sự cố này giúp bạn, hãy chuyển đến phần "Khắc phục sự cố giúp tôi". N?u b?n mu?n t? ḿnh kh?c ph?c s? c? này, hăy chuyển đến phần "Đ? tôi t? kh?c ph?c s? c?".

Kh?c ph?c s? c? cho tôi

Đ? kh?c ph?c s? c? này t? đ?ng, hãy b?m vào liên k?t Khắc phục sự cố này. Sau đó b?m Ch?y trong h?p tho?i T?p T?i xu?ng và th?c hi?n theo các bư?c trong thu?t s? này.

Khắc phục sự cố này
Microsoft Fix it 50724



Chú ý Thuật sĩ này có thể chỉ có bằng tiếng Anh. Tuy nhiên, bản vá t? đ?ng c?ng s? ho?t đ?ng đ?i v?i các phiên b?n ngôn ng? khác c?a Windows.

Chú ý Nếu bạn hiện không làm việc trên máy tính xảy ra sự cố, bạn có thể lưu khắc phục sự cố tự động vào ổ đĩa flash hoặc CD để bạn có thể chạy trên máy tính có sự cố.

Đ? tôi t? kh?c ph?c s? c?

Trên máy khách của người gửi, hãy sử dụng giá trị đăng ký sau để Outlook 2010 hoàn nguyên về chế độ có trong các phiên bản Outlook trước đó.

Quan trọng Phương pháp này chứa các bước chỉ dẫn bạn cách s?a đổi sổ đăng ký. Tuy nhiên, có th? x?y ras? c? nghiêm tr?ng n?u b?n s?a đ?i s? đăng ký không đúng cách. Do đó, h?y ch?c ch?n r?ng b?n th?c hi?n các bư?c sau c?n th?n. Để đượcbảo vệ nhiều hơn, hãy sao lưu s? đăng ký trước khi sửa đổi để bạn có thể khôi phục s? đăng ký nếu có sự cố xảy ra. Để biết thêm thông tin về cách sao lưu và sau đó khôi phục sổ đăng ký, hãy bấm vào số bài viết sau đây để xem bài viết trong Cơ sở Kiến thức Microsoft:

322756Cách sao lưu và khôi phục sổ đăng ký trong Windows

  1. Khởi động Registry Editor.
  2. Định vị rồi bấm để chọn khoá con đăng ký sau đây:

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\security

    Chú ý Tạo khoá con đăng ký \Bảo mậtnếu khoá con không tồn tại.
  3. Thêm d? li?u đăng ký sau vào khoá này:

    Loại giá trị: DWORD
    Tên giá trị: Dữ liệu giá trị UseIssuerSerialNumber
    : 1
  4. Thoát khỏi Registry Editor.

THÔNG TIN THÊM

Các sản phẩm của bên-thứ ba đã được thảo luận trong bài viết này do các công ty độc lập với Microsoft sản xuất. Microsoft không bảo đảm, dù ngụ ý hay bằng hình thức khác, về hiệu suất hay độ tin cậy của các sản phẩm này.

Microsoft cung cấp thông tin liên hệ của bên thứ ba nhằm giúp bạn tìm được hỗ trợ kỹ thuật. Thông tin liên hệ này có thể thay đổi mà không thông báo. Microsoft không bảo đảm độ chính xác về thông tin liên hệ của bên thứ ba này.

Để biết thông tin về cách liên hệ với một trong những công ty được đề cập trong bài viết này, hãy truy cập Web site sau của Microsoft:

Thu?c tính

ID c?a bài: 2142236 - L?n xem xét sau cùng: 22 Tháng Mười 2011 - Xem xét l?i: 3.0
Áp d?ng
  • Microsoft Outlook 2010
T? khóa: 
KB2142236

Cung cấp Phản hồi