Verwendung des Teilsummen-Assistenten in Microsoft Excel

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 214249 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Zusammenfassung

Dieser Artikel veranschaulicht der Teilsummen-Assistenten in Microsoft Excel verwenden.

Mit dem bedingten Summe-Assistenten können Sie die Summen der Werte berechnen, die angegebene Bedingungen erfüllen. Es ist in Microsoft Excel-Versionen 97 und höher enthalten.

Das in diesem Artikel beschriebene Add-In wird ohne Gewähr zur Verfügung gestellt. Microsoft übernimmt keine Gewähr dafür, dass es in allen Situationen verwendet werden kann. Die Mitarbeiter des Microsoft Software Service können Ihnen zwar Hilfe bei der Installation und bei der bestehenden Funktionalität dieses Add-Ins bieten, doch Sie können dem Add-In keine neue Funktionalität hinzufügen.

Weitere Informationen

Der Teilsummen-Assistent-Unterstützung beim Schreiben von Formeln, die einen Satz von Werten addieren, die angegebene Bedingungen erfüllen. Es gibt verschiedene Add-Ins, die in Excel enthalten sind, jedoch die werden nicht standardmäßig geladen.

Im folgenden finden eine detaillierte Beschreibung der einzelnen Schritt im Assistenten gefolgt von einer Beschreibung zum Installieren des Assistenten und ein Beispiel für die Verwendung.

Schritt 1: Ermitteln der Datenbereich

In dieser Schritt geben Sie den Zellbereich mit den Daten, die für die bedingte Summe verwendet werden soll. Dieser Bereich muss Spaltenüberschriften und die Zellen, die zu summierenden Daten sowie Daten definieren der Bedingungen für die Aufnahme in die Summe enthalten. In den meisten Fällen bedeutet dies eine gesamte Liste im Arbeitsblatt auswählen.

Wie die meisten Excel-Daten-Tools identifiziert der Assistent eine Liste der Daten automatisch, wenn die ausgewählte Zelle in der Liste befindet, wenn der Assistent gestartet wird. Wenn die ausgewählte Zelle außerhalb der Liste befindet, müssen Sie es durch den richtigen Bereich mit der Maus auswählen oder durch Eingeben der geeigneten Bereich Beschreibung identifizieren.

Hinweis : Es ist wichtig, Spalte-Überschriften im Datenbereich in dieser Schritt angegebenen verfügen. Die Spaltenüberschriften werden in den folgenden Schritten des Assistenten verwendet.

Schritt 2: Identifizieren der Daten, die summiert werden und die Bedingungen für Inklusion

Zunächst müssen Sie wählen Sie die Spalte mit, die die Werte, die Summe Wenn die angegebenen Bedingungen erfüllt sind; eine Auswahlliste verwenden, die Spaltenüberschriften im Datenbereich enthält, die Sie in Schritt 1 angegeben.

Zweitens müssen Sie die Bedingungen für die Summe angeben. Jede Bedingung hat einen Parameter Bedingung (Spaltenüberschrift), einen Operator und einen Wert. Auswahllisten werden für die Parameter und Operatoren zur Verfügung gestellt, und Sie können entweder den Wert für die Bedingung aus der bereitgestellten Liste auswählen, oder Sie können einen Wert, der nicht aufgeführt ist eingeben.

Sie können bis zu sieben Bedingungen einrichten. Nachdem Sie Sie jede Bedingung festgelegt, klicken Sie auf Bedingung hinzufügen , um ihn der Liste der Bedingungen hinzuzufügen. Wenn Sie einen Fehler machen oder Sie eine Bedingung zu ändern müssen, klicken Sie auf Bedingung löschen , um die Liste zu überarbeiten.

Schritt 3: Auswählen den Typ der Ausgabe

Sie können zwei Typen der Ausgabe des Teilsummen-Assistenten auswählen:
  • Kopieren Sie nur die Formel zu einer einzelnen Zelle. Dieses Kontrollkästchen ist standardmäßig aktiviert.

    -oder-
  • Kopieren Sie die Formel und bedingte Werte.

    Dadurch wird die Formel sowie die Werte der Parameter Bedingung auf das Arbeitsblatt kopiert. Wenn Sie diese Option auswählen, können Sie die Werte der Parameter Bedingung ändern, ohne die Formel ändern oder den Assistenten erneut durchlaufen.

Schritt 4: Ermitteln der Ausgabe Zellen

In dieser Schritt erforderlichen Informationen hängt ab, welche Option Sie im Schritt 3 auswählen. Führen Sie eine der in den folgenden Schritten:
  • Wenn Sie die erste Option (d. h. Sie kopiert nur die Summe, die sich aus der aktuellen Parameter ergibt), in dieser Schritt Sie die Adresse der Zelle für das Ergebnis der bedingter Summe auf dem Arbeitsblatt angeben müssen. Sie können die Zelle mit der Maus auswählen, oder geben Sie den Zellbezug.

    -oder-
  • Wenn Sie die zweite Option in Schritt 3 (d. h. enthalten aktuelle Parameter sowie das Ergebnis im Arbeitsblatt) ausgewählt haben, müssen Sie die Zellbezüge für Bedingung für alle Parameter als auch als das Ergebnis bereitzustellen. Sie können die Zelle mit der Maus auswählen, oder geben Sie den Zellbezug. Sie finden eine zusätzliche Schritt für jede Bedingung, die Sie in Schritt 2 angegeben.
Hinweis : mit dem bedingten Summe-Assistenten der maximal sieben verschachtelte Wenn-Funktionen in Microsoft Excel nicht erhöht. Der Assistent wird die Schaltfläche Bedingung hinzufügen deaktiviert, wenn Sie das Limit von sieben Bedingungen erreichen.

Gewusst wie: Laden Sie den Teilsummen-Assistenten

Der Teilsummen-Assistent wird nicht standardmäßig geladen. Suchen Sie nach den Menüpunkt " Assistent ", um ermitteln, ob es, im Menü Extras geladen wurde. Es es ist nicht vorhanden, oder wenn Sie darauf zeigen, das Element Summe nicht vorhanden ist, müssen Sie das Add-in zu laden.

Um den Teilsummen-Assistenten zu laden, gehen Sie folgendermaßen vor:
  1. Klicken Sie im Menü Extras auf Add-ins
  2. Wählen Sie in der Liste Verfügbare Add-Ins Bedingter Summe-Assistent , und klicken Sie dann auf OK .
Weitere Informationen Downloaden einer Datei im Internet folgendem Artikel der Microsoft Knowledge Base:
119591So erhalten Sie Dateien vom Microsoft Support im Internet

Beispiel zur Verwendung des Teilsummen-Assistenten

  1. In ein neues Microsoft Excel-Arbeitsblatt einfügen die folgenden, mit der Bezeichnung Region in Zelle A1:
        Region   Date        Total Sales    Sales Rep
        South    1-Jan-96    $103,476.98    John Smith
        East     1-Jan-96    $57,400.35     John Smith
        North    5-Jan-96    $95,375.34     Mary Jones
        East     9-Jan-96    $143,564.6     John Smith
        West     9-Jan-96    $200,359.85    Mary Jones
        North    9-Jan-96    $204,014.46    Mary Jones
        South    9-Jan-96    $98,435.12     Mary Jones
        West    13-Jan-96    $65,678.41     John Smith
        West    14-Jan-96    $138,357.60    John Smith
        East    23-Jan-96    $69,189.58     John Smith
        North   23-Jan-96    $40,781.30     Mary Jones
        East    25-Jan-96    $89,053.68     Mary Jones
        North   31-Jan-96    $85,462.12     John Smith
        South   31-Jan-96    $199,980.15    Mary Jones
    					
  2. Sicherzustellen Sie, dass die ausgewählte Zelle in der Liste im Menü Extras , zeigen Sie auf Assistent , und klicken Sie dann auf Summe .
  3. Der Bereich im Dialogfeld Schritt 1 von 4
    $ A $ 1: $ D $ 15
    sollten identifiziert werden. Ist dies nicht der Fall, geben Sie den richtigen Bereich, und klicken Sie dann auf Weiter .
  4. Im Dialogfeld Schritt 2 von 4 im Feld Spalte Summe die Option Gesamtumsatz aus.
  5. Im Feld Spalte wählen Vertriebsmitarbeitern ; im Feld ist auswählen = ; im Feld dieser Wert , Mary Jones ; auswählen und klicken Sie dann auf Bedingung hinzufügen .
  6. Wählen Sie im Feld Spalte Datum aus ; Wählen Sie im Feld ist > aus; im Feld dieser Wert , geben Sie 10-Jan-96 ; und klicken Sie dann auf Bedingung hinzufügen .
  7. Klicken Sie auf Weiter .
  8. Wählen Sie im Dialogfeld Schritt 3 von 4 Kopieren nur die Formel zu einer einzelnen Zelle . Beachten Sie, dass das Ergebnis $ 329,815.13 angezeigt wird, und klicken Sie dann auf Weiter .
  9. Klicken Sie im Dialogfeld Schritt 4 von 4 Geben Sie die Zellenadresse F1 , und klicken Sie dann auf Fertig stellen .

Bekannte Probleme, die auftreten können, wenn Sie den Teilsummen-Assistenten verwenden

Wenn der Dateiname oder den Namen des Blattes zu lang ist, wird der Teilsummen-Assistent mit fehl ein "Laufzeitfehler 1004: FormulaArray-Methode des Range-Klasse ist fehlgeschlagen" Fehler, wenn folgende Bedingungen erfüllt sind:
  • Sie versuchen, die Kriterien und die Formel zu einem anderen Blatt in der Arbeitsmappe zu kopieren.
  • Sie gelten mehrere Bedingungen.
Wenn Excel die Zeichenfolge für die Formel Array erstellt, schließt Excel den Arbeitsmappennamen mit jeder Verweis Kriterien ein. Die Zeichenfolge kann die maximale 255 Zeichen für FormulaArray-Methode nicht überschreiten. Obwohl die Namen der Arbeitsmappe entfernt werden, wenn die Formel eingegeben wird, ist die Methode nicht erfolgreich, da die Zeichen-Grenze überschritten wurde.

Informationsquellen

Weitere Informationen über Add-Ins klicken Sie im Menü Hilfe auf Microsoft Excel-Hilfe , geben Sie Add-In - Programme für Microsoft Excel im Office-Assistenten oder im Antwort-Assistenten ein und dann auf Suchen klicken, um die zurückgegebenen Themen anzuzeigen.

Eigenschaften

Artikel-ID: 214249 - Geändert am: Mittwoch, 24. Januar 2007 - Version: 2.4
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 97 Standard Edition
  • Microsoft Excel 95 Standard Edition
  • Microsoft Excel 98 für Macintosh
Keywords: 
kbmt kbhowto KB214249 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 214249
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com