Descripción de cómo determina Excel el modo actual de cálculo

Seleccione idioma Seleccione idioma
Id. de artículo: 214395 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Resumen

En Microsoft Excel, todos los documentos abiertos actualmente utilizan el mismo modo de cálculo, independientemente del modo en que se hayan guardado.

Más información

Para ayudar a explicar cómo se determina el modo de cálculo, en este artículo se refiere a los documentos hipotéticos siguientes:
                                      Saved with this
   File name      Type of document    mode of calculation
   ------------------------------------------------------
   Auto1.xls      Workbook            Automatic
   Manual1.xls    Workbook            Manual
   Auto2.xls      Workbook            Automatic
				
Las instrucciones siguientes se aplican a los modos de cálculo en Excel:
  • El primer documento abierto utiliza la adjudica el modo de cálculo se guardó por última vez. Documentos abiertos posteriormente utilizan el mismo modo.

    Por ejemplo, si abre Auto1.xls y a continuación abre Manual1.xls, ambos documentsuse el cálculo automático (el modo utilizado por Auto1.xls). Si se abre Manual1.xlsand, a continuación, abre Auto1.xls, ambos documentos utilizarán cálculo manual.
  • Cambiar el modo de cálculo del modo de abrir un documento cambia para todos los documentos abiertos.

    Si Auto1.xls y Auto2.xls están bothopen, cambiar el modo de cálculo de Auto2.xls a manual también cambiará transmitida de Auto1.xls a manual.
  • Todas las hojas contenidas en un libro que utilice el mismo ofcalculation de modo.

    Si Auto2.xls contiene tres hojas de cálculo, transmitida de cálculo de la primera hoja de cálculo manual de cambios también el ofcalculation de modo manual en las otras dos hojas.
  • Si se cierran todos los demás documentos y crea un newdocument, el nuevo documento utiliza el mismo modo de cálculo que los documentos de previouslyclosed.

    Sin embargo, si se utiliza una plantilla, el modo de cálculo es el modo en el que se especifica en la plantilla.
  • Si ha cambiado el modo de cálculo en un libro y se guarda el archivo, se guarda el modo de cálculo actual.

    Si se abre Auto1.xls, se abre Manual1.xls y se guarda Manual1.xls inmediatamente, el modo de cálculo se guardará como automático.

Cómo controlar el modo de cálculo

Todos documentos abiertos utilizan el mismo modo de cálculo. Debe seguir procedimientos especiales para trabajar con documentos que utilizan distintos modos de cálculo. Por ejemplo, si está trabajando con Auto1.xls y desea abrir Manual1.xls en modo de cálculo manual, realice una de las siguientes acciones:
  • Establezca Auto1.xls en el modo de cálculo manual antes de openManual1.xls.
  • Cierre Auto1.xls (y cualquier otro documento abierto) antes de hiciste Manual1.xls.
Hay cuatro modos de cálculo que puede seleccionar en Microsoft Office Excel 2003 y en versiones anteriores. Estos modos son los siguientes:
  • Automático
  • Automático excepto tablas
  • Manual
  • Recalcular antes de guardar
En Microsoft Office Excel 2007 y Excel 2010, los cuatro modos de cálculo son como sigue:
  • Automático
  • Automático excepto para tablas de datos
  • Manual
  • Volver a calcular libro antes de guardarlo
   For this mode          Recalculation occurs when
   -------------------------------------------------------------------
   Automatic              You make any change to the document. All
                          affected parts of the document are
                          recalculated.

   Automatic              You make any change to the document. All
   except tables          affected parts of the document except tables are
                          recalculated. A table is recalculated only when a 
                          change is made to it.

   Manual                 You press the F9 key, click Options on the
                          Tools menu, click the Calculation tab, and
                          click the Calc Sheet button.

   Manual /               You press F9, or click Calc Sheet on the
   Recalculate before     Calculation tab on the Tools/Options menu, as
   Save                   well as every time you save the file.
				

Volver a calcular la hoja activa

Para actualizar sólo la hoja activa, utilice uno de los métodos siguientes:
  • Presione MAYÚS + F9.
  • En las versiones de andearlier de Excel 2003, haga clic enOpciones de En la página Herramientas menú y a continuación, haga clic en el Cálculo ficha, haga clic en el Hoja de cálculo botón para calcular únicamente la hoja activa.
  • En Excel 2007 y Excel 2010, haga clic enCalcular hoja en el menú de fórmulas en el grupo de cálculo .

Volver a calcular todos los documentos abiertos

Para actualizar todos los documentos abiertos, utilice uno de los métodos siguientes:
  • Presione la tecla F9.
  • En las versiones de andearlier de Excel 2003, haga clic enOpciones de En la página Herramientas menú, haga clic en el Cálculo ficha y, a continuación, haga clic en el Calcular ahora .
  • En Excel 2007 y Excel 2010, haga clic enCalcular ahora en el menú de fórmulas en el grupo de cálculo .

Cómo cambiar el modo de cálculo en Excel 2007 y Excel 2010

  1. Haga clic en el Botón de Microsoft Officey, a continuación, haga clic en Opciones de Excel.
  2. En la ficha fórmulas , seleccione el modo de cálculo que desea usar.

Cómo cambiar el modo de cálculo en Excel 2003 y en versiones anteriores de Excel

  1. Haga clic en Opciones de En la página Herramientas menú y a continuación, haga clic en el Cálculo ficha.
  2. Bajo Cálculo, haga clic en el modo de cálculo que desea usar.

Propiedades

Id. de artículo: 214395 - Última revisión: lunes, 20 de enero de 2014 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft Excel 97 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Office Excel 2003
  • Microsoft Office Excel 2007
  • Microsoft Excel 2010
Palabras clave: 
kbhowto kbinfo kbmt KB214395 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 214395

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com