Directory Services for NetWare (DSMN) Fails Intermittently with an Application Error in Swsvc.exe (0xc0000005 - AV)

Article translations Article translations
Article ID: 214460 - View products that this article applies to.
This article was previously published under Q214460
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

Symptoms

Directory Services for NetWare (DSMN) fails intermittently, generating the following Dr. Watson error:
The application swsvc.exe has generated an application error.
The following message is also written to the System Event Log:
Event ID: 4097: The application, exe\swsvc.dbg, generated an application error. The exception is c0000005 at address 77a056e1 (wcsicmp).

Cause

The DSMN service will fail periodically when attempting to rename an account (user, or local or a global group). For example, it fails when the pszOldAcctName is set to a null value and Windows NT attempts to dereference this Null pointer in the _wcsicmp() routine. There are several conditions in the SwpRenameAccount() routine where the pszOldAcctName string can be set to a Null value; however, Windows NT never tests this string before making a call to _wcsicmp() routine.

Resolution

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or the individual software update. For information on obtaining the latest service pack, please go to:
  • Windows Service Pack Center -or-

  • 152734 how to obtain the latest windows nt 4.0 service pack
For information on obtaining the individual software update, contact Microsoft Product Support Services. For a complete list of Microsoft Product Support Services phone numbers and information on support costs, please go to the following address on the World Wide Web:
http://support.microsoft.com/contactus/?ws=support

Status

Microsoft has confirmed that this is a problem in Windows NT version 4.0. This problem was first corrected in Windows NT version 4.0 Service Pack 5.

Properties

Article ID: 214460 - Last Review: November 2, 2013 - Revision: 3.0
Applies to
  • Microsoft Windows NT Server 4.0 Standard Edition
Keywords: 
kbnosurvey kbarchive kbbug kbfix kbqfe KB214460

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com