Error Message: The System Is Not Fully Installed

Article translations Article translations
Article ID: 216684 - View products that this article applies to.
This article was previously published under Q216684
Expand all | Collapse all

SYMPTOMS

When you use the System Preparation tool (Sysprep) on a computer running Windows NT, you may receive the following error message after rebooting:
Windows Message:
The system is not fully installed.
Please run setup again.

CAUSE

The registry setting that Sysprep uses to mark its progress is incorrectly set when some third-party network clients are installed on the computer.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or the individual software update. For information on obtaining the latest service pack, please go to:
  • Windows Service Pack Center -or-

  • 152734 how to obtain the latest windows nt 4.0 service pack
For information on obtaining the individual software update, contact Microsoft Product Support Services. For a complete list of Microsoft Product Support Services phone numbers and information on support costs, please go to the following address on the World Wide Web:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

WORKAROUND

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

NOTE: The following steps are to be used with the non-hotfixed version of Sysprep.exe only.

To prevent this issue from occurring, remove the third-party network client from the computer before making the image or running Sysprep.

To work around this issue, install a parallel installation of Windows NT 4.0 in a different partition and then use Registry Editor to change the data value of the SystemSetupInProgress value from 1 to 0:
  1. Start Registry Editor (Regedt32.exe).
  2. On the Window menu, click HKEY_LOCAL_MACHINE.
  3. On the Registry menu, click Load Hive.
  4. Click the %SystemRoot%\System32\Config\System file, and then click Open.
  5. Type a name for the key, and then click OK.
  6. Double-click the name you chose in the previous step.
  7. Double-click the Setup key.
  8. Double-click the SystemSetupInProgress value in the right pane.
  9. Change the data value from 1 to 0, and then click OK.
  10. Click the key name you chose in step 5, and then click Unload Hive on the Registry menu.
  11. Quit Registry Editor and then restart the computer.

STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0.

Properties

Article ID: 216684 - Last Review: June 11, 2012 - Revision: 3.0
APPLIES TO
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Keywords: 
kbhotfixserver kbqfe kbbug kbfix KB216684

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com