エラー メッセージ : システムのインストールが完全ではありません。

文書翻訳 文書翻訳
文書番号: 216684 - 対象製品
この記事は、以前は次の ID で公開されていました: JP216684
重要 : この資料には、レジストリの編集に関する情報が含まれています。レジストリを編集する前に、問題が発生した場合に備えて、レジストリの復元方法を理解しておいてください。復元方法の詳細については、Regedit.exe のヘルプ トピック「レジストリを復元する」、または Regedt32.exe のヘルプ トピック「レジストリ キーを復元する」を参照してください。
すべて展開する | すべて折りたたむ

現象

Windows NT で System Preparation ツール (Sysprep) を使用すると、再起動後に以下のエラー メッセージが表示されることがあります。
Windows メッセージ:
システムのインストールが完全ではありません。
セットアップを再実行してください。

原因

コンピュータにサード パーティ製ネットワーク クライアントがインストールされている場合、Sysprep がプログラムの進行状況を記録するために使用するレジストリが正しく設定されません。

解決方法

この問題を解決するには、Windows NT 4.0 の個別修正プログラムを入手します。
個別修正プログラムの入手方法については、Microsoft Product Support Services にお問い合わせください。Microsoft Product Support Services の電話番号一覧およびサポート料金については、次の Web ページを参照してください。
http://www.microsoft.com/japan/support/supportnet/default.asp

回避策

警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要です。マイクロソフトは、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。

レジストリの編集方法の詳細については、レジストリ エディタ (Regedit.exe) のヘルプ トピック「キーと値の変更」、または Regedt32.exe のヘルプ トピック「レジストリ情報の追加と削除」と「レジストリ情報の編集」を参照してください。レジストリを編集する前にレジストリのバックアップを必ず作成してください。Windows NT または Windows 2000 を実行している場合、システム修復ディスク (ERD) も更新する必要があります。

: 以下の手順は、修正されていないバージョンの Sysprep.exe を実行する場合にのみ使用してください。

この問題を回避するには、イメージの作成または Sysprep の実行の前に、サード パーティのネットワーク クライアントをコンピュータから削除してください。

この問題を回避するには、異なるパーティションに Windows NT 4.0 のパラレル インストールを行い、その後、レジストリ エディタを使用して、SystemSetupInProgress のデータ値を 1 から 0 に変更してください。
  1. レジストリ エディタ (Regedt32.exe) を起動します。
  2. [ウィンドウ] メニューで [HKEY_LOCAL_MACHINE] をクリックします。
  3. [レジストリ] メニューの [ハイブのロード] をクリックします。
  4. %SystemRoot%\System32\Config\System ファイルをクリックし、[開く] をクリックします。
  5. キーの名前を入力し、[OK] をクリックします。
  6. 前の手順 5. で選択した名前をダブルクリックします。
  7. [Setup] キーをダブルクリックします。
  8. 右のペインで SystemSetupInProgress 値をダブルクリックします。
  9. データ値を 1 から 0 に変更し、[OK] をクリックします。
  10. 手順 5. で選択したキー名をクリックし、[レジストリ] メニューの [ハイブのアンロード] をクリックします。
  11. レジストリ エディタを終了し、コンピュータを再起動します。

状況

マイクロソフトでは、これが Windows NT 4.0 にかかわる問題であることを確認済みです。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 216684 (最終更新日 2002-05-16) をもとに作成したものです。

プロパティ

文書番号: 216684 - 最終更新日: 2006年3月23日 - リビジョン: 1.1
この資料は以下の製品について記述したものです。
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
キーワード:?
kbhotfixserver kbbug kbfix kbwinnt400sp5fix KB216684
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com