Artikel-ID: 216783 - Geändert am: Dienstag, 27. Februar 2007 - Version: 6.4

Sie können nicht vollständig Terminal Server-Verbindung trennen.

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Problembeschreibung

Nachdem eine Terminaldienste-Client die Verbindung zu einem Terminalserver verliert, die Sitzung auf dem Terminalserver möglicherweise nicht in einen getrennten Zustand Übergang, stattdessen es bleiben aktiv, obwohl der Client vom Terminal Server physikalisch getrennt wird. Wenn der Client auf demselben Terminal Server, wieder in meldet eine völlig neue Sitzung hergestellt werden kann und die ursprüngliche Sitzung möglicherweise noch aktiv.

Ursache

Dieses Problem kann auftreten, da Terminalserver einen Keep Alive -Mechanismus implementiert.

Lösung

wichtig In diesem Abschnitt, Methode oder Aufgabe enthält Hinweise zum Ändern der Registrierung. Allerdings können schwerwiegende Probleme auftreten, wenn Sie die Registrierung falsch ändern. Stellen Sie daher sicher, dass Sie diese Schritte sorgfältig ausführen. Für zusätzlichen Schutz sichern Sie der Registrierung, bevor Sie ihn ändern. Anschließend können Sie die Registrierung wiederherstellen, wenn ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) Zum Sichern und Wiederherstellen der Registrierung in Windows

Windows NT 4.0 Terminal Server Edition

Gehen Sie folgendermaßen vor um um dieses Problem zu beheben:
  1. Wenden Sie das neueste Servicepack für Windows NT 4.0, Terminal Server Edition.
  2. Verwenden Sie den Registrierungseditor einen DWORD-Wert KeepAliveEnable mit einem positiven numerischen Wert von 1 (die Minute darstellt) zum folgenden Registrierungsschlüssel hinzufügen:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal-Server
  3. Doppelklicken Sie im Tool Terminal Server-Verbindungskonfiguration auf Rdp-Tcp , und klicken Sie dann auf Erweitert .
  4. Auf der für eine Verbindung unterbrochen oder wegen Zeitüberschreitung abgebrochen < eine Verbindung herstellen Aktion > der Sitzung, deaktivieren Sie die Option Benutzer Konfiguration übernehmen . Klicken Sie auf Trennen auf auf eine Verbindung unterbrochen oder wegen Zeitüberschreitung < eine Verbindung herstellen Aktion > der Sitzung, und klicken Sie dann auf OK .

Windows 2000 Server

Gehen Sie folgendermaßen vor um um dieses Problem zu beheben:
  1. Registrierungseditor verwenden einen DWORD-Wert KeepAliveEnable mit einem positiven numerischen Wert von 1 (der aktivieren steht) zum folgenden Registrierungsschlüssel hinzufügen:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal-Server
  2. Öffnen Sie Terminaldienstekonfiguration in Verwaltung , doppelklicken Sie auf RDP-Tcp im Ordner Netzwerkverbindungen , und klicken Sie dann auf die Registerkarte Sitzungen .
  3. Aktivieren Sie wählen Benutzereinstellungen außer Kraft setzen und stellen sicher, dass Sitzung trennen, ausgewählt ist, und klicken Sie dann auf OK .

Windows XP und Windows Server 2003

Gehen Sie folgendermaßen vor um um dieses Problem zu beheben:
  1. Klicken Sie auf Start , klicken Sie auf Ausführen , geben Sie gpedit.msc ein und klicken Sie dann auf OK .
  2. Erweitern Sie Computerkonfiguration , erweitern Sie Administrative Vorlagen , erweitern Sie Windows-Komponenten , und klicken Sie dann auf Terminaldienste .
  3. Doppelklicken Sie im rechten Fensterbereich auf Keep-Alive-Verbindungen .
  4. Klicken Sie auf aktiviert , und klicken Sie dann auf OK .
  5. Schließen der Gruppenrichtlinienobjekt-Editor, klicken Sie auf OK und beenden Sie Active Directory-Benutzer und-Computer.

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows NT Server 4.0, Terminal Server Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
Keywords: 
kbmt kbnetwork kbprb kbui KB216783 KbMtde
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 216783  (http://support.microsoft.com/kb/216783/en-us/ )
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