ターミナル サーバー接続を完全に切断できない

文書翻訳 文書翻訳
文書番号: 216783 - 対象製品
この記事は、以前は次の ID で公開されていました: JP216783
重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、レジストリの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986 Microsoft Windows レジストリの説明
すべて展開する | すべて折りたたむ

目次

現象

ターミナル サーバー クライアントがターミナル サーバーへの接続を失った後で、クライアントがターミナル サーバーから物理的に切断されていても、ターミナル サーバーのセッションは切断状態に移行しないでアクティブのままであることがあります。クライアントがそのターミナル サーバーに再びログオンした場合、まったく新しいセッションが確立され、元のセッションは依然としてアクティブのままであることがあります。

原因

この問題は、ターミナル サーバーに "キープアライブ" メカニズムが実装されていることが原因で発生することがあります。

解決方法

警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。

Windows NT 4.0 Terminal Server Edition

この問題を回避するには、次の手順を実行します。
  1. Windows NT 4.0 Terminal Server Edition の最新の Service Pack を適用します。
  2. レジストリ エディタを使用して、以下のレジストリ キーに DWORD 値 KeepAliveEnable を追加し、正の値 1 (1 分を表します) を設定します。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server
  3. [Terminal Server コネクション構成] ツールの [rdp-tcp] をダブルクリックして、[詳細] をクリックします。
  4. [接続が切断またはタイムアウトしたときの処理] で、[ユーザー構成を継承] オプションをオフにします。[接続が切断またはタイムアウトしたときの処理] で [切断] をクリックし、[OK] をクリックします。

Windows 2000 Server

この問題を回避するには、次の手順を実行します。
  1. レジストリ エディタを使用して、以下のレジストリ キーに DWORD 値 KeepAliveEnable を追加し、正の値 1 ("有効" を表します) を設定します。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server
  2. 管理ツールの [ターミナル サービスの構成] を開き、[接続] フォルダの [RDP-Tcp] をダブルクリックし、[セッション] タブをクリックします。
  3. [ユーザー設定より優先にする] をクリックして選択し、[セッションから切断する] が選択されていることを確認し、[OK] をクリックします。

Windows XP および Windows Server 2003

この問題を回避するには、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。gpedit.msc と入力し、[OK] をクリックします。
  2. [コンピュータの構成]、[管理用テンプレート]、[Windows コンポーネント] を順に展開し、[Terminal Services] をクリックします。
  3. 右側のウィンドウで、[キープアライブ接続] をダブルクリックします。
  4. [有効] をクリックして、[OK] をクリックします。
  5. グループ ポリシー オブジェクト エディタを閉じて、[OK] をクリックし、Active Directory ユーザーとコンピュータを終了します。

プロパティ

文書番号: 216783 - 最終更新日: 2006年3月10日 - リビジョン: 6.1
この資料は以下の製品について記述したものです。
  • Microsoft Windows NT Server 4.0, Terminal Server Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
キーワード:?
kbnetwork kbui kbprb KB216783
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com