Fehlermeldung beim Auswählen eines Hyperlinks in Office: „Der Internetserver oder Proxy konnte nicht gefunden werden“

Problembeschreibung

Wenn Sie in einem Office-Dokument einen Hyperlink erstellen und anschließend den Link auswählen, wird möglicherweise eine der folgenden Fehlermeldungen angezeigt:

<URL> kann nicht geöffnet werden. Der Internetserver oder Proxyserver kann nicht gefunden werden.

<URL> kann nicht geöffnet werden. Die angegebene Datei kann nicht geöffnet werden.

                             <URL> = der eingefügte Hyperlink.

Hinweis

Der Hyperlink funktioniert, wenn Sie ihn direkt in den Browser oder in das Feld „Öffnen“ des Dialogfelds „Ausführen“ (wählen Sie Start und dann Ausführen) eingeben.

Ursache

Dieses Problem tritt auf, wenn folgende Bedingungen vorliegen:

  • Sie verwenden Microsoft Internet Explorer:

    • Als Proxyserver – oder –
    • Mit einer Firewall, die keine HTTP-Anfragen in Ihrem lokalen Netzwerk zulässt
  • Internet Explorer ist nicht Ihr Standardbrowser.

  • Der Registrierungsschlüssel ForceShellExecute befindet sich nicht am folgenden Ort oder ist nicht auf 1 gesetzt:

    • Für 32-Bit-Versionen von Office unter 64-Bit-Betriebssystemen:

      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\9.0\Common\Internet

    • Für 32-Bit-Versionen von Office, die auf 32-Bit-Betriebssystemen installiert sind, oder 64-Bit-Versionen von Office, die auf 64-Bit-Betriebssystemen installiert sind:

      HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Common\Internet

    Hinweis

    Der Registrierungspfad hängt nicht von Ihrer Office-Version ab.

Problemumgehung

Wichtig

Dieser Abschnitt, diese Methode bzw. diese Aufgabe enthält eine Beschreibung der Schritte zum Bearbeiten der Registrierung. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher ist es wichtig, bei der Ausführung der folgenden Schritte sorgfältig vorzugehen. Für zusätzlichen Schutz sichern Sie die Registrierung, bevor Sie sie ändern. Sie können die Registrierung wiederherstellen, wenn ein Problem auftritt. Weitere Informationen zum Erstellen einer Sicherungskopie und Wiederherstellen der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:

322756 Sichern und Wiederherstellen der Registrierung in Windows

Hinzufügen des Unterschlüssels „Internet“ zur Registrierung und Festlegen seines Werts

Problemumgehung: Wenn der Unterschlüssel ForceShellExecute nicht vorhanden ist, fügen Sie ihn hinzu und legen den Wert fest. Wenn der Unterschlüssel ForceShellExecute vorhanden ist, legen Sie seinen Wert fest.

  1. Beenden Sie alle Programme, die derzeit ausgeführt werden.

  2. Wählen Sie Start und dann Ausführen aus. Geben Sie regedit in das Feld Öffnen ein, und klicken Sie dann auf OK.

  3. Wechseln Sie im Registrierungs-Editor zu einem der folgenden Unterschlüssel (falls die Schlüssel nicht vorhanden sind, erstellen Sie sie):

    • Für eine 32-Bit-Version von Office unter einer 64-Bit-Version von Windows:

      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\9.0\Common\Internet

    • Für eine 32-Bit-Version von Office unter einer 32-Bit-Version von Windows:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Common\Internet

    • Für eine 64-Bit-Version von Office unter einer 64-Bit-Version von Windows:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Common\Internet

  4. Stellen Sie sicher, dass der Unterschlüssel „Internet“ ausgewählt ist. Zeigen Sie im Menü Bearbeiten auf Neu und wählen Sie dann DWORD-Wert. Fügen Sie den folgenden Registrierungswert hinzu:

    Wertname: ForceShellExecute

  5. Doppelklicken Sie auf ForceShellExecute, und legen Sie 1 für „Wert“ fest. Wählen Sie OK aus.

  6. Klicken Sie im Menü „Datei“ des Registrierungs-Editors auf „Beenden“.

Wurde das Problem behoben?

Testen Sie, ob das Problem behoben ist. Wenn das Problem behoben ist, sind Sie mit diesem Abschnitt fertig. Wenn das Problem nicht behoben ist, wenden Sie sich an den Support.

Weitere Informationen

Nach Verwendung dieser Problemumgehung funktionieren Hyperlinks zu einem Microsoft Word-Dokument oder einem Microsoft Excel-Arbeitsblatt eventuell nicht mehr.

Office verwendet die Datei „Urlmon.dll“, um alle Internetübergänge zu verwalten.

In diesem Fall sendet die Datei Urlmon.dll eine Anfrage zum Abrufen einer Datei über http:// durch den Proxy-Server. Der Proxyserver erkennt, dass die Anforderung von Internet Explorer stammt, basierend auf dem HTTP-Browsertyp-Feld der http://request. Es wird dann der Fehler 403 mit dem Hinweis „Zugriff verweigert“ angezeigt.

Die Datei „Urlmon.dll“ erhält dies und gibt die zuvor erwähnte Fehlermeldung zurück. Der Fehler bedeutet, dass die Anforderung fehlgeschlagen ist, aber es wird nicht angegeben, warum sie fehlgeschlagen ist.

Die Problemumgehung besteht darin, ShellExecute() für die URL zu verwenden. Dadurch kann das Betriebssystem die URL im Standardbrowser starten. Wenn der Standardbrowser nicht durch den Proxyserver eingeschränkt ist, wird die richtige Seite angezeigt.