Mensaje de error al seleccionar un hipervínculo en Office: "No se puede localizar el servidor de Internet o el servidor proxy"

Síntomas

Al crear un hipervínculo en un documento de Office y, a continuación, seleccionar el vínculo, puede recibir uno de estos mensajes de error:

No se puede abrir la <URL>. No se puede localizar el servidor de Internet o el servidor proxy.

No se puede abrir la <URL>. No se puede abrir el archivo especificado.

<URL> = el hipervínculo que has insertado.

Nota:

El hipervínculo funciona si lo escribe directamente en el navegador o en el cuadro de diálogo Abrir del cuadro de diálogo Ejecutar (seleccione Iniciar y, a continuación, Ejecutar).

Causa

Este problema se produce cuando se cumplen las condiciones siguientes:

  • Está utilizando Microsoft Internet Explorer:

    • Como un servidor proxy o
    • Con un firewall que no permite que las solicitudes HTTP se coloquen en la red local
  • Internet Explorer no es su navegador predeterminado.

  • La clave de registro ForceShellExecute no está presente en la siguiente ubicación o no está establecida en 1:

    • Para versiones de 32 bits de Office instaladas en sistemas operativos de 64 bits:

      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\9.0\Common\Internet

    • Para versiones de 32 bits de Office instaladas en sistemas operativos de 32 bits o versiones de 64 bits de Office instaladas en sistemas operativos de 64 bits:

      HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Common\Internet

    Nota:

    La ruta de registro no depende de la versión de Office.

Solución alternativa

Importante

Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. En consecuencia, asegúrese de seguir estos pasos cuidadosamente. Para mayor protección, cree una copia de seguridad del registro antes de modificarlo. Después, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el Registro, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

322756 Hacer una copia de seguridad del Registro y restaurarlo en Windows

Añadir la subclave de Internet al Registro y configurar los datos de valor

Para solucionar este problema, configure los datos de valor de la subclave ForceShellExecute. Si no está presente, agréguela antes.

  1. Cierre cualquier programa que se esté ejecutando.

  2. Haga clic en Inicio y, a continuación, en Ejecutar. Escriba regedit en el cuadro Abrir y, a continuación, haga clic en Aceptar.

  3. En el Editor del Registro, vaya a una de las siguientes subclaves (si no existen, créelas):

    • Para una versión de Office de 32 bits en una versión de Windows de 64 bits:

      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\9.0\Common\Internet

    • Para una versión de Office de 32 bits en una versión de Windows de 32 bits:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Common\Internet

    • Para una versión de Office de 64 bits en una versión de Windows de 64 bits:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Common\Internet

  4. Asegúrese de que la subclave de Internet esté seleccionada. En el menú Editar, seleccione Nuevo y, a continuación, seleccione el valor DWORD. Añada el siguiente valor de registro:

    Nombre del valor: ForceShellExecute

  5. Haga doble clic en ForceShellExecute y, a continuación, configure los datos de valor en 1. Seleccione Aceptar.

  6. En el menú Registro, haga clic en Salir.

¿Esta información le ha ayudado a solucionar el problema?

Compruebe si se ha solucionado el problema. Si el problema se soluciona, ha terminado con esta sección. Si el problema no se soluciona, póngase en contacto con el soporte técnico.

Más información

Es posible que un hipervínculo no se redirija a un documento de Microsoft Word o a una hoja de cálculo de Microsoft Excel después de utilizar esta solución alternativa.

Office usa el archivo Urlmon.dll para controlar todas las transiciones de Internet.

En este caso, el archivo Urlmon.dll envía una solicitud para obtener un archivo mediante http:// a través del servidor proxy. El servidor proxy observa que la solicitud procede de Internet Explorer, en función del campo Agente de usuario HTTP de http://request. A continuación, da un error 403, básicamente diciendo "Acceso denegado."

El archivo Urlmon.dll lo capta y simplemente devuelve el mensaje de error previamente mencionado. El error significa que la solicitud ha fallado, pero nunca indica por qué se ha producido un error.

La solución alternativa consiste en utilizar un ShellExecute() en la URL. Esto permite que el sistema operativo inicie la dirección URL en el explorador predeterminado. Si el navegador predeterminado no está restringido por el servidor proxy, se muestra la página adecuada.