Messaggio di errore durante la selezione del collegamento ipertestuale in Office: "Impossibile individuare il server Internet o il server proxy"

Sintomi

Quando si crea un collegamento ipertestuale in un documento di Office e poi si seleziona il collegamento, è possibile che venga visualizzato uno dei seguenti messaggi di errore:

Impossibile aprire <l'URL>. Impossibile individuare il server Internet o il server proxy.

Impossibile aprire <l'URL>. Impossibile aprire il file specificato.

                             <URL> = collegamento ipertestuale inserito.

Nota

Il collegamento ipertestuale funziona se viene digitato direttamente nel browser o nella casella Apri della finestra di dialogo Esegui (selezionare Start e quindi Esegui).

Causa

Questo problema si verifica in presenza delle seguenti condizioni:

  • Si sta utilizzando Microsoft Internet Explorer:

    • Come un server proxy -oppure-
    • Con un firewall che non consente l'inserimento di richieste HTTP nella rete locale
  • Internet Explorer non è il browser predefinito.

  • La chiave del Registro di sistema ForceShellExecute non è presente nella posizione seguente o non è impostata su 1:

    • Per le versioni a 32 bit di Office installate nei sistemi operativi a 64 bit:

      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\9.0\Common\Internet

    • Per le versioni a 32 bit di Office installate su sistemi operativi a 32 bit o versioni a 64 bit di Office installate su sistemi operativi a 64 bit:

      HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Common\Internet

    Nota

    Il percorso del Registro di sistema non dipende dalla versione di Office in uso.

Soluzione alternativa

Importante

In questa sezione, metodo o attività viene illustrata la procedura per modificare il Registro di sistema. Poiché l'errata modifica del Registro di sistema può causare seri problemi, Di conseguenza, attenersi scrupolosamente alla procedura indicata. Per una maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. In questo modo sarà possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni sull'esecuzione del backup e del ripristino del Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

322756 Come eseguire il backup e il ripristino del Registro di sistema in Windows

Aggiungere la sottochiave Internet al Registro di sistema e impostare i dati valore

Per risolvere questo problema, aggiungere la sottochiave ForceShellExecute, se non è presente, e impostare i dati valore; se è presente, impostare i dati valore della sottochiave ForceShellExecute.

  1. Chiudere tutti i programmi in esecuzione.

  2. Fare clic su Start, quindi scegliere Esegui. Digitare regedit nella casella Apri, quindi selezionare OK.

  3. Nell'editor del Registro di sistema, individuare una delle seguenti sottochiavi (crearle se non esistono):

    • Per una versione a 32 bit di Office su una versione a 64 bit di Windows:

      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\9.0\Common\Internet

    • Per una versione a 32 bit di Office su una versione a 32 bit di Windows:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Common\Internet

    • Per una versione a 64 bit di Office su una versione a 64 bit di Windows:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Common\Internet

  4. Assicurarsi che la sottochiave Internet sia selezionata. Scegliere Nuovo dal menu Modifica e quindi selezionare Valore DWORD . Aggiungere il seguente valore del Registro di sistema:

    Nome valore: ForceShellExecute

  5. Fare doppio clic su ForceShellExecute e quindi impostare i Dati valore su 1. Seleziona OK.

  6. Scegliere Esci dal menu del Registro di sistema.

Il problema è stato risolto?

Verificare se il problema è stato risolto. Se il problema è stato risolto, questa sezione è terminata. Se il problema non viene risolto, contattare il supporto.

Ulteriori informazioni

Un collegamento ipertestuale potrebbe non condurre a un documento di Microsoft Word o un foglio di lavoro di Microsoft Excel dopo aver utilizzato questa soluzione alternativa.

Office utilizza il file Urlmon.dll per gestire tutte le transizioni Internet.

In questo caso, il file Urlmon.dll invia una richiesta per ottenere un file http:// tramite il server proxy. Il server proxy vede che la richiesta proviene da Internet Explorer, in base al campo Agente utente HTTP di http://request. A questo punto restituisce un messaggio di errore 403: "Accesso negato".

Il file Urlmon.dll riceve questo messaggio e mostra il messaggio di errore menzionato in precedenza. L'errore indica che la richiesta non è riuscita, ma non indica mai il motivo per cui è fallita.

La soluzione alternativa consiste nell'utilizzare ShellExecute() nell'URL. Ciò consente al sistema operativo di avviare l'URL nel browser predefinito. Se il browser predefinito non è limitato dal server proxy, viene visualizzata la pagina corretta.