文書番号: 218160 - 最終更新日: 2004年12月27日 - リビジョン: 1.4

最適化を実行するディスクを選択するとディスク デフラグ ツールが応答を停止する

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目次

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現象

最適化を実行するディスクを選択すると、ディスク デフラグ ツールが応答を停止 (ハング) することがあります。

原因

この問題は、ファイルまたはフォルダが破損しているか、ハード ディスクに不良セクタが存在するために発生することがあります。

この問題は、バックグラウンドで実行中のプログラムがハード ディスクにアクセスしている場合にも発生することがあります。

解決方法

この問題を回避するには、以下の手順を実行します。
  1. すべてのファイルが表示されるように Windows を設定します。この設定を行うには、エクスプローラを開き、[ツール] メニューの [フォルダ オプション] をクリックします。
  2. [表示] タブをクリックして [すべてのファイルを表示する] をクリックし、[適用] をクリックして [OK] をクリックします。
  3. C:\Windows フォルダから Applog フォルダを削除し、ディスク クリーンアップ ツールを実行します。
ディスク クリーンアップ ツールでは、インターネット一時ファイル、一時ファイル (.tmp ファイル) およびその他のオプションのコンポーネントの削除に便利なインターフェイスが提供されています。ディスク クリーンアップ ツールを起動するには、以下の手順を実行します。

  1. [スタート] ボタンをクリックして [プログラム]、[アクセサリ]、[システム ツール] の順にポイントし、[ディスク クリーンアップ] をクリックします。
  2. クリーンアップするドライブを選択し、[OK] をクリックします。
  3. 削除する必要があるファイルが選択された状態で、ディスク クリーンアップのメニューが表示されます。 : 自動で選択されていない他の項目も削除する場合は、それらを同時に削除することもできます。ディスク クリーンアップ ツールに精通していない場合、別の機会にそれらの項目を削除することができます。 ディスク クリーンアップ ツールの詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    186099? (http://support.microsoft.com/kb/186099/EN-US/ ) Description of the Disk Cleanup Tool in Windows 98
    186099 ? (http://support.microsoft.com/kb/186099/JA/ ) ディスク クリーンアップ ツールについて
Applog フォルダと一時ファイルを削除したら、スキャンディスクを実行し、その後、再度ディスク デフラグ ツールを実行します。

リアル モードのスキャンディスク

: Windows Millennium Edition (Me) ではリアル モードはサポートされていません。リアル モードを使用する必要がある場合は、起動ディスクを使用してコンピュータを起動し、スキャンディスクを実行します。

スキャンディスク ユーティリティを実行してもエラーが検出されなかった場合は、Safe モードでディスク デフラグ ユーティリティを実行します。それでもディスクが最適化されない場合は、MS-DOS プロンプトから (リアル モードで) スキャンディスクを実行します。

まず、以下の手順に従って、クラスタ スキャンの実行中、ディスクのタイムアウトを検出して各クラスタを 5 回ずつ確認するようにスキャンディスクを構成します。
  1. Windows\Command フォルダで Scandisk.ini ファイルを見つけます。このファイルをダブルクリックし、メッセージが表示されたら、メモ帳などの任意のテキスト エディタを使用してファイルを開きます。
  2. ファイル内で [Environment] セクションを見つけます。このセクションが存在しない場合は、以下のパラメータでセクションを作成します。
    [Environment]
    ScanTimeOut=On
    NumPasses=5
    既に "ScanTimeOut=" 行と "NumPasses=" 行が存在する場合でも、値が異なるときは上記の値に変更します。
  3. Scandisk.ini ファイルを保存して閉じます。
  4. [スタート] ボタンをクリックして [シャットダウン] をクリックし、[MS-DOS モードで起動する] をクリックして [OK] をクリックします。
  5. コマンド プロンプトで次の行を入力し、Enter キーを押してスキャンディスクを実行します。
    scandisk <ドライブ>:
    <ドライブ> にはスキャンするハード ディスクのドライブ文字を入力します。スキャンディスクからクラスタ スキャンを実行するように求めるメッセージが表示された場合はクラスタ スキャンを実行し、スキャンディスクで検出されたエラーを修復し、作成されたログ ファイルを確認して保存します。
  6. スキャンディスクが完了したら exit と入力し、Enter キーを押して Windows 98 に戻ります。
  7. 再度ディスク デフラグ ツールを実行します。
上記の手順を実行しても問題が解決しない場合、使用しているハード ディスク専用の診断ツールを実行する必要がある場合があります。そのような診断ツールがコンピュータに付属していない場合は、ハードウェアの製造元に問い合わせてください。コンピュータの購入後ハード ディスクをアップグレードしていて、そのハードディスク用の診断ツールがない場合、ハードウェアの製造元の Web サイトから診断ツールのファイルをダウンロードできる可能性があります。詳細については、使用しているハード ディスクの製造元に問い合わせてください。


実行中のプログラムの終了方法

1. Ctrl + Alt + Del キーを押します。

2. [プログラムの強制終了] ダイアログ ボックスの一覧で、Explorer と Systray 以外の任意のプログラムをクリックし、[終了] をクリックします。再度 [終了] をクリックするように求めるメッセージが表示された場合は、再度 [終了] をクリックします。

3. [プログラムの強制終了] ダイアログ ボックスの一覧で、Explorer と Systray 以外の各プログラムに対して、手順 1. 〜 2. を繰り返し実行します。

4. ディスク デフラグ ツールを実行します。

状況

この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

詳細

ディスク デフラグ ツール使用時に発生する問題の関連情報について参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
186978? (http://support.microsoft.com/kb/186978/EN-US/ ) "Drive's Contents Have Changed: Restarting..." Message When You Use the Disk Defragmenter Tool
259030? (http://support.microsoft.com/kb/259030/EN-US/ ) APC PowerChute Plus Causes Disk Defragmenter to Hang

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 218160? (http://support.microsoft.com/kb/218160/EN-US/ ) (最終更新日 2001-09-17) を基に作成したものです。

この資料は以下の製品について記述したものです。
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows Millennium Edition
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