FP2000 : Erreur exploration des pages de résultats de la base de données après la publication de site Web sur disque

Traductions disponibles Traductions disponibles
Numéro d'article: 219170 - Voir les produits auxquels s'applique cet article
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Agrandir tout | Réduire tout

Sommaire

Symptômes

Après avoir publié un site Web sur disque sur un serveur Web, message d'erreur suivant peut s'afficher lorsque vous affichez un aperçu de la page dans le navigateur sur les pages qui contiennent des zones de résultats de base de données :
Erreur de requête de base de données
La connexion de base de données nommée 'DatabaseName' n'est pas défini.

Ce problème peut se produire si :
* La connexion a été supprimée à partir du web
* le fichier «global.asa» manque ou contient des erreurs
* le dossier racine n'a pas d'autorisations de script activée
* le site web n'est pas marqué comme une application root
où DatabaseName est le nom de votre connexion de base de données.

Cause

Ce problème se produit lorsque le Web n'est pas marqué comme racine d'application.

Le Web n'est pas créé automatiquement en tant que racine d'application. Les fonctionnalités Active Server Pages (ASP) et base de données ne fonctionnent pas, sauf si le Web fait partie d'une racine d'application.

Résolution

Pour résoudre ce problème, appliquez l'une des méthodes suivantes.

Méthode 1: Vérifier la connexion à la base de données

Pour vérifier la connexion de base de données, procédez comme suit :
  1. Ouvrez le site Web sur le serveur.
    1. Dans le menu fichier, cliquez sur Ouvrir un site Web.
    2. Dans la zone Nom du dossier, tapez le nom du site Web. (Exemple : http://localhost/myweb)
    3. Cliquez sur Ouvrir.
  2. Dans le menu Outils, cliquez sur Paramètres du site Web.
  3. Cliquez sur l'onglet base de données.
  4. Sélectionnez la connexion de base de données, cliquez sur Vérifier. Répétez cette procédure pour chaque base de données dans la liste.

Méthode 2: Définir le dossier racine pour autoriser l'exécution de programmes

Pour définir le dossier racine pour permettre aux programmes à exécuter, procédez comme suit :
  1. Ouvrez le site Web sur le serveur.
    1. Dans le menu fichier, cliquez sur Ouvrir un site Web.
    2. Dans la zone Nom du dossier, tapez le nom du site Web. (Exemple : http://localhost/myweb)
    3. Cliquez sur Ouvrir.
  2. Dans le menu affichage, cliquez sur dossiers.
  3. Dans la liste des dossiers, cliquez avec le bouton droit sur le dossier de niveau supérieur, puis cliquez sur Propriétés.
  4. Activez la case à cocher Autoriser les programmes à exécuter, puis cliquez sur OK. Remarque : dans les sous-dossiers qui contiennent des ASP, il se peut que vous deviez cliquez avec le bouton droit sur le dossier et activez la case à cocher Autoriser les programmes à exécuter pour ASP fonctionner correctement.

    Sites Web hébergés sur Microsoft Internet Information Server 4.0 avec les extensions serveur FrontPage 2000 ou sur Internet Information Services 5.0 devez également disposer d'une racine d'application créée. Cliquez sur l'onglet répertoire dans le Gestionnaire des services Internet, puis cliquez sur créer.

Méthode 3: Création d'une page à l'aide de la connexion à la base de données

Pour créer une nouvelle page à l'aide de la connexion de base de données, procédez comme suit :
  1. Ouvrez une nouvelle page dans le mode page de FrontPage.
  2. Dans le menu Insertion, pointez sur la base de données et cliquez sur résultats.
  3. Dans étape un de l'Assistant Requête de base de données, sélectionnez l'option utiliser une base de données existante et sélectionnez votre base de données dans la liste.
  4. Cliquez sur suivant et acceptez toutes les valeurs par défaut.
  5. Lorsque l'Assistant est terminé, enregistrez la page sur le Web (sur le serveur). Remarque : après la page initiale a été enregistrée, vous pouvez supprimer le fichier créé à l'aide de cette méthode.

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés au début de cet article.

Plus d'informations

Si vous hébergez votre site Web sur Internet Information Server 3.0 avec les extensions serveur FrontPage 2000, consultez l'article suivant dans la base de connaissances Microsoft :
215365Erreur du serveur : Le dossier ' / CGI-bin ' est marqué exécutable

Propriétés

Numéro d'article: 219170 - Dernière mise à jour: samedi 1 février 2014 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft FrontPage 2000 Standard
Mots-clés : 
kbnosurvey kbarchive kbmt kbbug kbpending KB219170 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 219170
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com