Article ID: 219380 - Last Review: November 1, 2006 - Revision: 2.5

SP4 RAS server hangs up when RAS client tries to connect as Windows NT 3.1 dial-up server

This article was previously published under Q219380
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SYMPTOMS

When a Microsoft Windows NT 4.0 RAS client tries to connect to a RAS server computer running Windows NT Server 4.0 Service Pack 4, the RAS server unexpectedly hangs up the connection.

CAUSE

This problem occurs because the Ndiswan.sys driver for the RAS server in this particular hardware configuration becomes deadlocked. The deadlock occurs in the code that causes the NdisWanSend() API call to quit without contacting the RAS client. The RAS server then hangs up.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or the individual software update. For information on obtaining the latest service pack, please go to:
For information on obtaining the individual software update, contact Microsoft Product Support Services. For a complete list of Microsoft Product Support Services phone numbers and information on support costs, please go to the following address on the World Wide Web:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS (http://support.microsoft.com/default.aspx?scid=fh;en-us;cntactms)

STATUS

Microsoft has confirmed that this is a problem in Windows NT Server 4.0 and Windows NT Server 4.0 Service Pack 4. This problem was first corrected in Windows NT Server 4.0 Service Pack 5.

APPLIES TO
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT 4.0 Service Pack 4
Keywords: 
kbhotfixserver kbqfe kbbug kbfix kbqfe KB219380
 

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