The "All Day" field is marked with "No" when you access a meeting request that has a duration time that is more than 24 hours by using a mobile client through ActiveSync in an Exchange Server 2007 environment

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Article ID: 2201236 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • You access a mailbox which is hosted on a Microsoft Exchange Server 2007 server by using a mobile client through ActiveSync.
  • The mailbox has a meeting request that has a duration time that is more than 24 hours.
In this scenario, the mobile client does not treat the meeting request as an all day event meeting request. Additionally, the All Day field is marked with "No". However, if you access the mailbox by using Microsoft Office Outlook, the all day flag of the meeting request in Outlook client is set correctly.

CAUSE

This problem occurs because Exchange Server 2007 misses the scenario that an all day event meeting request spans across multiple days in the ActiveSync component.

RESOLUTION

To resolve this problem, install the following update rollup:
2407025 Description of Update Rollup 2 for Exchange Server 2007 Service Pack 3

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 2201236 - Last Review: December 14, 2010 - Revision: 1.0
APPLIES TO
  • Microsoft Exchange Server 2007 Service Pack 3, when used with:
    • Microsoft Exchange Server 2007 Enterprise Edition
    • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbqfe kbfix kbexpertiseinter kbhotfixrollup kbsurveynew KB2201236

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