Help and Support
 

powered byLive Search

[VI60] "Web サーバーに接続できません" のトラブルシューティング

文書番号:220166
最終更新日:2007年7月2日
リビジョン:1.1
この記事は、以前は次の ID で公開されていました: JP220166

現象

新しい Visual InterDev 6.0 プロジェクトを作成する際に、次のエラーが発生することがあります。
Web サーバーに接続できません。
または、既存の Web プロジェクトを開いたり、修正したり、保存したりしようとすると、次のエラーが表示されることがあります。
HTTP エラーが発生しました。サーバーは要求を完了できませんでした。インターネット サービス プロバイダまたは Web サーバー管理者に連絡し、サーバーに FrontPage Server Extensions がインストールされ、Web アプリケーションがサーバー上に存在することを確認してください。

先頭へ戻る

原因

このエラーは、Visual InterDev が Web サーバー上の FrontPage Server Extensions (FPSE) との接続を確立できないことを表しています。この問題は、次のように分類することができます。
? クライアントの問題 : Visual InterDev が正しくセットアップされていない、または、通信していない (クライアント ライブラリ)。
? ネットワークの問題 : TCP/IP、プロキシ サーバー、DNS、SSL など。
? サーバーの問題 : FPSE のセットアップまたは構成が正しく行われていない。Web サーバーの問題。

先頭へ戻る

解決方法

次の手順を使って、通信に失敗している個所の切り分けを行ってください。
1. Web サーバーが動作している事を確認します。テスト用の .htm および .asp ページをブラウズして、Web サーバーの基本的な機能をテストします。ページが正しく表示されない場合は、IIS または Personal Web Server のインストールに関するトラブルシューティングを実施してください。
2. FrontPage Server Extensions がインストールされていることを確認します。http://<サーバー名>/_vti_bin/shtml.dll をブラウズしてください。次に示す 2 つのエラー メッセージのいずれかが表示されます。
FrontPage 2000 Server Extensions:
この HTML でないページ "" で FrontPage Server Extensions の Smart HTML インタープリタは実行できません。
または

FrontPage 98 Server Extensions:
FrontPage エラー。ユーザー : このサイトの Webmaster に詳細を報告してください。Webmaster : 詳細については、サーバーのアプリケーション イベント ログを見てください。
上記のメッセージが表示されない場合は、FrontPage Server Extensions がインストールされていません。次の Web ページから最新バージョンをダウンロードしてください。
http://msdn2.microsoft.com/en-us/library/aa140179(office.10).aspx (http://msdn2.microsoft.com/en-us/library/aa140179(office.10).aspx)
3. FrontPage Server Extensions のバージョンを確認します。http://<サーバー名>/_vti_inf.html をブラウズします。「FrontPage 設定に関する情報」という見出しのページが表示されます。このページのソースを表示します。"FPVersion=" の後ろに FrontPage Server Extensions のバージョンが表示されます。推奨される FrontPage Server Extensions のバージョンは、4.0.2.2717 以上です。最新バージョンをダウンロードするには、次の Web ページにアクセスしてください。
http://msdn2.microsoft.com/en-us/library/aa140179(office.10).aspx (http://msdn2.microsoft.com/en-us/library/aa140179(office.10).aspx)
4. Server Extensions が正しくインストールされているかどうかを確認します。

FrontPage 2000 のサーバー拡張機能を使用している場合は、MMC を開き、[既定の Web サイト] または該当する Web サイトを右クリックして、[すべてのタスク] をクリックします。[Server Extensions の設定] が表示される場合は、その Web サイトではサーバー拡張が有効になっていないことを示しています。このオプションをクリックしてウィザードを起動し、画面の指示に従ってください。

[Server Extensions の確認] が表示される場合、その Web サイトには拡張機能がインストールされています。このオプションを選択し、Web サイトを分析して一般的な問題を修正する診断プログラムを起動してください。

Web サイトを右クリックしても [すべてのタスク] の項目が表示されない場合は、FrontPage 2000 の拡張機能がこのコンピュータにインストールされていないか、拡張機能用の MMC スナップインがセットアップ中に有効にされていません。該当する場合は、上記のリンクからこの拡張機能をインストールしてください。拡張機能のスナップインを有効にするには、インターネット サービス マネージャでメニューの [コンソール] をクリックします。

注 : Windows 2000 の場合は、[インターネット インフォメーション サービス] ウィンドウを閉じ、[管理ツール] グループの [インターネット サービス マネージャ] アイコンを右クリックして [作成者] を選択し、[コンソール] メニューを有効にします。[スナップインの追加と削除] メニュー項目をクリックします。[拡張] タブで、[FrontPage Server Extensions] のチェック ボックスがオンになっていることを確認します。これで、[Server Extensions の設定] を行い、その後に [Server Extensions の確認] を実行できます。

Visual InterDev と FrontPage Server Extensions に関するすべての Knowledge Base 資料に対して、キーワード kbFrontPage、kbServer、kbVisID600 で検索を行います。

5. プロキシ サーバーの問題 : ローカルの LAN 上で開発を行っている場合に、プロキシまたはファイアウォールの外側にある Web サーバーにアクセスする必要がある場合は、プロキシの設定をオフにします。これを行うには、Visual InterDev で [ツール] メニューの [オプション] をクリックします。[プロジェクト] および [Web プロキシ設定] を選択します。[システム設定を使用] チェック ボックスをオフにします。プロキシ サーバーは、デザイン時のセキュリティ処理で使われる Windows NT チャレンジ/レスポンス認証を妨害する可能性があります。 関連情報については、次の文書番号をクリックして Microsoft Knowledge Base を参照してください。
195954 (http://support.microsoft.com/kb/195954/EN-US/) PRB: "Unable to Contact Web Server" Error Creating New Project
6. クライアント ライブラリの問題 : Visual InterDev によって使用される DLL が未登録になっている可能性があります。[スタート] メニューの [ファイル名を指定して実行] をクリックして、次の行を入力します。
Regsvr32 C:\<Windows フォルダ>\System\FP30wec.dll
指定したファイルが正常に登録されたことを示す確認メッセージが表示されます。Visual InterDev を起動して、プロジェクトの作成を試みてください。 関連情報については、次の文書番号をクリックして Microsoft Knowledge Base を参照してください。
218167 (http://support.microsoft.com/kb/218167/EN-US/) PRB: Visual InterDev Is Not Installed Correctly on This Computer
7. TCP/IP のチェック : FrontPage Server Extensions 2000 と一緒に TCPTest ユーティリティがインストールされます。これは、基本的な WinSock32 の機能をチェックするために使われます。TCPTest ユーティリティは、コンピュータの以下の場所にあります。
Program Files\Common Files\Microsoft Shared\web server extensions\40\bin\tcptest.exe
8. DNS またはポートの問題 : Web プロジェクト ウィザードのステップ 1 でサーバー名の入力を求められたら、次の例に示すように ServerIP:PortNumber の形式で Web サーバーの IP アドレスを入力してください。
157.54.123.41:80
これで正常に動作する場合、お使いのネットワークには DNS 解決に関する問題があります。管理者が標準以外 (80 が HTTP に対するデフォルト値です) のポートに Web サーバーをセットアップしていた場合は、必ず正しいポートを入力するようにしてください。
9. Personal Web Server の問題 : Window 95 や Windows 98 の Personal Web Server では、リモートの FrontPage Server Extensions 接続はサポートされません。Visual InterDev と Personal Web Server は同じコンピュータにインストールする必要があります。また、Visual InterDev と一緒に使用する場合に推奨される Personal Web Server のバージョンは 4.x です。これは Visual Studio や Visual InterDev の CD の NTOPTPAK フォルダにあります。Personal Web Server (1.0 か 1.0a) の以前のバージョンをアンインストールし、Visual Studio の CD からインストールを行ってください。Personal Web Server 4.x は、次の Web サイトからダウンロードすることもできます。
http://www.microsoft.com/japan/products/ntserver/option_pack/download.htm
10. Secure Sockets Layer (SSL) の問題 : Visual InterDev は SSL を使用している Web サーバーに接続できますが、これは 40 ビットの暗号化に制限されます (128 ビットはサポートされません)。Web サーバーが 128 ビットの暗号化を要求する場合、接続は失敗します。また Visual InterDev では、次の認証局によるサーバー証明書しか認識されません。
? Verisign-Secure Server Certification Authority
? RSA Data Security, Inc.
? AT&T-Certificate Services
? AT&T-Directory Services
関連情報については、次の文書番号をクリックして Microsoft Knowledge Base を参照してください。
238662 (http://support.microsoft.com/kb/238662/EN-US/) INFO: Using Visual InterDev and Secure Sockets Layer
11. お使いの Web サーバーにある _vti_bin 仮想ディレクトリが、Windows 2000 上で [スクリプトと実行可能ファイル] に設定された実行アクセス権があることを確認してください。NT 4.0 では、このアクセス権を [実行] (スクリプトを含む) に設定します。インターネット サービス マネージャで [_vti_bin] フォルダを右クリックし、[プロパティ] をクリックすることにより、実行許可を設定します。表示されるダイアログ ボックスで、[仮想ディレクトリ] タブの実行権限を設定します。

先頭へ戻る

関連情報

関連情報については、次の文書番号をクリックして Microsoft Knowledge Base を参照してください。
192638 (http://support.microsoft.com/kb/192638/EN-US/) PRB: Web Server Related Errors On Multi-Processor Machine
195954 (http://support.microsoft.com/kb/195954/EN-US/) PRB: "Unable to Contact Web Server" Error Creating New Project
194798 (http://support.microsoft.com/kb/194798/EN-US/) PRB: Cannot Create Disk-based Web App or Unable to Contact Web
216846 (http://support.microsoft.com/kb/216846/EN-US/) FrontPage Server Extensions Administrator Does Not Open
272289 (http://support.microsoft.com/kb/272289/JA/) [VI60] Visual InterDev 6.0 における接続問題のトラブルシューティング

先頭へ戻る

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 220166 (http://support.microsoft.com/kb/220166/EN-US/) (最終更新日 2001-03-09) をもとに作成したものです。

先頭へ戻る


この資料は以下の製品について記述したものです。
?Microsoft Visual InterDev 6.0 Standard Edition

先頭へ戻る

キーワード:?
vi60 kbprb KB220166

先頭へ戻る

"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

サポート技術情報の翻訳

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.