Help and Support
 

powered byLive Search

[IIS]ErrMsg:サーバーに接続できませんでした

文書番号:220173
最終更新日:2004年9月17日
リビジョン:1.0
この記事は、以前は次の ID で公開されていました: JP220173

現象

IIS (Internet Information Server) 4.0 または 5.0 を実行しているコンピュータ上の Internet Explorer を使って、http://localhost または製品のマニュアルを開こうとすると、次のいずれかのエラー メッセージが表示されます。
インターネット サイト http://localhost/ を開けません。
サーバーに接続できませんでした。
または
インターネット サイト http://localhost/iisHelp/iis/misc/default.asp を開けません。
サーバーに接続できませんでした。

先頭へ戻る

原因

既定の Web サイトが特定の IP アドレスを使用するよう、設定されています。

このような設定が行われると、標準の IIS インストール環境のデフォルトの [未使用の IP アドレスすべて] の設定で使用可能な機能の一部が使用できなくなります。このとき、IIS のデフォルト設定に依存する追加機能も無効になります。

IIS のデフォルトの設定では、ローカルで事前定義された方法でホスト名 "localhost" を解決することにより、既定の Web サイトに正しくアクセスできます。"localhost" は、TCP/IP がインストールされている場合は必ず、%SystemRoot%\System32\drivers\etc\HOSTS ファイル (Microsoft Windows NT と Microsoft Windows 2000 の場合) または %windir%\HOSTS ファイル (Microsoft Windows 95 と Microsoft Windows 98 の場合) の定義内容に従って IP アドレス 127.0.0.1 に関連付けられます。しかし、このファイルとの関連付けを変更すると、既定の Web サイトへの正しいアクセスが許可されなくなります。

先頭へ戻る

解決方法

既定の Web サイトが未使用の IP アドレスすべてを使用するよう、変更を行います。それには以下の手順を実行します。
1. インターネット サービス マネージャを起動し、Microsoft 管理コンソール (MMC) で Internet Information Server スナップインを読み込みます。
2. 既定の Web サイト フォルダを右クリックし、[プロパティ] をクリックします。
3. [Web サイト] タブで、[IP アドレス] の [(未使用の IP アドレスすべて)] をクリックします。
4. [OK] をクリックします。
(c) Microsoft Corporation 2000, All Rights Reserved. Contributions by Kevin Zollman, Microsoft Corporation.

先頭へ戻る

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 220173 (http://support.microsoft.com/kb/220173/EN-US/) (最終更新日 2000-11-08) をもとに作成したものです。

先頭へ戻る


この資料は以下の製品について記述したものです。
?Microsoft Internet Information Server 4.0
?Microsoft Internet Information Services 5.0

先頭へ戻る

キーワード:?
kbhowto kbtshoot KB220173

先頭へ戻る

"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

サポート技術情報の翻訳

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.