Artigo: 221085 - Última revisão: segunda-feira, 28 de Agosto de 2006 - Revisão: 2.0

Mensagem de erro ao escrever endereço na caixa Endereço (Address) ou Abrir (Open)

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Este artigo foi publicado anteriormente em PT221085
Se este artigo não descrever a mensagem de erro de página inválida que lhe foi apresentada, visite o seguinte Web site da Microsoft para visualizar mais artigos que descrevem mensagens de erro de página inválida no Internet Explorer:
Click here to view a list of invalid page fault articles (http://support.microsoft.com/search/default.aspx?catalog=lcid%3d1033&spid=global&query=kbieipf&adv=&mode=s&cat=false)

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Quando escreve um endereço Web (URL) na caixa Endereço (Address) do Internet Explorer ou escreve um comando na caixa Abrir (Open) depois de clicar Executar (Run) no menu Iniciar (Start), poderá receber uma das seguintes mensagens de erro:
  • Explorer causou um erro de página inválida no módulo Kernel32.dll.
  • Explorer causou uma falha de página inválida no módulo Shdocvw.dll
  • Iexplore causou uma falha de página inválida no módulo Shdocvw.dll

Causa

Este comportamento pode ocorrer se uma entrada na pasta Histórico (History) estiver danificada e a funcionalidade Conclusão automática (AutoComplete) do Internet Explorer não a poder processar.

Resolução

Para confirmar que é a funcionalidade Conclusão automática (AutoComplete) que causa o problema, desactive a Conclusão automática (AutoComplete):
  1. Clique em Iniciar (Start), aponte para Settings (Definições), clique em Painel de controlo (Control Panel) e, em seguida, clique em Internet.
  2. Clique no separador Avançadas (Advanced ).
  3. Clique para desmarcar a caixa de verificação Utilizar a 'Conclusão automática' incorporada em endereços da Web (Use inline AutoComplete for Web address) e a caixa de verificação Utilizar a 'Conclusão automática' incorporada no 'Explorador do Windows' (Use inline AutoComplete in Windows Explorer).
  4. Clique em OK.
Se conseguir, agora, escrever um endereço Web (URL) na caixa Endereço do Internet Explorer ou escrever um comando na caixa Abrir depois de clicar em Executar (Run) no menu Iniciar (Start), o problema será, muito provavelmente, uma pasta Histórico (History) danificada: Para eliminar a pasta Histórico (History) danificada:

Windows 95/Windows 98

  1. Clique em Iniciar, clique em Encerrar, clique em Reiniciar no modo de MS-DOS e, em seguida, clique em OK.
  2. Na linha de comandos, escreva os seguintes comandos premindo ENTER após cada comando e premindo a tecla S se lhe for pedido para confirmar a eliminação de uma pasta:
    cd\windows
    deltree history
    exit
Depois de completar os passos acima, active novamente a funcionalidade Conclusão automática (AutoComplete ):
  1. Clique em Iniciar, aponte para Definições, clique em Painel de controlo e, em seguida, clique em Internet.
  2. Clique no separador Avançadas.
  3. Na secção Navegação, clique para seleccionar a caixa de verificação Utilizar a 'Conclusão automática' incorporada em endereços da Web e a caixa de verificação Utilizar a 'Conclusão automática' incorporada no 'Explorador do Windows'.
  4. Clique em OK.

Windows NT 4.0

  1. Inicie a sessão utilizando a conta de administrador predefinida no computador local.
  2. Clique em Start, clique em Run, escreva cmd na caixa Open e, em seguida, clique em OK.
  3. Prima CTRL+ALT+DELETE e, em seguida, clique em Task Manager.
  4. No separador Processes, clique em Explorer.exe e, em seguida, clique em End Task.
  5. No separador Applications, mude para Cmd.exe.
  6. Na linha de comandos, escreva cd\winnt\profiles\nome_do_utilizador\history e, em seguida, prima ENTER.
  7. Escreva attrib -r -a -s -h *.* e, em seguida, prima ENTER.
  8. Escreva del *.* e, em seguida, prima ENTER.
  9. Escreva explorer e, em seguida, prima ENTER para reiniciar a shell.
  10. Inicie o Windows NT Explorer e localize a pasta Winnt\Profiles\Nome_do_utilizador\History. Deverá ver um ficheiro denominado MSHist xxxxxxxxxxxxxxxxxx, em que xxxxxxxxxxxxxxxxxx são caracteres numéricos.
  11. Envie este ficheiro para o Recycle Bin.
  12. No separador Processes no Task Manager, clique em Explorer.exe e, em seguida, clique em End Task.
  13. No separador Applications, mude para Cmd.exe.
  14. Escreva cd\winnt\profiles\nome_do_utilizador e, em seguida, prima ENTER.
  15. Escreva rd history e, em seguida, prima ENTER.
  16. A pasta History é eliminada; escreva explorer para reiniciar a shell.
Depois de completar os passos acima, active novamente a funcionalidade Conclusão automática (AutoComplete ):
  1. Clique em Iniciar (Start), aponte para Definições (Settings), clique em Painel de controlo (Control Panel) e, em seguida, clique em Internet.
  2. Clique no separador Avançadas (Advanced).
  3. Na secção Navegação (Browsing), clique para seleccionar a caixa de verificação Utilizar a 'Conclusão automática' incorporada em endereços da Web (Use inline AutoComplete for Web address) e a caixa de verificação Utilizar a 'Conclusão automática' incorporada no 'Explorador do Windows' (Use inline AutoComplete in Windows Explorer).
  4. Clique em OK.

Windows 2000 e Windows NT 4.0

Para eliminar a sua própria pasta Histórico (History), se tiver privilégios administrativos:
  1. Inicie sessão como um utilizador com direitos de administrador. Se a conta de administrador incorporada tiver um problema com a pasta Histórico (History), crie uma nova conta e defina este utilizador como membro do grupo de administradores.
  2. No Explorador do Windows (Windows Explorer), localize o perfil da conta com o problema. No Windows NT 4.0, localize a pasta %SystemRoot\Profiles\Nome_do_utilizador\History. No Windows 2000, localize a pasta Documents and Settings\Nome_do_utilizador\Definições locais\Histórico.
  3. Clique com o botão direito do rato na pasta Histórico e, em seguida, clique em Delete.
  4. Quando lhe for solicitado que confirme que pretende eliminar a pasta Histórico, clique em Sim.

Mais Informação

Para obter informações adicionais sobre a funcionalidade Conclusão automática (AutoComplete), clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
217148  (http://support.microsoft.com/kb/217148/PT/ ) Como utilizar a funcionalidade 'Conclusão automática' no Internet Explorer 5

A informação contida neste artigo aplica-se a:
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.0 128-Bit Edition
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.0 128-Bit Edition
Palavras-chave: 
kberrmsg kbinvalidpagefault kbprb KB221085