ID do artigo: 221509 - Última revisão: quarta-feira, 1 de novembro de 2006 - Revisão: 3.2

Como configurar uma impressora de Autocreated padrão com o Windows Terminal Server usando o cliente do MetaFrame ICA

Observação : Este artigo só se aplica ao Windows Terminal Server com Citrix MetaFrame aplicado.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Alguns drivers de estação de trabalho de impressão local representam problemas para o Windows NT Server, Terminal Server Edition. Se os drivers não foram testados adequadamente no Terminal Server, eles podem causar problemas lockup no servidor ou tela azul até mesmo mensagens de erro.

Causa

O usuário geralmente tem a capacidade de instalar impressoras locais em sua própria estação de trabalho. Quando o usuário se conecta a uma sessão do Terminal Server, a impressora local é autocreated na sessão do Terminal Server. Em grandes empresas, é difícil controlar quais impressoras e drivers de impressão o usuário está carregando em sua própria estação de trabalho local.

Por exemplo, o HP4000 imprimir driver causou problemas em algumas instalações do Terminal Server. A fila de impressão pode parar de responder (travar) e os trabalhos não impressos. O driver de impressão HP LaserJet 4 mostrou ser muito estável no ambiente e pode ser usado como um substituto para o driver de impressão HP4000. Para garantir que o driver HP LaserJet 4 é usado, se o usuário tentar carregar o driver de impressão HP4000 ou qualquer outro driver incompatível em sua própria estação de trabalho local, há uma solução alternativa para definir o driver de impressora padrão usado no servidor de terminal.

Resolução

Há um arquivo no servidor de terminal pode ser modificado para tornar a impressora diferentes nomes de driver parece ser iguais, e isso definirá um driver de impressão padrão que funciona corretamente no servidor de terminal.

Para fazer esta modificação, execute estas etapas:
  1. Você precisa saber antecipadamente o nome exato do driver de impressão em questão que potencialmente pode ser carregado na estação de trabalho cliente. Você pode descobrir isso carregando o driver de impressão em uma estação de trabalho teste no modo local, não uma sessão do Terminal Server e, em seguida, fazer o seguinte:
    1. Clique em Iniciar , clique em configurações e, em seguida, clique em impressoras .
    2. Selecione a impressora que provou ser um problema e clique com o botão direito do mouse.
    3. Selecione Propriedades e, em seguida, clique na guia detalhes .
    4. Anote o nome do driver de impressora. Em computadores que executam o Windows 95 e Windows 98, o driver está listado na caixa Imprimir usando o seguinte driver . Em computadores que executam o Windows NT, a caixa de driver é na guia Geral . O nome do driver de impressão pode variar na estação de trabalho, dependendo do sistema operacional. Verifique se que você tem o nome do driver correto para a estação de trabalho cliente que está sendo usado.

      Por exemplo, se você vir "HP LaserJet 4000 Series PCL 5e", escrever esse nome, prestando atenção a sensibilidade de pontuação e caso todos os.
  2. No computador do Terminal Server, clique em Iniciar , clique em configurações e, em seguida, clique em impressoras .
  3. Clique duas vezes no ícone Adicionar impressora , selecione Meu computador e, em seguida, clique em Avançar .
  4. Na caixa de lista de Portas disponíveis , selecione LPT1 e, em seguida, clique em Avançar .
  5. No painel esquerdo, selecione o fabricante da impressora que você tiver instalado em sua estação de trabalho. No painel direito, role para o modelo da impressora que você deseja que o Terminal Server carregar como o driver padrão.

    Por exemplo, "HP LaserJet 4". Este é o nome do driver de impressora servidor que você deseja usar como impressora padrão. Anote esse nome.
  6. Abra o arquivo Wtsuprn.txt. Esse arquivo está localizado na pasta % systemroot%\System32. O arquivo é da seguinte maneira:
     ==========================================================================
     ; WTSUPRN.TXT 
     ;
     ; this is a template for wtsuprn.inf -- rename this file to wtsuprn.inf
     ;
     ; this file provides a mapping for client printers which have a name
     ; different from the server printer.  this file is necessary since many
     ; printers for Win95 are different from their WinNT equivalent.
     ;
     ; Note: the driver for the server printer must be installed.  See the
     ; WinFrame Concepts and Planning Guide.
     ;
     [Identification]
             OptionType = PRINTER
     [ClientPrinters]
     ;
     ;     Client Name                                  Server Name
     ;          |                                            |
     ;          |                                            |
     ;         \|/                                          \|/ 
     ;"HP LaserJet 4/4M"                          = "HP LaserJet 4"
     ;"HP LaserJet 4P/4MP"                        = "HP LaserJet 4P"
     ;"HP LaserJet 4 Plus/4M Plus"                = "HP LaserJet 4 Plus"
     ;"HP LaserJet 4Si/4Si MX"                    = "HP LaserJet 4Si"
     ;"HP LaserJet 4V/4MV"                        = "HP LaserJet 4V"
     ;"HP LaserJet 5/5M - Enhanced"               = "HP LaserJet 5"
     ;"HP LaserJet 5/5M - Standard"               = "HP LaserJet 5"
     ;"HP LaserJet 5/5M PostScript"               = "HP LaserJet 5"
     ;"HP LaserJet 5L (PCL)"                      = "HP LaserJet 5L"
     ;"HP LaserJet 5P/5MP (HP)"                   = "HP LaserJet 5P"
     ==========================================================================
    						
    usar esse formato exato para inserir as informações anteriores que você coletadas a partir da estação de trabalho e o servidor. Deixar o ponto-e-vírgula (;), isso é remark a linha de saída.

    Verifique se que você digitar o driver correto na coluna apropriada. Nome do cliente seria a estação de trabalho; nome do servidor é o Terminal Server.

    Por exemplo:
     "HP LaserJet 4000 Series PCL 5e"	     = "HP LaserJet 4"
    						
  7. Salvar este arquivo com uma extensão .inf e, em seguida, feche o arquivo Wtsuprn.txt. De agora em diante, se você tiver que adicionar qualquer outra impressora, adicioná-los para o arquivo Wtsuprn.inf.
  8. Fazer logoff do computador do Terminal Server e log logon novamente. Faça logon em sua estação de trabalho cliente para um servidor de terminal sessão e você deve agora consulte autocreated sua impressora na pasta de impressoras de sessão do Terminal Server e poderá imprimir volta para a impressora local.

Instalando um novo driver de impressão não nativo.

Quando você precisar instalar um novo driver de impressão para sua estação de trabalho, você também precisará instalar um driver de impressão para o computador do Terminal Server. Instale a impressora no servidor como uma impressora local. Após a conclusão da instalação de impressora, exclua o ícone da impressora da pasta impressora. O driver de impressora será instalado no servidor um quando você conectar-se a estação de trabalho ao Terminal Server, a nova impressora será autocreated. Se os nomes de driver de impressora são diferentes para a estação de trabalho (cliente) e o servidor, siga o mesmo procedimento como acima para torná-los igual.

Mais Informações

Isso funcionará para suas necessidades de impressão. A única desvantagem é que algumas das funcionalidades do substituído driver de impressora no servidor podem não funcionar na impressora mais recente. Se você tem preocupações sobre isso, contate o fabricante da impressora.

Referências

Para obter informações adicionais com relação aos recursos Autocreate Citrix, visite o seguinte site da Citrix:
http://knowledgebase.citrix.com/article/CTX681954 (http://knowledgebase.citrix.com/article/CTX681954)

A informação contida neste artigo aplica-se a:
  • Microsoft Windows NT Server 4.0, Terminal Server Edition
Palavras-chave: 
kbmt kbprb KB221509 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 221509  (http://support.microsoft.com/kb/221509/en-us/ )
 

Traduções deste artigo