[FIX] メディアからアプリケーションをインストールできませんと"AllocateCDRom または AllocateFloppies"レジストリ値が設定

文書翻訳 文書翻訳
文書番号: 221524 - 対象製品
この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
すべて展開する | すべて折りたたむ

目次

現象

アプリケーションのセットアップを開始して、Windows インストーラーでは、ディスクから読み取るしようとする次のエラーを受信する可能性があります。
エラーが発生したため、インストールを完了できませんでした。
または、管理者は CD-ROM またはフロッピー ディスクから、"提供"設定 (たとえば、"セットアップ/jm"Office から) を実行する可能性があります。 Windows インストーラー] ダイアログ ボックスが簡単に表示されますが、アプリケーションはアドバタイズされません。 上の通常のセットアップ例 as in エラー メッセージはありません。

原因

HKEY_LOCAL_MACHINE\Software\Microsoft\ に 2 つのレジストリ エントリがこの問題の原因となる WindowsNT\CurrentVersion\Winlogon サブキー。
  • AllocateCDRoms:REG_SZ
  • AllocateFloppies:REG_SZ
これらのエントリのいずれかの追加や 1、したがって、ローカルでログオンしているユーザーがすべてのユーザーへのアクセスを無効に設定がされています。 オフ、CD-ROM またはフロッピー ディスク ドライブを読み取るとき、Windows インストーラーはローカル システムとして実行される、ため、アクセスは拒否ローカル システムがこのセキュリティで保護された環境で、ドライブへのアクセスを与えられていないためにされます。

解決方法

メディアからインストールを実行するにはこれらのレジストリ キーを削除か、0 (ゼロ) に設定する必要がありますがします。 まったくでこれらのメディアからインストールするキーし、値のセットがあります。

状況

マイクロソフトではこれが、この資料の冒頭に記載されているマイクロソフト製品のバグとして認識しています。

この問題は、Windows 2000 で修正されました。

詳細

再現手順:

  1. セキュリティ構成エディターを使用して、次のテンプレートのいずれか、システムを保護します。
    • compdc4.inf
    • compws4.inf
    • hisecdc4.inf
    • hisecws4.inf
    • securedc4.inf
    • securws4.inf
  2. ローカルの CD-ROM ドライブまたはフロッピー ドライブから、アプリケーションのセットアップを実行します。

    結果: ファイルをコピー、直前に、次のエラー表示されます。
    エラーが発生したため、インストールを完了できませんでした
    -または-

  3. /j [u|m] スイッチには、アドバタイズ セットアップを実行します。

    結果: Windows インストーラー] ダイアログ ボックスは、簡単に表示されますが、アプリケーションはアドバタイズされません。 上の通常のセットアップ例としてのエラーはありません。

関連情報

これらのセキュリティ キーについては、ください「以下「サポート技術情報」(Microsoft Knowledge Base)。
172520共有の CD-ROM にアクセスしようとするとアクセス拒否エラーになる

プロパティ

文書番号: 221524 - 最終更新日: 2014年2月23日 - リビジョン: 2.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows インストーラ 1.0?を以下の環境でお使いの場合
    • Microsoft Windows NT 4.0
キーワード:?
kbnosurvey kbarchive kbbug kbfix kbappsetup kboswin2000fix kbmt KB221524 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:221524
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com