FIX: 응용 프로그램 미디어에서 설치할 수 때 "AllocateCDRom 또는 AllocateFloppies" 레지스트리 값 설정?

기술 자료 번역 기술 자료 번역
기술 자료: 221524 - 이 문서가 적용되는 제품 보기.
이 문서가 보관되었습니다. "그대로" 제공되었으며, 업데이트가 되지 않을 것입니다.
모두 확대 | 모두 축소

이 페이지에서

현상

응용 프로그램 설치 프로그램을 시작하고 설치 드라이브에서 읽으려고 하면 아래와 같은 오류 메시지가 나타날 수 있습니다.
오류 때문에 설치가 중간에 중단되었습니다.
또는 관리자가 Advertise 설치 (예를 들어, "설치/jm" 에서 Office) CD-ROM 또는 플로피 디스크에서 실행할 수 있습니다. Windows Installer 대화 상자가 간략하게 표시될 수 있습니다, 하지만 응용 프로그램이 아닌 알려집니다. 일반 설치 경우처럼 위의 오류 메시지가 있습니다.

원인

HKEY_LOCAL_MACHINE\Software\Microsoft\ 있는 레지스트리 항목을 두 가지 WindowsNT\CurrentVersion\Winlogon 하위가 이 문제가 발생할 수 있습니다.
  • AllocateCDRoms:REG_SZ
  • AllocateFloppies:REG_SZ
이러한 항목 중 하나 또는 모두를 이미 추가된 또는 1, 따라서 제외한 모든 로컬로 로그온한 사용자 액세스를 사용하지 않도록 설정합니다. CD-ROM 또는 플로피 디스크 드라이브 해제 읽을 때 Windows Installer 로컬 시스템으로 실행되기 때문에 로컬 시스템 보안 환경에서 이 드라이브에 액세스 부여되지 않았기 때문에 액세스가 거부되었습니다.

해결 방법

설치 미디어에서 실행되도록 이러한 레지스트리 키가 합니다 수 제거되거나 0 (영) 으로 설정합니다. 미디어에서 이러한 사용하여 설치하는 방법을 키 및 값 집합을.

현재 상태

Microsoft는 이 문서의 시작 부분에 나열한 제품에서 문제를 확인했습니다.

이 문제는 Windows 2000에서 수정되었습니다.

추가 정보

재현 단계:

  1. 보안 구성 편집기를 사용하여 다음 템플릿을 사용하여 시스템의 보안을.
    • compdc4.inf
    • compws4.inf
    • hisecdc4.inf
    • hisecws4.inf
    • securedc4.inf
    • securws4.inf
  2. 로컬 CD-ROM 드라이브 또는 플로피 드라이브에서 응용 프로그램 설치 프로그램을 실행하십시오.

    결과: 방금 파일을 복사하기 전에 다음과 같은 오류 메시지가 나타납니다.
    오류 때문에 설치가 중간에 중단되었습니다.
    -또는-

  3. advertise 설치 [u|m]/j 스위치를 사용하여 실행하십시오.

    결과: Windows Installer 대화 상자를 잠깐, 표시되지만 응용 프로그램이 아닌 알려집니다. 일반 설치 경우처럼 위의 오류가 발생하지 않습니다.

참조

이러한 보안 키에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
172520액세스 거부 오류가 공유 CD-ROM 액세스 시도 시

속성

기술 자료: 221524 - 마지막 검토: 2014년 2월 23일 일요일 - 수정: 2.0
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows Installer 1.0?을(를) 다음과 함께 사용했을 때
    • Microsoft Windows NT 4.0
키워드:?
kbnosurvey kbarchive kbmt kbappsetup kbbug kbfix kboswin2000fix KB221524 KbMtko
기계 번역된 문서
중요: 본 문서는 전문 번역가가 번역한 것이 아니라 Microsoft 기계 번역 소프트웨어로 번역한 것입니다. Microsoft는 번역가가 번역한 문서 및 기계 번역된 문서를 모두 제공하므로 Microsoft 기술 자료에 있는 모든 문서를 한글로 접할 수 있습니다. 그러나 기계 번역 문서가 항상 완벽한 것은 아닙니다. 따라서 기계 번역 문서에는 마치 외국인이 한국어로 말할 때 실수를 하는 것처럼 어휘, 구문 또는 문법에 오류가 있을 수 있습니다. Microsoft는 내용상의 오역 또는 Microsoft 고객이 이러한 오역을 사용함으로써 발생하는 부 정확성, 오류 또는 손해에 대해 책임을 지지 않습니다. Microsoft는 이러한 문제를 해결하기 위해 기계 번역 소프트웨어를 자주 업데이트하고 있습니다.

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com