Chybová zpráva: Předchozí instalace programu byla nikdy dokončena

Překlady článku Překlady článku
ID článku: 221863 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Při pokusu o instalaci aplikace Internet Explorer, můžete obdržet následující chybovou zprávu:
Instalace systému Windows Update

Předchozí instalace programu byla dokončena nikdy. Bude nutné restartovat počítač a dokončete instalaci před spuštěním instalace aplikace Internet Explorer. Instalační program bude nyní ukončen.

Příčina

Tato chybová zpráva se může zobrazit, pokud systém Windows nebyl dosud restartován po instalaci nebo aktualizaci souborů, které byly používány systémem Windows.

Například některé instalace programu nebo aktualizace nutné nahradit soubory, které jsou aktuálně používány v systému Windows. Některé soubory nelze nahradit, je-li spuštěn systém Windows. Tak, aby tyto soubory mohou být aktualizovány při počátečním spuštění systému Windows před načtením do paměti, je nutné restartovat systém Windows.

Aplikace Internet Explorer zjistí, že tyto operace čekají a není možné nainstalovat až do dokončení těchto operací.

Řešení

Chcete-li tento problém vyřešit, klepněte na tlačítko OK a restartujte systém Windows. Po restartování systému Windows, spusťte znovu instalační program aplikace Internet Explorer. Pokud obdržíte chybovou zprávu znovu, klepněte na tlačítko OK a restartujte systém Windows. Po restartování systému Windows, spusťte znovu instalační program aplikace Internet Explorer.

Všimněte si, že restartování systému Windows může problém nevyřeší. Stačí může provést odpovídající níže uvedeným postupem.

Systém Windows 95, Microsoft Windows 98 a Windows Millennium Edition (ME)

Přejmenujte soubor Wininit.ini, restartujte počítač a znovu spusťte instalační program aplikace Internet Explorer. Chcete-li přejmenovat soubor Wininit.ini, postupujte takto:
  1. Ukončit systém Windows tak, že klepnete na tlačítko Start, klepnutí na tlačítko vypnout a potom klepnutím na položku Restartovat v režimu MS-DOS.
  2. Ze systému DOS spusťte wininit.exe a stiskněte klávesu ENTER.
  3. Zadejte příkaz exit a nechte systém Windows spustit zálohování.
Pokud, nefunguje, zkuste následující kroky.
  1. Klepněte na tlačítko Start, klepněte na příkaz Najít (nebo hledání) a potom klepněte na položku soubory či složky.
  2. Do pole název zadejte wininit.ini.
  3. V rozevíracím seznamu Oblast hledání klepněte na položku Místní pevné disky.
  4. Klepněte na tlačítko Najít nyní.
  5. Klepněte pravým tlačítkem myši na soubor Wininit.ini a potom klepněte na příkaz Přejmenovat.
  6. Zadejte Wininit.nin a stiskněte klávesu ENTER.
  7. Zavřít okno hledání.

Windows NT 4.0 a Windows 2000

Důležité Tento oddíl, metody nebo úkol obsahuje kroky, které vám sdělit, jak upravit registr. Při nesprávných úpravách registru však mohou nastat závažné problémy. Proto se ujistěte, pečlivě provedení těchto kroků. Zvýšení ochrany zálohovat registr před úpravami je nutné. Pokud dojde k potížím se potom může obnovit registr. Další informace o zálohování a obnovení registru získáte následujícím článku báze Microsoft Knowledge Base:
322756Zálohování a obnovení registru v systému Windows

Vyhledejte následující klíč registru:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
Odstraňte všechny hodnoty PendingFileRenameOperations v tomto klíči.

Bude možná nutné vyhledat a odebrat operace přejmenování čekající souborů v následujících klíčích registru:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnceEx

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunServicesOnce

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce
Poznámka: Pokud je problém stále není vyřešen, zjišťovat existenci původní instalační soubory ve složkách TEMP nebo TMP, zkontrolovat existenci složku s názvem "$! $! $! $!" v kořenové složce nebo zkuste vyprázdnění složky dočasné soubory Internetu.

Odstranit dočasné soubory

  1. Poklepejte na ikonu Tento počítač, poklepejte na jednotku C, poklepejte na složku Windows a potom poklepejte na složku Temp.
  2. Stisknutím kombinace kláves CTRL + A vyberte všechny soubory ve složce.
  3. Stiskněte klávesu DELETE.
  4. Zavřete tento počítač.

Odstranění dočasných souborů Internetu

  1. Na pracovní ploše klepněte pravým tlačítkem na položku Internet Explorer a potom klepněte na příkaz Vlastnosti.
  2. Ve skupinovém rámečku Dočasné soubory Internetu klepněte na tlačítko Odstranit soubory.
  3. Klepnutím zaškrtněte políčko Odstranit Offline obsah a klepněte na tlačítko OK.
  4. Zavřete okno vlastností Internetu.
Aplikace Internet Explorer pouze vynutí restartování v případě živých instalace. Pokud správce je psaní skriptu k zřetězení řadu nainstaluje společně, by měly používá instalační program Nastaví tichý režim (/ Q:A). to nekontroluje čekající přejmenuje soubor před instalací (nedochází došlo k chybě uvedeno výše).

Prohlášení

Toto chování je záměrné.

Vlastnosti

ID článku: 221863 - Poslední aktualizace: 24. ledna 2007 - Revize: 3.3
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.01 128-Bit Edition
  • 128bitová verze aplikace Microsoft Internet Explorer 4.0
  • Microsoft Internet Explorer 3.03 for Windows NT 3.51
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.01 128-Bit Edition
  • 128bitová verze aplikace Microsoft Internet Explorer 4.0
  • Microsoft Internet Explorer 3.02
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.0 for UNIX
  • Microsoft Internet Explorer 4.01
  • Microsoft Internet Explorer 5.0 for Macintosh
  • Microsoft Internet Explorer 4.5 for Macintosh
  • Microsoft Internet Explorer 3.0 pro počítače Macintosh
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 6.0 na těchto platformách
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows NT Server 4.0, Terminal Server Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
Klíčová slova: 
kbmt kberrmsg kbprb kbsetup KB221863 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:221863

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com