Article ID: 222008 - Last Review: November 17, 2003 - Revision: 3.0 Cannot Open Service.lck for Writing or ReadingThis article was previously published under Q222008 SYMPTOMS
When you attempt to open or list Webs using the FrontPage Server
Extensions running on an IIS 3.0 or 4.0 computer, one of the following
error messages may occur:
Server Error: Cannot open file "e:\InetPub\WWWRoot\_vti_pvt\service.lck"
for writing.
Server Error: Cannot open file "e:\InetPub\WWWRoot\_vti_pvt\service.lck"
for reading.
CAUSE
The error is caused by inappropriate permissions on the Service.lck file
in the Web you are trying to open.
RESOLUTION
To resolve this problem, use one of the following methods: Delete the Service.lck file. (It can become corrupted, especially by someone opening a Web then ending the network connection rather than exiting the FrontPage Explorer gracefully.)or Reset the permissions for the Anonymous Account by doing the following: For IIS 3.0
For IIS 4.0
MORE INFORMATION
The most common cause for permissions problems in FrontPage is manually
editing NTFS permissions in Windows NT Explorer. The FrontPage permissions
scheme is very specific and applying NTFS permissions manually often
causes problems. For additional information, please see the following article(s) in the Microsoft Knowledge Base: 209906
(http://support.microsoft.com/kb/209906/EN-US/
)
Web Busy Errors When Authoring FrontPage Webs on IIS
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