Article ID: 222008 - Last Review: November 17, 2003 - Revision: 3.0

Cannot Open Service.lck for Writing or Reading

This article was previously published under Q222008
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SYMPTOMS

When you attempt to open or list Webs using the FrontPage Server Extensions running on an IIS 3.0 or 4.0 computer, one of the following error messages may occur:
Server Error: Cannot open file "e:\InetPub\WWWRoot\_vti_pvt\service.lck" for writing.
Server Error: Cannot open file "e:\InetPub\WWWRoot\_vti_pvt\service.lck" for reading.

CAUSE

The error is caused by inappropriate permissions on the Service.lck file in the Web you are trying to open.

RESOLUTION

To resolve this problem, use one of the following methods:

Delete the Service.lck file. (It can become corrupted, especially by someone opening a Web then ending the network connection rather than exiting the FrontPage Explorer gracefully.)or

Reset the permissions for the Anonymous Account by doing the following:

For IIS 3.0

  1. Click Start and point to Programs.
  2. Point to Microsoft Internet Information Server.
  3. Click Internet Service Manager.
  4. Double-click the WWW Service
  5. Uncheck the checkbox for Allow Anonymous.
  6. Click Apply.
  7. Open the Web in FrontPage.
  8. When the Web is open re-check the checkbox for Allow Anonymous.
  9. Click Apply
  10. In the FrontPage client, on the Tools menu, click Permissions.
  11. On the Users tab, select the radio button so only registered users have browse access.
  12. Click Apply.
  13. When the process has executed, select the radio button so everyone has browse access, and then click Apply.
You should now be able to open the Web with Anonymous Access turned on.

For IIS 4.0

  1. Click Start and point to Programs.
  2. Point to Microsoft Windows NT 4 Option Pack
  3. Point to Microsoft Internet Information Server.
  4. Click Internet Service Manager.
  5. Right-click the virtual server that the Web is running on (for example the Default Web Site), and then click Properties.
  6. On the Directory Security tab, click Edit in the Anonymous Access and Authentication Control section.
  7. Uncheck the checkbox for Allow Anonymous.
  8. Click OK twice.
  9. Open the Web in FrontPage.
  10. When the Web is open, re-check the checkbox for Allow Anonymous.
  11. Click OK.
  12. In the FrontPage client, on the Tools menu, click Permissions.
  13. On the Users tab, select the radio button so only registered users have browse access.
  14. Click Apply.
  15. When the process has executed, select the radio button so everyone has browse access, and then click Apply.

MORE INFORMATION

The most common cause for permissions problems in FrontPage is manually editing NTFS permissions in Windows NT Explorer. The FrontPage permissions scheme is very specific and applying NTFS permissions manually often causes problems.

For additional information, please see the following article(s) in the Microsoft Knowledge Base:
209906  (http://support.microsoft.com/kb/209906/EN-US/ ) Web Busy Errors When Authoring FrontPage Webs on IIS

APPLIES TO
  • Microsoft FrontPage 98 Standard Edition
  • Microsoft Internet Information Server 3.0
  • Microsoft Internet Information Server 4.0
Keywords: 
kbprb KB222008
 

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