Jak vyhledat a použít dokumentaci modelu objektu sady Office

Překlady článku Překlady článku
ID článku: 222101 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

Tento článek popisuje prostředky a dokumentace, které jsou k dispozici pro automatizaci aplikace sady Microsoft Office. Tyto informace lze použít bez ohledu na to, programovací jazyk, který vyberete pro automatizaci aplikace sady Office. Tento článek také ukazuje, jak můžete začít psát kód automatizace pomocí krokování můžete v dokumentaci vyhledejte informace potřebné k provedení určitého úkolu prostřednictvím automatizace.

Další informace

Kde lze najít v dokumentaci k modelu objektu?

Modely objektů aplikací sady Office, které jsou popsány v Language Reference pro obě verze sady Office: Microsoft Office 97 jazyka Visual Basic for Applications Language Reference
ISBN 1-57231-339-0

Aktualizace Microsoft Office 2000 Visual Basic pro aplikace Language Reference
ISBN 1-57231-955-0.
Jazykové reference jsou k dispozici webu MSDN a v online nápovědě dodávaný se sadou Microsoft Office. Také je lze zakoupit v tištěné podobě. Další informace o objednávce, najdete:
http://mspress.microsoft.com
V následující tabulce jsou uvedeny soubory nápovědy pro každou aplikaci sady Office.

Zmenšit tuto tabulkuRozšířit tuto tabulku
AplikaceVerze 97 (nebo 8.0)Verze 2000 (nebo 9.0)Verze 2002 (nebo 10)Verze 2003 (nebo 11)
OfficeVbaoff8.hlpVbaoff9.chmVbaof10.chmVbaof11.chm
PřístupAcvba80.hlpAcmain9.chmAcmain10.chm, Vbaac10.chmACMAIN11.chm, VBAAC10.chm
Aplikace ExcelVbaXl8.hlpVbaxl9.chmVbaxl10.chmVBAXL10.chm
MapPointNENÍ K DISPOZICIMapPoint.chm (ver.2001)MapPoint.chmMAPPOINT.chmn (verze 2004)
Aplikace OutlookVbaoutl.hlpVbaoutl9.chmVbaol10.chmVBAOL11.chm
Aplikace PowerPointVbappt.hlpVbappt9.chmVbapp10.chmVBAPP10.chm
Aplikace WordVbawrd8.hlpVbawrd9.chmVbawd10.chmVBAWD10.chm
GrafVbagrp8.hlpVbagrp9.chmVbagr10.chmVBAGR10.chm
Aplikace FrontPageNENÍ K DISPOZICIVbafp4.chm, Vbafpom4.chmVbafpd10.chm, vbafpw10.chmVBAFPD10.chm, VBAFPW10.chm
PořadačVbabdr8.hlpVbabdr8.hlpPozastaveno


Soubory nápovědy dodávané s aplikací Microsoft Office 97 jsou instalovány standardně při:
C:\Program Files\Microsoft Office\Office
Pokud nemůžete najít požadovaný soubor sady Office 97 VBA nápovědy, je pravděpodobně nebyla nainstalována při počátečním spuštění instalačního programu sady Office 97. Chcete-li nainstalovat soubor nápovědy, spusťte instalační program sady Office můžete přidat soubor nápovědy jazyka VBA. Všimněte si, že soubor nápovědy jazyka VBA 97 aplikace Outlook není nainstalována pomocí instalačního programu sady Office. Informace o instalaci v souboru aplikace Outlook 97 VBA nápovědy naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
166738 OL97: Jak nainstalovat nápovědu programu Visual Basic
Soubory nápovědy, které jsou dodávány se sadou Microsoft Office 2000 jsou instalovány standardně při:
C:\Program Files\Microsoft Office\Office\1033
Soubory nápovědy, které jsou dodávány se sadou Microsoft Office XP jsou instalovány standardně při:
C:\Program Files\Microsoft Office\Office10\1033
C:\Program Files\Microsoft Office\Office11\1033
POZNÁMKA:: V aplikacích Microsoft Office 2000, Microsoft Office XP a instalace sady Microsoft Office 2003 nainstalovat soubory nápovědy jazyka VBA "při prvním použití." Pokud není dříve pokusů o přístup k nápovědě VBA v aplikaci sady Office proto pravděpodobně naleznete není v souboru nápovědy v tomto adresáři.

Použití dokumentace modelu objektu

Existuje několik metod, které můžete použít k vyhledání dokumentace pro určité třídy, metody nebo vlastnosti:
  • Vyhledejte soubor nápovědy jazyka VBA:

    V editoru jazyka Visual Basic pro aplikace sady Office, klepněte na tlačítko Obsah a Index v Nápověda nabídka. V Obsah karta, vyberte odkaz jazyk a klepněte na tlačítko Zobrazení. Nápověda pro vybraný odkaz jazyk VBA se zobrazí. V tomto okamžiku můžete použít buď Index nebo Najít kartu Najít informace o konkrétní třídy, metody nebo vlastnosti.
  • V modulu nebo v podokně okamžité, použijte kontextovou nápovědu:

    V editoru jazyka Visual Basic pro aplikace sady Office, zadejte třídu, metodu nebo vlastnost v okně kódu modulu nebo v Podokno hodnot proměnných, zvýrazněte ho a stiskněte klávesu F1. Zobrazí se téma nápovědy pro danou položku.
  • Pomocí prohlížeče objektů:

    Stisknutím klávesy F2 v editoru jazyka Visual Basic pro aplikace sady Office, zobrazí Prohlížeč objektů. Na Prohlížeč objektů seznam všech tříd zpřístupňuje aplikaci a metody nebo vlastnosti jednotlivých tříd. Chcete-li zobrazit nápovědu pro konkrétní třídy nebo člen třídy, vyberte ji v prohlížeči objektů a stisknutím klávesy F1.

Jak zjistit které třídy, metody a vlastnosti, které chcete použít?

Pokud nejste již obeznámeni s objektovým modelem aplikace, kterou chcete automatizovat, můžete zaznamenáním makra aplikace představu. Pro ilustraci, Předpokládejme, kterou chcete automatizovat aplikaci Microsoft Word přidat text do nového dokumentu a potom dokument uložíte, ale nevíte, které metody a vlastnosti použití; lze spustit s záznam makra:
  1. Spusťte aplikaci Microsoft Word.
  2. Klepněte na tlačítko Makro v Nástroje nabídky a pak vyberte Záznam nového makra. Poznamenejte si název nové makro a klepněte na tlačítko OK spuštění nahrávání.
  3. Otevřete nový dokument.
  4. Typ jeden a stiskněte klávesu ENTER.
  5. Typ dvě a stiskněte klávesu ENTER.
  6. Typ tři.
  7. Klepněte na tlačítko Uložit v Soubor nabídky a uložit dokument jako "C:\doc1.doc".
  8. Klepněte Zastavit záznam tlačítko (nebo klepněte na tlačítko Makro v Nástroje nabídku a vyberte Zastavit záznam).
  9. Chcete-li zobrazit kód jazyka VBA generující záznam makra z akcí, klepněte na tlačítko Makro v Nástroje nabídku a vyberte Makra. V seznamu vyberte název nové makro a klepněte na tlačítko Upravit. Visual Basic Editor se zobrazí s zaznamenané makro:
     Documents.Add
     Selection.TypeText Text:="one"
     Selection.TypeParagraph
     Selection.TypeText Text:="two"
     Selection.TypeParagraph
     Selection.TypeText Text:="three"
     ActiveDocument.SaveAs FileName:="Doc1.doc", FileFormat:=wdFormatDocument,_
       LockComments:=False, Password:="", AddToRecentFiles:=True, _ 
       WritePassword:="", ReadOnlyRecommended:=False, _
       EmbedTrueTypeFonts:=False, SaveNativePictureFormat:=False, _
       SaveFormsData:=False, SaveAsAOCELetter:= False
    					
Využívat výrazně vysvětlení, jak se jednotlivé třídy vejde do objektového modelu a studium, popis a druh všechny parametry metody a vlastnosti, které používáte.

Začínají zkoumání první řádek zaznamenané makro: Documents.Add. Zvýraznění Dokumenty v modulu kódu makra nahraný a stiskněte klávesu F1, klíč. Téma nápovědy obsahuje následující důležité informace:
  • Vlastnost"dokumenty" Vrátí kolekci dokumentů, která představuje všechny otevřené dokumenty.
  • Vlastnost"doklady" se vztahuje na aplikační objekt.
Návrat k zaznamenané makro, zvýraznění Přidat v modulu kódu a stiskněte klávesu F1, klíč. Zobrazí se téma nápovědy, vysvětlující, že metodu přidat mnoho různých objektů. Klepněte na tlačítko Dokumenty Zobrazit nápovědu pro Přidat Metoda kolekci dokumentů. Téma nápovědy obsahuje následující důležité informace:
  • "Přidat metodu" Přidá nový prázdný dokument do kolekce otevřené dokumenty.
  • "Přidat metodu" může trvat dva argumenty, které jsou volitelné.
Nyní prozkoumat další řádek v zaznamenané makro: Selection.TypeText textu: = jeden. Zvýraznění Výběr v modulu kódu a stiskněte klávesu F1, klíč:
  • Vlastnost"výběr" vrátí výběr objektu, který představuje vybrané oblasti nebo kurzor.
  • Vlastnost"výběr" se vztahuje na aplikační objekt.
Návrat k zaznamenané makro, zvýraznění TypeText v modulu kódu a stiskněte klávesu F1, klíč:
  • Způsob"TypeText" Vloží zadaný text.
  • "TypeText metoda" má jeden povinný argument typu řetězec.
  • Způsob"TypeText" se vztahuje k výběru objektu.
Dále naleznete v tématu nápovědy TypeParagraph:
  • Způsob"TypeParagraph" vkládá nový odstavec prázdné.
  • Způsob"TypeParagraph" se vztahuje k výběru objektu a neobsahuje žádné argumenty.
Zkoumat témata nápovědy pro ActiveDocument Vlastnost a Uložit jako Metoda:
  • Vlastnost"ActiveDocument" vrátí objekt dokument představuje dokument s fokusem. "activedocument" se vztahuje k objektu Application.
  • Způsob"Uložit jako" uloží dokument. V závislosti na verzi aplikace Word tato metoda je 11 16 argumenty, z nichž pouze jedna je vyžadován. "Uložit jako" se vztahuje k objektu dokumentu.
Jste si všimli, Dokumenty Vlastnost Výběr Vlastnost, a ActiveDocument vlastnosti jsou všechny vlastnosti, které se vztahují k Aplikace objekt ale ještě nejsou kvalifikované s "Aplikace" v zaznamenané makro. Na Aplikace objekt je objekt výchozí pro všechny vlastnosti a lze tedy vynechat při psaní kódu makra VBA. Toto není případ při psaní kódu pro automatizaci; všechny vlastnosti a metody by měl být úplný v kódu automatizace.

Při zkoumání zaznamenané makro, které naleznete Uložit jako Metoda má argument pro kterou předá předdefinované konstanty wdFormatDocument. V závislosti na programovací jazyk, který vyberete pro řadič automatizace budete muset projít číselnou hodnotu pro předdefinované konstanty. Téma nápovědy týkající Uložit jako metoda neposkytuje tyto informace, ale také vyhledat v Prohlížeč objektů. Stisknutím klávesy F2 zobrazit Prohlížeč objektů. Typ:

wdFormatDocument

v okně Hledat a stiskněte klávesu zadejte klíč. V dolním podokně Prohlížeč objektů, viz číselný ekvivalent wdFormatDocument(=0) stejně jako jiné informace o konstantu.

Odkazy

Kde lze najít některé automatizační ukázky kódu?

Informace předložené doposud vám dobré jen pro psaní kódu pro automatizaci. Znalostní báze Microsoft Knowledge Base je vynikající prostředek pro vyhledání ukázky kódu automatizace napsané v jazyce Visual Basic, Visual C++ a MFC. Zde jsou uvedeny pouze několik:

Pro vývojáře aplikace Visual Basic

Další informace získáte klepnutím na tlačítko naleznete v následujících článcích znalostní báze společnosti Microsoft:
220595Jak automatizovat pomocí jazyka Visual Basic aplikace Outlook
219151 Automatizace aplikace Microsoft Excel z aplikace Visual Basic
147650 Jak procházet objekty aplikace Excel z aplikace Visual Basic
142387 Jak vytvořit automatizace w/OLE grafu aplikace Excel z aplikace Visual Basic
184974 Použití automatizace (OLE) s aplikací Word
220607 Automatizace aplikace Microsoft Word pro hromadnou korespondenci prostřednictvím jazyka Visual Basic
222929 Jak automatizovat pomocí jazyka Visual Basic v aplikaci Office 2003, Office XP Developer a Office 2000 Developer aplikace PowerPoint

Visual C++ vývojáři (pomocí MFC)

Další informace získáte klepnutím na tlačítko naleznete v následujících článcích znalostní báze společnosti Microsoft:
178749Jak vytvořit projekt automatizace pomocí MFC a knihovny typů
179706 Jak automatizovat aplikaci Excel a vytvářet a formátovat nový sešit pomocí MFC
186120 Jak používat k automatizaci aplikace Excel a vyplnit pole oblast MFC
186122 Použití MFC k automatizaci aplikace Excel 2000 a Excel 2002 a získat pole z oblasti v aplikaci Excel 2000 a Excel 2002
220911 Jak automatizovat aplikaci Microsoft Word k vytvoření hromadné korespondence pomocí aplikace Visual C++ a MFC
222960 Jak automatizovat aplikaci PowerPoint pomocí The Microsoft Foundation Classes Visual C++ 5.0 nebo Visual C++ 6.0

C/C++ vývojáři (bez MFC)

Další informace získáte klepnutím na tlačítko naleznete v následujících článcích znalostní báze společnosti Microsoft:
216686Automatizace aplikace Excel z C++ bez použití MFC nebo #import
181473 Použití automatizace OLE z aplikace c spíše než C++

Visual J ++ vývojáři

Další informace získáte klepnutím na tlačítko naleznete v následujících článcích znalostní báze společnosti Microsoft:
219430Jak vytvořit a formát sešitu aplikace Excel pomocí jazyka Visual J ++ automatizace
215484 Jak automatizovat aplikaci PowerPoint pomocí aplikace Visual J ++ 6.0

Vývojáři Visual FoxPro

Další informace získáte klepnutím na tlačítko naleznete v následujících článcích znalostní báze společnosti Microsoft:
142193Jak přidat data do listu aplikace Excel pomocí automatizace OLE
180901 Jak vytvořit tabulku zařazené v aplikaci Word 97 nebo v aplikaci Office Word 2003 z Visual FoxPro pro Windows 5.0 a novější verze
181926 Jak automatizovat hromadné korespondence do aplikace Word pomocí OLE a ODBC
194306 Jak vytisknout oboustranný tisk pomocí automatizace OLE z aplikace Visual FoxPro
230154 Jak automatizovat aplikaci PowerPoint pomocí aplikace Visual FoxPro
241942 Jak zabránit tiskové chyby v aplikaci Word s vlastností BackgroundPrintingStatus
Další informace, včetně ukázky kódu a zdrojů pro automatizaci aplikace Microsoft Office navštivte následující Web společnosti Microsoft:
http://support.microsoft.com/gp/ofd

Vlastnosti

ID článku: 222101 - Poslední aktualizace: 26. dubna 2011 - Revize: 8.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Visual Basic 5.0 Professional Edition
  • Microsoft Visual Basic 6.0 Professional Edition
  • Microsoft Visual Basic 4.0 Enterprise Edition
  • Microsoft Visual Basic 5.0 Enterprise Edition
  • Microsoft Visual C++ 4.0 Professional Edition
  • Microsoft Visual C++ 5.0 Professional Edition
  • Microsoft Visual J++ 6.0 Standard Edition
  • Microsoft Visual Studio .NET 2002 Professional Edition
  • Microsoft Visual Studio .NET 2003 Professional Edition
  • Microsoft Access 2002 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Access 97 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft Outlook 97 Standard Edition
  • Microsoft Outlook 98 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft PowerPoint 97 Standard Edition
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
  • Microsoft Word 97 Standard Edition
  • Microsoft Visual FoxPro 6.0 Professional Edition
  • Microsoft MapPoint 2002 Standard Edition
  • Microsoft MapPoint 2001 Standard Edition
Klíčová slova: 
_ik11561 _ik11593 kbautomation kbgrpdso kbhowto kbvba kbvbp400 kbvbp500 kbvbp600 kbmt KB222101 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:222101

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com