Cómo encontrar y usar la documentación del modelo de objetos de Office

Seleccione idioma Seleccione idioma
Id. de artículo: 222101 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Resumen

En este artículo se describen los recursos y la documentación disponibles para automatizar aplicaciones de Microsoft Office. Esta información es aplicable cualquiera que sea el lenguaje de programación que elija para automatizar una aplicación de Office. En este artículo también se ilustra cómo puede empezar a escribir código de automatización recorriendo la documentación para encontrar la información necesaria para realizar una tarea específica mediante automatización.

Más información

Dónde puedo encontrar la documentación del modelo de objetos

Los modelos de objetos para las aplicaciones de Office se documentan en una Referencia del lenguaje para ambas versiones de Office: Microsoft Office 97 Visual Basic for Applications Language Reference (Referencia del lenguaje Visual Basic para Aplicaciones de Microsoft Office 97)
ISBN 1-57231-339-0

Microsoft Office 2000 Visual Basic for Applications Language Reference (Referencia del lenguaje Visual Basic para Aplicaciones de Microsoft Office 2000)
ISBN 1-57231-955-0.
Las Referencias del lenguaje están disponibles en MSDN y en la Ayuda en pantalla que se incluye con Microsoft Office. También se pueden adquirir en formato impreso. Para obtener información de pedido, visite el siguiente sitio Web:
http://mspress.microsoft.com
En la tabla siguiente se enumeran los archivos de Ayuda para cada aplicación de Office.

Contraer esta tablaAmpliar esta tabla
AplicaciónVersión 97 (u 8.0)Versión 2000 (o 9.0)Versión 2002 (o 10)Versión 2003 (u 11)
OfficeVbaoff8.hlpVbaoff9.chmVbaof10.chmVbaof11.chm
AccessAcvba80.hlpAcmain9.chmAcmain10.chm, Vbaac10.chmACMAIN11.chm,VBAAC10.chm
ExcelVbaXl8.hlpVbaxl9.chmVbaxl10.chmVBAXL10.chm
MapPointN/DMappoint.chm (ver.2001)Mappoint.chmMAPPOINT.chmn (Ver. 2004)
OutlookVbaoutl.hlpVbaoutl9.chmVbaol10.chmVBAOL11.chm
PowerPointVbappt.hlpVbappt9.chmVbapp10.chmVBAPP10.chm
WordVbawrd8.hlpVbawrd9.chmVbawd10.chmVBAWD10.chm
GraphVbagrp8.hlpVbagrp9.chmVbagr10.chmVBAGR10.chm
FrontPageN/DVbafp4.chm, Vbafpom4.chmVbafpd10.chm, vbafpw10.chmVBAFPD10.chm, VBAFPW10.chm
CuadernoVbabdr8.hlpVbabdr8.hlpInterrumpido


Los archivos de Ayuda que se incluyen con Microsoft Office 97 se instalan de manera predeterminada en:
C:\Archivos de programa\Microsoft Office\Office
Si no encuentra el archivo de Ayuda de VBA de Office 97 que necesita, probablemente no se instaló cuando ejecutó inicialmente el programa de instalación de Office 97. Para instalar el archivo de Ayuda, ejecute el programa de instalación de Office para agregar el archivo de Ayuda de VBA. Tenga en cuenta que el programa de instalación de Office no instala el archivo de Ayuda de VBA de Outlook 97. Para ver información acerca de cómo instalar el archivo de Ayuda de VBA de Outlook 97, consulte el siguiente artículo en Microsoft Knowledge Base:
166738 OL97: Cómo instalar la Ayuda de Visual Basic
Los archivos de Ayuda que se incluyen con Microsoft Office 2000 se instalan de manera predeterminada en:
C:\Archivos de programa\Microsoft Office\Office\1033
Los archivos de Ayuda que se incluyen con Microsoft Office XP se instalan de manera predeterminada en:
C:\Archivos de programa\Microsoft Office\Office10\1033
C:\Archivos de programa\Microsoft Office\Office11\1033
NOTA: Los programas de instalación de Microsoft Office 2000, Microsoft Office XP y Microsoft Office 2003 instalan los archivos de Ayuda de VBA la primera vez que se utilizan. Por tanto, quizás no vea el archivo de Ayuda en este directorio si no ha intentado tener acceso previamente a la Ayuda de VBA en la aplicación de Office.

Cómo puedo utilizar la documentación del modelo de objetos

Hay varias formas de encontrar documentación para una clase, un método o una propiedad determinados:
  • Busque el archivo de Ayuda de VBA.

    En el Editor de Visual Basic para la aplicación de Office, haga clic en Contenido y en Índice en el menú Ayuda. En la ficha Contenido, seleccione la referencia del lenguaje que desee y haga clic en Mostrar. Aparecerá la Ayuda VBA para la Referencia del lenguaje que seleccionó. En este momento puede utilizar la ficha Índice o la ficha Buscar para encontrar información acerca de una clase, un método o una propiedad determinados.
  • Utilice la Ayuda contextual en un módulo o en el panel Inmediato:

    En el Editor de Visual Basic para la aplicación de Office, escriba la clase, el método o la propiedad que desee en la ventana de código de un módulo o en la ventana Inmediata, resalte el texto y presione la tecla F1. Aparecerá el tema de Ayuda correspondiente al elemento.
  • Utilice el Examinador de objetos:

    Presione la tecla F2 en el Editor de Visual Basic para la aplicación de Office para mostrar el Examinador de objetos. El Examinador de objetos muestra todas las clases que la aplicación expone, así como las propiedades o los métodos asociados a cada clase. Para ver Ayuda acerca de una clase o de un miembro de una clase determinados, selecciónelo en el Examinador de objetos y presione la tecla F1.

Cómo sé qué clases, métodos y propiedades tengo que utilizar

Si no está familiarizado con el modelo de objetos de la aplicación que piensa automatizar, puede utilizar la Grabadora de macros de la aplicación para hacerse una idea. Suponga que desea automatizar Microsoft Word para agregar texto a un documento nuevo y guardar después el documento, pero no sabe qué métodos y propiedades debe utilizar; en ese caso, puede empezar con la Grabadora de macros:
  1. Inicie Microsoft Word.
  2. Haga clic en Macro en el menú Herramientas y seleccione Grabar nueva macro. Anote el nombre de la nueva macro y haga clic en Aceptar para empezar a grabar.
  3. Inicie un nuevo documento.
  4. Escriba uno y presione la tecla ENTRAR.
  5. Escriba dos y presione la tecla ENTRAR.
  6. Escriba tres.
  7. Haga clic en Guardar en el menú Archivo y guarde el documento como "C:\doc1.doc".
  8. Haga clic en el botón Detener grabación (o haga clic en Macro en el menú Herramientas y seleccione Detener grabación).
  9. Para ver el código VBA que la Grabadora de macros generó a partir de sus acciones, haga clic en Macro en el menú Herramientas y seleccione Macros. Seleccione el nombre de la nueva macro en la lista y haga clic en Modificar. Aparecerá el Editor de Visual Basic con la macro grabada:
     Documents.Add Selection.TypeText Text:="uno" Selection.TypeParagraph Selection.TypeText Text:="dos" Selection.TypeParagraph Selection.TypeText Text:="tres" ActiveDocument.SaveAs FileName:="Doc1.doc", FileFormat:=wdFormatDocument,_ LockComments:=False, Password:="", AddToRecentFiles:=True, _ WritePassword:="", ReadOnlyRecommended:=False, _ EmbedTrueTypeFonts:=False, SaveNativePictureFormat:=False, _ SaveFormsData:=False, SaveAsAOCELetter:= False
    					
Es muy útil entender cómo encaja cada clase dentro del modelo de objetos, y conocer la descripción y el tipo de todos los parámetros para los métodos y las propiedades que utilice.

Empiece por examinar la primera línea de la macro grabada: Documents.Add. Resalte Documents en el módulo de código de la macro grabada y presione la tecla F1. El tema de Ayuda muestra la siguiente información importante:
  • La "propiedad Documents" devuelve una colección Documents que representa todos los documentos abiertos.
  • La "propiedad Documents" se aplica al objeto Application.
Vuelva a la macro grabada, resalte Add en el módulo de código y presione la tecla F1. Aparecerá un tema de Ayuda que explica que muchos objetos diferentes tienen un método Add. Haga clic en Documents para ver la Ayuda del método Add de la colección Documents. El tema de Ayuda muestra la siguiente información importante:
  • El "método Add" agrega un nuevo documento vacío a la colección de documentos abiertos.
  • El "método Add" puede tomar dos argumentos, siendo ambos opcionales.
Examine ahora la línea siguiente de la macro grabada: Selection.TypeText Text:="uno". Resalte Selection en el módulo de código y presione la tecla F1:
  • La "propiedad Selection" devuelve el objeto Selection que representa un intervalo seleccionado o el punto de inserción.
  • La "propiedad Selection" se aplica al objeto Application.
Vuelva a la macro grabada, resalte TypeText en el módulo de código y presione la tecla F1:
  • El "método TypeText" inserta el texto especificado.
  • El "método TypeText" tiene un argumento necesario de tipo String.
  • El "método TypeText" se aplica al objeto Selection.
Después, vea el tema de Ayuda de TypeParagraph:
  • El "método TypeParagraph" inserta un nuevo párrafo en blanco.
  • El "método TypeParagraph" se aplica al objeto Selection y no tiene ningún argumento.
Examine los temas de Ayuda de la propiedad ActiveDocument y el método SaveAs:
  • La "propiedad ActiveDocument" devuelve un objeto Document que representa el documento que tiene el enfoque. "ActiveDocument" se aplica al objeto Application.
  • El "método SaveAs" guarda un documento. Dependiendo de la versión de Word, este método tiene de 11 a 16 argumentos y sólo uno de ellos es obligatorio. "SaveAs" se aplica a un objeto Document.
Quizás haya observado que las propiedades Documents, Selection y ActiveDocument se aplican al objeto Application, pero que no están calificadas con "Application" en la macro grabada. Application es el objeto predeterminado para todas las propiedades y, por tanto, se puede omitir cuando se escribe código en una macro de VBA. Este no es el caso cuando se escribe código de automatización; todas las propiedades y los métodos deben calificarse totalmente en el código de automatización.

Al examinar la macro grabada, verá que el método SaveAs tiene un argumento para el que pasa la constante integrada wdFormatDocument. Dependiendo del lenguaje de programación que elija para el controlador de automatización, quizás tenga que pasar el valor numérico para las constantes integradas. El tema de Ayuda del método SaveAs no ofrece esta información, pero puede encontrarla en el Examinador de objetos. Presione la tecla F2 para mostrar el Examinador de objetos. Escriba:

wdFormatDocument

en la ventana de búsqueda y presione la tecla ENTRAR. En el panel inferior del Examinador de objetos verá el equivalente numérico de wdFormatDocument(=0), así como otra información acerca de la constante.

Referencias

Dónde puedo encontrar ejemplos de código de automatización

La información presentada hasta ahora le ofrece una buena base para escribir código de automatización. Microsoft Knowledge Base es un recurso excelente para encontrar ejemplos de código de automatización escritos en Visual Basic, Visual C++ y MFC. Aquí se indican algunos:

Para desarrolladores de Visual Basic

Para obtener más información al respecto, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
220595 Cómo automatizar Outlook con Visual Basic
219151 Cómo automatizar Microsoft Excel desde Visual Basic
147650 Cómo recorrer objetos de Excel desde Visual Basic
142387 Cómo crear un gráfico de Excel con automatización OLE desde Visual Basic
184974 Cómo usar la automatización (OLE) con Word
220607 Cómo automatizar Microsoft Word para que realice una combinación de correspondencia desde Visual Basic
222929 Cómo automatizar PowerPoint usando Visual Basic en Office 2003, en Office XP Developer y en Office 2000 Developer

Desarrolladores de Visual C++ (que utilicen MFC)

Para obtener más información al respecto, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
178749 Cómo crear un proyecto de automatización mediante MFC y una biblioteca de tipos
179706 Cómo usar MFC para automatizar Excel, crear un libro nuevo y darle formato
186120 Cómo usar MFC para automatizar Excel y rellenar un rango con una matriz
186122 Cómo usar MFC para automatizar Excel 2000 y Excel 2002, obteniendo una matriz desde un rango en Excel 2000 y Excel 2002
220911 Cómo automatizar Microsoft Word para que realice una combinación de correspondencia desde Visual C++ y MFC
222960 Cómo automatizar PowerPoint utilizando Visual C++ 5.0 o Visual C++ 6.0 con Microsoft Foundation Classes

Desarrolladores de C/C++ (sin MFC)

Para obtener más información al respecto, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
216686 Cómo automatizar Excel desde C++ sin usar MFC o #import
181473 Cómo usar automatización OLE desde una aplicación C en lugar de C++

Desarrolladores de Visual J++

Para obtener más información al respecto, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
219430 Cómo crear un libro de Excel o darle formato usando automatización Visual J++
215484 Cómo automatizar PowerPoint utilizando Visual J++ 6.0

Desarrolladores de Visual FoxPro

Para obtener más información al respecto, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
142193 Cómo usar una automatización OLE para agregar datos a una hoja Excel
180901 Cómo crear una tabla con categorías en Word 97 o en Office Word 2003 desde Visual FoxPro para Windows 5.0 y versiones posteriores
181926 Cómo automatizar la combinación de correspondencia en Word utilizando OLE y ODBC
194306 Cómo imprimir a doble cara en Word utilizando automatización OLE desde Visual FoxPro
230154 Cómo automatizar PowerPoint con Visual FoxPro
241942 Cómo prevenir un error de impresión de Word con la propiedad BackgroundPrintingStatus
Para obtener información adicional al respecto, incluyendo código de ejemplo y recursos para automatizar Microsoft Office, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/gp/ofd

Propiedades

Id. de artículo: 222101 - Última revisión: viernes, 16 de junio de 2006 - Versión: 6.1
La información de este artículo se refiere a:
  • Microsoft Office Standard Edition 2003
  • Microsoft Visual Basic 4.0 Professional Edition
  • Microsoft Visual Basic 5.0 Professional Edition
  • Microsoft Visual Basic 6.0 Professional Edition
  • Microsoft Visual Basic 4.0 Enterprise Edition
  • Microsoft Visual Basic 5.0 Enterprise Edition
  • Microsoft Visual Basic 6.0 Edición empresarial
  • Microsoft Visual C++ 4.0 Professional Edition
  • Microsoft Visual C++ 5.0 Professional
  • Microsoft Visual C++ 6.0 Professional
  • Microsoft Visual J++ 6.0 Edición estándar
  • Microsoft Visual Studio .NET 2002 Professional
  • Microsoft Visual Studio .NET 2003 Professional
  • Microsoft Access 2002 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Access 97 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Outlook 2002 Standard
  • Microsoft Outlook 2000 Standard
  • Microsoft Outlook 97 Standard
  • Microsoft Outlook 98 Standard
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft PowerPoint 97 Standard Edition
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
  • Microsoft Word 97 Standard Edition
  • Microsoft Visual FoxPro 5.0a
  • Microsoft Visual FoxPro 6.0 Professional Edition
  • Microsoft MapPoint 2002 Standard Edition
  • Microsoft MapPoint 2001 Standard Edition
Palabras clave: 
_ik11561 _ik11593 kbautomation kbgrpdso kbhowto kbvba kbvbp400 kbvbp500 kbvbp600 KB222101

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com