Office 개체 모델 설명서를 찾고 사용하는 방법

기술 자료 번역 기술 자료 번역
기술 자료: 222101 - 이 문서가 적용되는 제품 보기.
이 문서는 이전에 다음 ID로 출판되었음: KR222101
모두 확대 | 모두 축소

이 페이지에서

요약

이 문서에서는 Microsoft Office 응용 프로그램을 자동화하는 데 이용할 수 있는 리소스와 설명서를 제공합니다. 이 정보는 Office 응용 프로그램을 자동화하기 위해 선택한 프로그래밍 언어에 상관없이 적용할 수 있습니다. 이 문서에서는 또한 자동화 작업 중 특정 작업을 수행하는 데 필요한 정보를 설명서에서 찾는 방법을 안내하여 자동화 코드 작성을 시작하는 방법도 설명합니다.

추가 정보

개체 모델 설명서를 구하는 방법

Office 응용 프로그램의 개체 모델 설명서는 다음 두 Office 버전에 대하여 Language Reference로 작성되어 있습니다.

Microsoft Office 97 Visual Basic for Applications Language Reference
ISBN 1-57231-339-0

Microsoft Office 2000 Visual Basic for Applications Language Reference
ISBN 1-57231-955-0
Language Reference는 MSDN 및 Microsoft Office에서 제공하는 온라인 도움말에서 사용할 수 있습니다. 또한 인쇄본 형태로 구입할 수도 있습니다. 주문 정보는 다음을 참조하십시오.
http://www.microsoft.com/mspress/korea/
다음 표는 각 Office 응용 프로그램에 대한 도움말 파일을 나열한 것입니다.

표 축소표 확대
응용 프로그램버전 97(또는 8.0)버전 2000(또는 9.0)버전 2002(또는 10)버전 2003(또는 11)
OfficeVbaoff8.hlpVbaoff9.chmVbaof10.chmVbaof11.chm
AccessAcvba80.hlpAcmain9.chmAcmain10.chm, Vbaac10.chmACMAIN11.chm,VBAAC10.chm
ExcelVbaXl8.hlpVbaxl9.chmVbaxl10.chmVBAXL10.chm
MapPoint해당 없음Mappoint.chm(버전 2001)Mappoint.chmMAPPOINT.chmn(버전 2004)
OutlookVbaoutl.hlpVbaoutl9.chmVbaol10.chmVBAOL11.chm
PowerPointVbappt.hlpVbappt9.chmVbapp10.chmVBAPP10.chm
WordVbawrd8.hlpVbawrd9.chmVbawd10.chmVBAWD10.chm
GraphVbagrp8.hlpVbagrp9.chmVbagr10.chmVBAGR10.chm
FrontPage해당 없음Vbafp4.chm, Vbafpom4.chmVbafpd10.chm, vbafpw10.chmVBAFPD10.chm, VBAFPW10.chm
BinderVbabdr8.hlpVbabdr8.hlp중단됨


Microsoft Office 97과 함께 제공되는 도움말 파일은 기본적으로 다음 위치에 설치됩니다.
C:\Program Files\Microsoft Office\Office
필요한 Office 97 VBA 도움말 파일을 찾을 수 없다면 Office 97 설치 프로그램을 처음 실행할 때 도움말 파일이 설치되지 않은 것입니다. 도움말 파일을 설치하려면 Office 설치 프로그램을 실행하여 VBA 도움말 파일을 추가하십시오. Outlook 97 VBA 도움말 파일은 Office 설치 프로그램에 의해 설치되지 않습니다. Outlook 97 VBA 도움말 파일 설치에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
166738 OL97: Visual Basic 도움말을 설치하는 방법
Microsoft Office 2000과 함께 제공되는 도움말 파일은 기본적으로 다음 위치에 설치됩니다.
C:\Program Files\Microsoft Office\Office\1042
Microsoft Office XP와 함께 제공되는 도움말 파일은 기본적으로 다음 위치에 설치됩니다.
C:\Program Files\Microsoft Office\Office10\1042
C:\Program Files\Microsoft Office\Office11\1042
참고: Microsoft Office 2000, Microsoft Office XP 및 Microsoft Office 2003 설치 프로그램은 "처음 사용할 때" VBA 도움말 파일을 설치합니다. 따라서 이전에 Office 응용 프로그램에서 VBA 도움말에 액세스하지 않았다면 이 디렉터리에 도움말 파일이 없을 수 있습니다.

개체 모델 설명서를 사용하는 방법

특정 클래스, 메서드 또는 속성에 대한 설명서를 찾는 방법이 몇 가지 있습니다.
  • VBA 도움말 파일 검색:

    Office 응용 프로그램에 대한 Visual Basic Editor의 도움말 메뉴에서 목차색인을 누릅니다. 목차 탭에서 원하는 언어 참조를 선택하고 표시를 누릅니다. 선택한 언어 참조에 대한 VBA 도움말이 나타납니다. 이 때 색인 탭이나 찾기 탭 중 하나를 사용하여 특정 클래스, 메서드 또는 속성에 대한 정보를 찾을 수 있습니다.
  • 모듈 또는 직접 실행 창에서 상황에 맞는 도움말 사용:

    Office 응용 프로그램에 대한 Visual Basic Editor에서 모듈의 코드 창이나 직접 실행 창에 클래스, 메서드 또는 속성을 입력하고 텍스트를 강조 표시한 다음 F1 키를 누릅니다. 해당 항목에 대한 도움말 항목이 나타납니다.
  • 개체 브라우저 사용:

    개체 브라우저를 표시하려면 Office 응용 프로그램에 대한 Visual Basic Editor에서 F2 키를 누르십시오. 개체 브라우저는 해당 응용 프로그램이 제공하는 모든 클래스 및 각 클래스와 관련된 메서드나 속성을 나열합니다. 특정 클래스나 클래스 구성원에 대한 도움말을 보려면 개체 브라우저에서 해당 클래스나 클래스 구성원을 선택한 다음 F1 키를 누릅니다.

사용할 클래스, 메서드 및 속성을 판단하는 방법

자동화하려는 응용 프로그램의 개체 모델에 대하여 잘 알지 못하는 경우 해당 응용 프로그램의 매크로 기록을 사용하면 도움이 됩니다. 새 문서에 텍스트를 추가한 다음 Microsoft Word를 자동화하여 이 문서를 저장하려 할 경우 어떠한 메서드와 속성을 사용해야 할지 모르겠다면 다음과 같이 매크로 기록 기능을 사용할 수 있습니다.
  1. Microsoft Word를 시작합니다.
  2. 도구 메뉴의 매크로를 누른 다음 새 매크로 기록을 선택합니다. 새 매크로의 이름을 기록해 두고 확인을 눌러 기록을 시작합니다.
  3. 새 문서를 시작합니다.
  4. one을 입력한 다음 Enter 키를 누릅니다.
  5. two를 입력한 다음 Enter 키를 누릅니다.
  6. three를 입력합니다.
  7. 파일 메뉴의 저장을 누른 다음 문서를 "C:\doc1.doc"라는 이름으로 저장합니다.
  8. 기록 중지 단추를 누릅니다. 또는 도구 메뉴의 매크로를 누르고 기록 중지를 선택합니다.
  9. 이러한 작업에서 매크로 기록이 생성한 VBA 코드를 보려면 도구 메뉴의 매크로를 누른 다음 매크로를 선택합니다. 목록에서 새 매크로의 이름을 선택한 다음 편집을 누릅니다. Visual Basic Editor에 기록한 매크로가 나타납니다.
     Documents.Add
     Selection.TypeText Text:="one"
     Selection.TypeParagraph
     Selection.TypeText Text:="two"
     Selection.TypeParagraph
     Selection.TypeText Text:="three"
     ActiveDocument.SaveAs FileName:="Doc1.doc", FileFormat:=wdFormatDocument,_
       LockComments:=False, Password:="", AddToRecentFiles:=True, _ 
       WritePassword:="", ReadOnlyRecommended:=False, _
       EmbedTrueTypeFonts:=False, SaveNativePictureFormat:=False, _
       SaveFormsData:=False, SaveAsAOCELetter:= False
    					
각 클래스를 해당 개체 모델에 맞추는 방법을 이해하고, 사용하는 메서드 및 속성에 대한 모든 매개 변수의 설명과 유형을 알면 큰 도움이 됩니다.

우선 아래와 같은 기록된 매크로의 첫 줄을 조사하십시오.

Documents.Add

기록한 매크로에 대한 코드 모듈에서 Documents를 강조 표시하고 F1 키를 누르십시오. 도움말 항목에서 다음과 같은 중요한 정보를 제공합니다.
  • "Documents 속성"은 열려 있는 모든 문서를 나타내는 문서 모음을 반환합니다.
  • "Documents 속성"은 Application 개체에 적용됩니다.
기록한 매크로로 돌아가서 코드 모듈에서 Add를 강조 표시하고 F1 키를 누릅니다. 다양한 여러 개체에 Add 메서드가 있음을 설명하는 도움말 항목이 나타납니다. 문서 모음의 Add 메서드에 대한 도움말을 보려면 Documents를 누르십시오. 도움말 항목에서 다음과 같은 중요한 정보를 제공합니다.
  • "Add 메서드"는 열려 있는 문서 모음에 빈 새 문서를 추가합니다.
  • "Add 메서드"에는 두 가지 인수가 있으며 모두 선택적입니다.
이제 기록된 매크로의 다음 줄인 Selection.TypeText Text:="one"을 조사하십시오. 코드 모듈에서 Selection을 강조 표시하고 F1 키를 누르십시오.
  • "Selection 속성"은 선택한 범위나 삽입 지점을 나타내는 Selection 개체를 반환합니다.
  • "Selection 속성"은 Application 개체에 적용됩니다.
기록한 매크로로 돌아가서 코드 모듈에서 TypeText를 강조 표시하고 F1 키를 누르십시오.
  • "TypeText 메서드"는 지정한 텍스트를 삽입합니다.
  • "TypeText 메서드"에는 문자열 유형의 필수 인수가 하나 있습니다.
  • "TypeText 메서드"는 Selection 개체에 적용됩니다.
다음으로 TypeParagraph에 대한 도움말 항목을 보십시오.
  • "TypeParagraph 메서드"는 비어 있는 새 단락을 삽입합니다.
  • "TypeParagraph 메서드"는 Selection 개체에 적용되고 인수가 없습니다.
ActiveDocument 속성과 SaveAs 메서드에 대한 도움말 항목을 조사하십시오.
  • "ActiveDocument 속성"은 포커스를 가진 문서를 나타내는 Document 개체를 반환합니다. "ActiveDocument"는 Application 개체에 적용됩니다.
  • "SaveAs 메서드"는 문서를 저장합니다. Word 버전에 따라 이 메서드에는 11에서 16개의 인수가 있습니다. 이 중 하나만 필요합니다. "SaveAs"는 Document 개체에 적용됩니다.
Documents 속성, Selection 속성 및 ActiveDocument 속성은 모두 Application 개체에 적용되지만 기록된 매크로에서 "Application"으로 명시되어 있지는 않습니다. Application 개체는 모든 속성의 기본 개체이므로 VBA 매크로 코드 작성 시 이를 생략할 수 있습니다. 그러나 자동화 코드를 작성할 때는 해당되지 않으므로 자동화 코드에서는 모든 속성과 메서드를 완전히 명시해야 합니다.

기록한 매크로를 조사해 보면 SaveAs 메서드에는 기본 상수 wdFormatDocument를 전달하는 인수가 있음을 알게 됩니다. 자동화 컨트롤러에 대해 선택한 프로그래밍 언어에 따라 기본 상수에 숫자 값을 전달해야 할 수 있습니다. SaveAs 메서드에 대한 도움말 항목에는 이 정보가 나와 있지 않지만 개체 브라우저에서 이 정보를 찾을 수 있습니다. 개체 브라우저를 표시하려면 F2 키를 누르십시오. 검색 창에

wdFormatDocument

를 입력하고 Enter 키를 누르십시오. 개체 브라우저의 아래쪽 창에 wdFormatDocument(=0)의 숫자 값뿐 아니라 이 상수에 대한 다른 정보도 나타납니다.

참조

자동화 코드 예제를 구하는 방법

지금까지 이 문서에서 제공한 정보로도 자동화 코드를 작성할 수 있습니다. Visual Basic, Visual C++ 및 MFC로 작성된 자동화 코드 예제가 필요한 경우에는 Microsoft 기술 자료에서 찾아보십시오. 일부 문서를 예로 들면 다음과 같습니다.

Visual Basic 개발자용

자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
220595 HOWTO: Visual Basic을 사용하여 Outlook을 자동화하는 방법
219151 Visual Basic에서 Microsoft Excel을 자동화하는 방법
147650 Visual Basic에서 Excel 개체를 탐색하는 방법
142387 Visual Basic에서 OLE 자동화를 사용하여 Excel 차트를 만드는 방법
184974 OFF: Word에서 OLE 자동화를 사용하는 방법
220607 Visual Basic에서 Microsoft Word를 자동화하여 편지 병합을 수행하는 방법
222929 Office 2003, Office XP Developer 및 Office 2000 Developer에서 Visual Basic을 사용하여 PowerPoint를 자동화하는 방법

Visual C++ 개발자용(MFC를 사용하는 경우)

자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
178749 MFC와 형식 라이브러리를 사용하여 자동화 프로젝트를 만드는 방법
179706 HOWTO: MFC를 사용하여 Excel 자동화 및 새 통합 문서 만들기/서식 지정하기
186120 MFC를 사용하여 Excel을 자동화하고 배열로 범위를 채우는 방법
186122 MFC를 사용하여 Excel 2000 및 Excel 2002를 자동화하고 Excel 2000 및 Excel 2002의 범위에서 배열을 구하는 방법
220911 Microsoft Word를 자동화하여 Visual C++ 및 MFC를 사용하여 편지 병합을 수행하는 방법
222960 Microsoft Foundation Classes가 있는 Visual C++ 5.0 또는 Visual C++ 6.0을 사용하여 PowerPoint를 자동화하는 방법

C/C++ 개발자용(MFC를 사용하지 않는 경우)

자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
216686 C++에서 MFC나 #import를 사용하지 않고 Excel을 자동화하는 방법
181473 HOWTO: C++ 대신 C 응용 프로그램에서 OLE 자동화 사용

Visual J++ 개발자용

자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
219430 Visual J++ 자동화를 사용하여 Excel 통합 문서를 만들고 서식을 지정하는 방법
215484 Visual J++ 6.0을 사용하여 PowerPoint를 자동화하는 방법

Visual FoxPro 개발자용

자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
142193 OLE 자동화를 사용하여 Excel 시트에 데이터를 추가하는 방법
180901 Visual FoxPro for Windows 5.0 이상 버전의 Word 97 또는 Office Word 2003에서 분류된 테이블을 만드는 방법
181926 OLE 및 ODBC를 사용하여 Word에 대한 편지 병합을 자동화하는 방법
194306 Visual FoxPro의 자동화를 사용하여 Word에서 양면 인쇄하는 방법
230154 Visual FoxPro를 사용하여 PowerPoint를 자동화하는 방법
241942 BackgroundPrintingStatus 속성을 사용하여 Word 인쇄 오류를 예방하는 방법
Microsoft Office를 자동화하기 위한 예제 코드와 리소스를 비롯하여 이에 대한 자세한 내용을 보려면 다음 Microsoft 웹 사이트를 방문하십시오.
http://support.microsoft.com/gp/ofd(영문)




Microsoft 제품 관련 기술 전문가들과 온라인으로 정보를 교환하시려면 Microsoft 뉴스 그룹에 참여하시기 바랍니다.

속성

기술 자료: 222101 - 마지막 검토: 2007년 3월 20일 화요일 - 수정: 6.1
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Office Standard Edition 2003
  • Microsoft Visual Basic 4.0 Professional Edition
  • Microsoft Visual Basic 5.0 Professional Edition
  • Microsoft Visual Basic 6.0 Professional Edition
  • Microsoft Visual Basic 4.0 Enterprise Edition
  • Microsoft Visual Basic 5.0 Enterprise Edition
  • Microsoft Visual Basic 6.0 Enterprise Edition
  • Microsoft Visual C++ 4.0 Professional Edition
  • Microsoft Visual C++ 5.0 Professional Edition
  • Microsoft Visual C++ 6.0 Professional Edition
  • Microsoft Visual J++ 6.0 Standard Edition
  • Microsoft Visual Studio .NET 2002 Professional Edition
  • Microsoft Visual Studio .NET 2003 Professional Edition
  • Microsoft Access 2002 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Access 97 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft Outlook 97 Standard Edition
  • Microsoft Outlook 98 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft PowerPoint 97 Standard Edition
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
  • Microsoft Word 97 Standard Edition
  • Microsoft Visual FoxPro 5.0a
  • Microsoft Visual FoxPro 6.0 Professional Edition
  • Microsoft MapPoint 2002 Standard Edition
  • Microsoft MapPoint 2001 Standard Edition
키워드:?
_ik11561 _ik11593 kbautomation kbgrpdso kbhowto kbvba kbvbp400 kbvbp500 kbvbp600 KB222101

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com