Como localizar e utilizar a documentação sobre o modelo de objecto do Office

Traduções de Artigos Traduções de Artigos
Artigo: 222101 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sumário

Este artigo descreve os recursos e documentação disponível para automatizar a aplicações do Microsoft Office. Estas informações podem ser aplicadas independentemente da linguagem de programação que escolher para automatizar uma aplicação do Office. Este artigo também ilustra como pode começar a escrever código de automatização, percorrendo a documentação para localizar as informações que necessita de realizar uma tarefa específica através de automatização.

Mais Informação

Onde posso encontrar a documentação do modelo de objecto?

Os modelos de objecto para aplicações do Office estão documentados na referência de linguagem para ambas as versões do Office: Microsoft Office 97 Visual Basic for Applications Language Reference
ISBN 1-57231-339-0

Microsoft Office 2000 Visual Basic for Applications Language Reference
ISBN 1-57231-955-0.
As referências de idioma estão disponíveis na MSDN e na ajuda online fornecida com o Microsoft Office. Estes também podem ser adquiridas num formato impresso. Para ordenar informações, visite:
http://mspress.Microsoft.com
A tabela seguinte lista os ficheiros de ajuda para cada aplicação do Office.

Reduzir esta tabelaExpandir esta tabela
AplicaçãoVersão 97 (ou 8.0)Versão 2000 (ou 9.0)Versão 2002 (ou 10)Versão 2003 (ou 11)
OfficeVbaoff8.hlpVbaoff9.chmVbaof10.chmVbaof11.chm
AcessoAcvba80.hlpAcmain9.chmAcmain10.chm, Vbaac10.chmACMAIN11.chm, VBAAC10.chm
ExcelVbaXl8.hlpVbaxl9.chmVbaxl10.chmVBAXL10.chm
MapPointN/AMappoint.chm (ver.2001)Mappoint.chmMAPPOINT.chmn (versão 2004)
OutlookVbaoutl.hlpVbaoutl9.chmVbaol10.chmVBAOL11.chm
PowerPointVbappt.hlpVbappt9.chmVbapp10.chmVBAPP10.chm
WordVbawrd8.hlpVbawrd9.chmVbawd10.chmVBAWD10.chm
GráficoVbagrp8.hlpVbagrp9.chmVbagr10.chmVBAGR10.chm
FrontPageN/AVbafp4.chm, Vbafpom4.chmVbafpd10.chm, vbafpw10.chmVBAFPD10.chm, VBAFPW10.chm
ArquivadorVbabdr8.hlpVbabdr8.hlpDescontinuados


Os ficheiros de ajuda fornecidos com o Microsoft Office 97 são instalados por predefinição em:
C:\Programas\Microsoft Office\Office
Se não conseguir localizar o ficheiro de ajuda do VBA do Office 97 que necessário, provavelmente não foi instalado quando executou o programa de configuração Office 97 inicialmente. Para instalar o ficheiro de ajuda, execute a configuração do Office para adicionar o ficheiro de ajuda do VBA. Tenha em atenção que o ficheiro de ajuda de VBA do Outlook 97 não é instalado pelo programa de configuração do Office. Para obter informações sobre como instalar o ficheiro de ajuda de VBA do Outlook 97, consulte o seguinte artigo na base de dados de conhecimento da Microsoft:
166738OL97: Como instalar a ajuda do Visual Basic
Os ficheiros de ajuda fornecidos com o Microsoft Office 2000 são instalados por predefinição em:
C:\Programas\Microsoft Office\Office\1033
Os ficheiros de ajuda fornecidos com o Microsoft Office XP são instalados por predefinição em:
C:\Program Files\Microsoft Office\Office10\1033
C:\Program Files\Microsoft Office\Office11\1033
Nota : programas O Microsoft Office 2000, Microsoft Office XP e o programa de configuração do Microsoft Office 2003 instalam os ficheiros para ajuda do VBA "no primeira utilização." Por conseguinte, poderá não ver o ficheiro de ajuda existentes neste directório se ter não anteriormente tentou aceder ajuda do VBA na aplicação do Office.

Como posso utilizar a documentação do modelo de objecto?

Existem vários métodos que pode utilizar para localizar documentação para uma classe específica, método ou propriedade:
  • Procure o ficheiro de ajuda do VBA:

    No Visual Basic Editor da aplicação do Office, clique em índices no menu Ajuda . No separador conteúdo , seleccione a referência de idioma pretendido e clique em Mostrar . É apresentada a ajuda do VBA para a referência de linguagem que seleccionou. Neste ponto, é possível utilizar o índice remissivo ou no separador Localizar para localizar informações sobre uma classe específica, método ou propriedade.
  • Utilize ajuda sensível ao contexto de um módulo ou no painel de imediato:

    No Visual Basic Editor da aplicação do Office, escreva a classe, método ou propriedade na janela de código de um módulo ou na Janela Immediate , realce o texto e prima a tecla F1. Aparece o tópico de ajuda para o produto.
  • Utilize o Object Browser:

    Prima a tecla F2 no Editor do Visual Basic da aplicação do Office apresentar o Localizador de objectos . O Object Browser lista todas as classes que expõe a aplicação, métodos e propriedades associadas a cada classe. Para visualizar ajuda numa classe específica ou membro de classe, seleccione-a no localizador de objectos e prima a tecla F1.

Como posso saber que classes, métodos e propriedades para utilizar?

Se não estiver familiarizado com o modelo de objectos da aplicação que pretende automatizar, pode utilizar o gravador de macros da aplicação para ter uma ideia. Para ilustrar, suponha que pretende automatizar o Microsoft Word para adicionar texto a um novo documento e guarde o documento mas não souber os métodos e propriedades para utilizar, pode começar com o gravador de macros:
  1. Inicie o Microsoft Word.
  2. Clique em ' macro ' no menu Ferramentas e seleccione Gravar nova macro . Tome nota do nome da nova macro e clique em OK para iniciar a gravação.
  3. Inicie um novo documento.
  4. Escreva um e prima a tecla ENTER.
  5. Escreva dois e prima a tecla ENTER.
  6. Escreva três .
  7. Clique em Guardar no menu ficheiro e guarde o documento como "C:\doc1.doc."
  8. Clique no botão Parar Gravação (ou clique em ' macro ' no menu Ferramentas e seleccione Terminar gravação ).
  9. Para ver o código VBA que gerou o gravador de macros de suas acções, clique em ' macro ' no menu Ferramentas e seleccione macros . Seleccione o nome da nova macro na lista e clique em Editar . O Editor do Visual Basic é apresentado com a macro gravada:
     Documents.Add
     Selection.TypeText Text:="one"
     Selection.TypeParagraph
     Selection.TypeText Text:="two"
     Selection.TypeParagraph
     Selection.TypeText Text:="three"
     ActiveDocument.SaveAs FileName:="Doc1.doc", FileFormat:=wdFormatDocument,_
       LockComments:=False, Password:="", AddToRecentFiles:=True, _ 
       WritePassword:="", ReadOnlyRecommended:=False, _
       EmbedTrueTypeFonts:=False, SaveNativePictureFormat:=False, _
       SaveFormsData:=False, SaveAsAOCELetter:= False
    					
Pode beneficiar significativamente de compreender como cada classe se ajusta dentro do modelo de objectos e aprender a descrição e tipo de todos os parâmetros para os métodos e propriedades que utiliza.

Iniciar com a primeira linha da macro gravada a examinar: Documents.Add. Realce os documentos no módulo de código para a macro gravado e prima a tecla F1. O tópico de ajuda fornece-lhe as seguintes informações importantes:
  • "Propriedades de documentos" devolve um conjunto de documentos que representa todos os documentos abertos.
  • "Propriedades de documentos" aplicada ao objecto Application.
Volte a macro gravada, realce Adicionar no módulo de código e prima a tecla F1. Aparece um tópico de ajuda explicando que muitos objectos diferentes têm um método Add. Clique em documentos para ver a ajuda para o método Add da colecção de documentos. O tópico de ajuda fornece-lhe as seguintes informações importantes:
  • "Adicionar método" Adiciona um novo documento vazio à colecção de documentos abertos.
  • "Adicionar método" pode demorar dois argumentos, sendo que ambos são opcionais.
Agora, examine a linha seguinte na macro gravada: Selection.TypeText Text: = "um". Realce de selecção no módulo de código e prima a tecla F1:
  • "Selecção de propriedades" devolve o objecto de selecção que representa um intervalo seleccionado ou o ponto de inserção.
  • "Selecção de propriedades" aplicada ao objecto Application.
Volte a macro gravada, realce TypeText no módulo de código e prima a tecla F1:
  • O "método TypeText" insere o texto especificado.
  • O "método TypeText" tem um argumento obrigatório do tipo cadeia.
  • O "método TypeText" aplica-se o objecto da selecção.
Em seguida, consulte o tópico de ajuda para TypeParagraph :
  • O "método TypeParagraph" insere um novo parágrafo em branco.
  • O "método TypeParagraph" aplica-se para a selecção e tem sem argumentos.
Examine os tópicos de ajuda para a propriedade ActiveDocument e o método ' Guardar como ' :
  • A "propriedade ActiveDocument" devolve um objecto de documento que representa o documento com o foco. "ActiveDocument" aplica-se ao objeto Application.
  • O "método de ' Guardar como'" guarda um documento. Dependendo da versão do Word, este método tem de 11 a 16 argumentos, é necessário apenas um deles. "Guardar como" aplica-se a um objecto de documento.
Pode ter reparado que a propriedade de documentos , propriedade Selection e ActiveDocument propriedade estão todas as propriedades que aplicam ao objecto de aplicação mas ainda não são qualificadas com "Aplicações" na macro gravada. O objecto de aplicação é o objecto predefinido para todas as propriedades e, por isso, pode ser omitido ao escrever código numa macro VBA. Isto não é o caso, quando escrever o código de automatização; todas as propriedades e métodos devem ser totalmente qualificados do código de automatização.

Após o exame da macro gravada, verá que o método ' Guardar como ' tem um argumento para o qual transmitir a constante wdFormatDocument incorporado. Dependendo do idioma programação que escolher para o controlador de automatização, poderá ter de passar o valor numérico para as constantes incorporados. O tópico de ajuda para o método ' Guardar como ' não fornecer estas informações mas não pode localizar no Localizador de objectos . Prima a tecla F2 para apresentar o Localizador de objectos . Tipo:

wdFormatDocument

na janela de procura e prima a ENTER chave. No painel inferior do Object Browser , verá o equivalente numérico de wdFormatDocument(=0) , bem como outras informações sobre a constante.

Referências

Onde posso encontrar alguns automatização Exemplos de código?

As informações apresentadas até ao momento dá-lhe estabelecer boa base para escrever o código de automatização. A base de dados de conhecimento da Microsoft é um excelente recurso para localizar automatização Exemplos de código escritos no Visual Basic, Visual C++ e o MFC. Seguem-se apenas alguns:

Para programadores do Visual Basic

Para obter mais informações, clique números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft:
220595Como automatizar o Outlook utilizando o Visual Basic
219151Como automatizar o Microsoft Excel a partir do Visual Basic
147650Como navegar objectos do Excel a partir do Visual Basic
142387A criação de automatização do Excel gráfico w/OLE a partir do Visual Basic
184974Como utilizar a automatização (OLE) com o Word
220607Como automatizar o Microsoft Word para efectuar impressão em série a partir do Visual Basic
222929Como automatizar o PowerPoint utilizando o Visual Basic no Office 2003, no Office XP Developer e no Office 2000 Developer

Programadores de C++ Visual (utilizando MFC)

Para obter mais informações, clique números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft:
178749Como criar um projecto de automatização utilizando MFC e uma biblioteca de tipos
179706Como utilizar MFC para automatizar o Excel e criar e formatar um novo livro
186120Como utilizar MFC para automatizar o Excel e introduza um intervalo com uma matriz
186122Como utilizar MFC para automatizar o Excel 2000 e Excel 2002 e obter uma matriz de um intervalo no Excel 2000 e Excel 2002
220911Como automatizar o Microsoft Word para efectuar uma impressão em série utilizando o Visual C++ e MFC
222960Como automatizar o PowerPoint utilizando o Visual C++ 5.0 ou Visual C++ 6.0 com O Microsoft Foundation Classes

Programadores de C/C ++ (sem MFC)

Para obter mais informações, clique números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft:
216686Como automatizar o Excel a partir de C++ sem utilizar MFC ou #import
181473Como utilizar a automatização OLE a partir de uma aplicação C em vez de C++

Programadores de Visual J ++

Para obter mais informações, clique números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft:
219430Como criar/formato Livro do Excel utilizando automatização do Visual J ++
215484Como automatizar o PowerPoint utilizando o Visual J ++ 6.0

Visual FoxPro programadores

Para obter mais informações, clique números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft:
142193Como utilizar a automatização OLE para adicionar dados a folha de cálculo do Excel
180901Como criar uma tabela categorizada no Word 97 ou no Office Word 2003 do Visual FoxPro para Windows 5.0 e versões posteriores
181926Como automatizar o Word utilizando OLE e ODBC em série
194306Como tornar o Word de impressão duplex utilizando Automatização OLE a partir do Visual FoxPro
230154Como automatizar o PowerPoint utilizando o Visual FoxPro
241942Como evitar erro de impressão do Word com a propriedade BackgroundPrintingStatus
Para obter informações adicionais, incluindo o código de exemplo e recursos para automatizar o Microsoft Office, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/gp/ofd

Propriedades

Artigo: 222101 - Última revisão: 22 de novembro de 2005 - Revisão: 6.4
A informação contida neste artigo aplica-se a:
  • Microsoft Office 2003, All Editions
  • Microsoft Visual Basic 4.0 Professional Edition
  • Microsoft Visual Basic 5.0 Professional Edition
  • Microsoft Visual Basic 6.0 Professional Edition
  • Microsoft Visual Basic 4.0 Enterprise Edition
  • Microsoft Visual Basic 5.0 Enterprise Edition
  • Microsoft Visual Basic Enterprise Edition for Windows 6.0
  • Microsoft Visual C++ 4.0 Professional Edition
  • Microsoft Visual C++ 5.0 Professional Edition
  • Microsoft Visual C++ 6.0 Professional Edition
  • Microsoft Visual J++ 6.0 Standard Edition
  • Microsoft Visual Studio .NET 2002 Professional Edition
  • Microsoft Visual Studio .NET 2003 Professional Edition
  • Microsoft Access 2002 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Access 97 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft Outlook 2000
  • Microsoft Outlook 97 Standard Edition
  • Microsoft Outlook 98 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft PowerPoint 97 Standard Edition
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
  • Microsoft Word 97 Standard Edition
  • Microsoft Visual FoxPro 5.0a
  • Microsoft Visual FoxPro 6.0 Professional Edition
  • Microsoft MapPoint 2002 Standard Edition
  • Microsoft MapPoint 2001 Standard Edition
Palavras-chave: 
kbmt _ik11561 _ik11593 kbautomation kbgrpdso kbhowto kbvba kbvbp400 kbvbp500 kbvbp600 KB222101 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 222101

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com