Nasıl bulmak ve Office nesne modeli belgeler

Makale çevirileri Makale çevirileri
Makale numarası: 222101 - Bu makalenin geçerli olduğu ürünleri görün.
Hepsini aç | Hepsini kapa

Bu Sayfada

Özet

Bu makalede, kaynaklar ve Microsoft Office uygulamalarını otomatikleştirmek için kullanabileceğiniz belgelerine açıklanır. Bu bilgiler, bir Office uygulamasını otomatikleştirmek için seçtiğiniz bir programlama dili ne olursa olsun uygulanır. Bu makalede ayrıca, nasıl, Otomasyon yoluyla, belirli bir görevi gerçekleştirmek için gereksinim duyduğunuz bilgileri bulmak için belgeleri aracılığıyla atlama tarafından Otomasyon kod yazmaya başlayabilirsiniz göstermektedir.

Daha fazla bilgi

Nesne modeli belgelerine nereden EDINEBILIRIM?

Office uygulamaları için nesne modellerini iki Office sürümleri için bir dil başvurusu belgelenmiştir: Microsoft Office 97 Visual Basic Applications dil başvurusu için
1-57231-339-0 isbn

Microsoft Office 2000 Visual Basic Applications dil başvurusu için
1-57231-955-0 isbn.
Dil başvuruları, MSDN ve Microsoft Office ile birlikte gelen çevrimiçi Yardım kullanılabilir. Bunlar aynı zamanda yazdırılan formda satın alınabilir. Sipariş bilgisi için lütfen aşağıdaki adresi ziyaret edin:
http://mspress.Microsoft.com
Aşağıdaki tablo her Office uygulaması için Yardım dosyaları listeler.

Bu tabloyu kapaBu tabloyu aç
UygulamaSürüm 97 (veya 8.0)Sürüm 2000 (veya 9.0)Sürüm 2002 (veya 10)Sürüm 2003 (veya 11)
OfficeVbaoff8.hlpVbaoff9.chmVbaof10.chmVbaof11.chm
AccessAcvba80.hlpAcmain9.chmAcmain10.chm, Vbaac10.chmACMAIN11.chm, VBAAC10.chm
ExcelVbaXl8.hlpVbaxl9.chmVbaxl10.chmVBAXL10.chm
MapPointYokMappoint.chm (ver.2001)Mappoint.chmMAPPOINT.chmn (sürüm 2004)
OutlookVbaoutl.hlpVbaoutl9.chmVbaol10.chmVBAOL11.chm
PowerPointVbappt.hlpVbappt9.chmVbapp10.chmVBAPP10.chm
WORDVbawrd8.hlpVbawrd9.chmVbawd10.chmVBAWD10.chm
GrafikVbagrp8.hlpVbagrp9.chmVbagr10.chmVBAGR10.chm
FrontPageYokVbafp4.chm, Vbafpom4.chmVbafpd10.chm, vbafpw10.chmVBAFPD10.chm, VBAFPW10.chm
CiltçiVbabdr8.hlpVbabdr8.hlpPiyasadan kalkıyor


Microsoft Office 97 ile birlikte gelen Yardım dosyaları varsayılan olarak yüklenir:
C:\Program Files\Microsoft Office\Office
Size gereken Office 97 VBA Yardım dosyasını bulamıyorsanız, Office 97 Kur ilk çalıştırdığınızda, büyük olasılıkla yüklenmedi. Yardım dosyasını yüklemek için <a0></a0>, VBA Yardım dosyası eklemek için Office Kur'u çalıştırın. Outlook 97 VBA Yardım dosyasını Office Kurulum tarafından yüklendiğini unutmayın. Outlook 97 VBA Yardım dosyası'nı yükleme hakkında daha fazla bilgi için lütfen Microsoft Knowledge Base'de aşağıdaki makaleye bakın:
166738OL97: Visual Basic Yardımı'nı yüklemek nasıl
Microsoft Office 2000 ile birlikte gelen Yardım dosyaları varsayılan olarak yüklenir:
C:\Program Files\Microsoft Office\Office\1033
Microsoft Office XP ile birlikte gelen Yardım dosyaları varsayılan olarak yüklenir:
C:\Program Files\Microsoft Office\Office10\1033
C:\Program Files\Microsoft Office\Office11\1033
Not: Microsoft Office 2000, Microsoft Office XP ve Microsoft Office 2003 Kur programı VBA Yardım dosyalarında "ilk kullanımda." yükleyin Bu nedenle, daha önce VBA Yardım Office uygulamasında erişmeye çalıştığınız değildir, bu dizindeki Yardım dosyasını görmeyebilirsiniz.

Nesne modeli belgeleri nasıl kullanabilirim?

Belirli bir sınıf, yöntem veya özellik için belgeleri bulmak için kullanabilirsiniz, birkaç yöntem vardır:
  • VBA Yardım dosyasını arayın:

    Office uygulaması için Visual Basic Editor'da, Yardım menüsünde içindekiler ve Dizin'i tıklatın. Içindekiler sekmesinde, Göster ' i tıklatın ve istediğiniz dili başvuruyu seçin. Seçtiğiniz dil başvurusu için VBA Yardım görüntülenir. Bu noktada, dizin veya Bul) sekmesini, bir özel sınıf, yöntem veya özellik hakkında bilgi bulmak için kullanın.
  • Içerik duyarlı Yardım, komut bölmesinde veya bir modülde kullanın:

    Visual Basic Düzenleyicisi'nde bir Office uygulaması için metni vurgulayın sınıf, yöntem veya özellik kod penceresinde bir modül veya Anlık pencere yazın ve F1 tuşuna basın. Madde için bir Yardım konusu görüntülenir.
  • Böylece Nesne Tarayıcısı'nı kullanın:

    Visual Basic Düzenleyicisi'nde Office uygulamasının Nesne Gözatıcısı ' nı görüntülemek için F2 tuşuna. Nesne Tarayıcısı, uygulamayı gösteren tüm sınıflar ve yöntemler veya her sınıf ile ilişkili özellikleri listeler. Belirli bir sınıfın veya sınıf üyesi üzerinde görüntülemek için <a0></a0>, nesne tarayıcı içinde seçin ve F1 tuşuna basın.

Hangi sınıflarını, yöntemlerini ve özelliklerini kullanmak için nasıl anlarım?

Zaten otomatikleştirmek istediğiniz uygulama nesne modeliyle alışık değilseniz, bir fikir edinmek için uygulamanın makro kaydedicisi kullanabilirsiniz. Otomasyon gerçekleştirmek istediğiniz varsayın göstermek için Microsoft Word'ün bazı metin yeni belgeye ekleyin ve sonra belge ancak yoksa biliyor hangi yöntemleri ve özellikleri kullanmak için; makro kaydedici ile başlatabilirsiniz:
  1. Microsoft Word'ü başlatın.
  2. Makro, Araçlar menüsünden Seçenekler'i tıklatın ve sonra Yeni Makro Kaydet'i seçin. Yeni makro adını not alın ve kaydı başlatmak için Tamam ' ı tıklatın.
  3. Yeni bir belge açın.
  4. Bir yazın ve ENTER tuşuna basın.
  5. Iki yazın ve ENTER tuşuna basın.
  6. Üç yazın.
  7. Dosya menüsünde <a1>Kaydet</a1> seçeneğini tıklatın ve belgeyi "C:\doc1.doc." olarak kaydedin.
  8. Kaydı Durdur düğmesini tıklatın (veya makro için Araçlar menüsünden ve seçme Kaydı Durdur tıklatın).
  9. Makro kaydedici, eylemlerden oluşturulan VBA kodunu görüntülemek için <a0></a0>, makro, Araçlar menüsünden Seçenekler'i tıklatın ve makrolar ' ı seçin. Yeni bir makro adını listeden seçin ve Düzenle ' yi tıklatın. Visual Basic Düzenleyicisi ile kayıtlı makroyu görüntülenir:
     Documents.Add
     Selection.TypeText Text:="one"
     Selection.TypeParagraph
     Selection.TypeText Text:="two"
     Selection.TypeParagraph
     Selection.TypeText Text:="three"
     ActiveDocument.SaveAs FileName:="Doc1.doc", FileFormat:=wdFormatDocument,_
       LockComments:=False, Password:="", AddToRecentFiles:=True, _ 
       WritePassword:="", ReadOnlyRecommended:=False, _
       EmbedTrueTypeFonts:=False, SaveNativePictureFormat:=False, _
       SaveFormsData:=False, SaveAsAOCELetter:= False
    					
Her sınıf, nesne modeli nasıl uyguladığı anlama ve yöntemlerini ve özelliklerini kullanarak tüm parametreleri tür ve açıklama öğrenme önemli ölçüde yararlanabilir.

Ilk satırı kayıtlı makroyu inceleniyor ile başlatın: Documents.Add. Kaydedilen makro için kod modülde Belgeler vurgulayın ve F1 tuşuna basın. Yardım konusu aşağıdaki önemli bilgileri sağlar:
  • "Belgeler özelliği" tüm açık belgeleri gösteren bir belge koleksiyonu döndürür.
  • "Belgeler özelliği" için <a2>Uygulama</a2> nesnesinin uygulanır.
Kayıtlı makroyu için iade kod modülü, Ekle ' ni vurgulayın ve F1 tuşuna basın. Çok sayıda farklı nesne bir Add yöntemi olduğunu açıklayan BIR Yardım konusu görüntülenir. Belgeler belgeler tahsilat <a1>Ekle</a1> yöntemi için Yardım'ı görmek için Ek Yardım düğmesini tıklatın. Yardım konusu aşağıdaki önemli bilgileri sağlar:
  • "Add yöntemi" yeni, boş bir belge açık belgelerin derlemesine ekler.
  • "Add yöntemi" her ikisi de, isteğe bağlı olan iki bağımsız değişkeni olarak alabilir.
Şu anda kaydedilen makro bir sonraki satıra inceleyin: Selection.TypeText metin: "bir" =. Kod modülü, seçim vurgulayın ve F1 tuşuna basın:
  • "Seçim özelliği" seçili bir aralığa ya da ekleme noktasını gösteren bir seçenek nesnesi döndürür.
  • "Seçim özelliği" için <a2>Uygulama</a2> nesnesinin uygulanır.
Kaydedilen makroyu için iade TypeText kod modülü, vurgulamak ve F1 tuşuna basın:
  • "TypeText yöntemi" Belirtilen metni ekler.
  • "TypeText yöntemi" dize türünün gerekli bir bağımsız değişken var.
  • "TypeText yöntemi" seçim nesneye uygular.
Ardından, TypeParagraph için Yardım konusuna bakın:
  • "TypeParagraph yöntemi" yeni, boş bir paragraf ekler.
  • "TypeParagraph yöntemi" seçim nesneye uygulanır ve hiçbir bağımsız değişkenlere sahiptir.
ActiveDocument'e özelliği ve SaveAs yöntemini Yardım konularını inceleyin:
  • "ActiveDocument'e özelliği" odağı olan belgeyi gösteren bir belge nesnesi döndürür. "ActiveDocument'e" için <a2>Uygulama</a2> nesnesinin uygulanır.
  • "SaveAs yöntemini" belgeyi kaydeder. Word sürümüne bağlı olarak, bu yöntem 11-16 bağımsız, yalnızca biri gereklidir var. "Farklı Kaydet" bir Document nesnesi için geçerlidir.
Belge özelliği, seçim özelliği ve ActiveDocument'e özelliği için <a2>Uygulama</a2> nesnesinin geçerli, ancak henüz "İle uygulaması" kayıtlı makroyu nitelenir değil, tüm özellikleri olduğunu fark. Uygulama nesnesinin, tüm özellikleri için varsayılan nesne ve bu nedenle kod, VBA makro yazarken atlanabilir. Bu durum Otomasyon kod yazarken değildir; tüm özellikleri ve yöntemleri Otomasyon kodunuzda tam.

Kaydedilen makroyu incelenmesi SaveAs yöntemini yerleşik sabit wdFormatDocument geçirmeden bağımsız değişken olduğunu bakın. Otomasyon denetleyiciniz için seçtiğiniz programlama diline bağlı olarak yerleşik sabitler için sayısal bir değer geçmesi gerekebilir. SaveAs yöntemi için bir Yardım konusu bu bilgileri vermek, ancak Nesne Gözatıcısı bulabilirsiniz. Nesne Gözatıcısı ' nı görüntülemek için F2 tuşuna basın. TYPE:

wdFormatDocument

ENTER tuşuna basın ve arama penceresi anahtar. Nesne Tarayıcısı <a1>alt</a1> bölmesinde wdFormatDocument(=0) yanı sıra diğer bilgiler sabit sayısal eşdeğeri bakın.

Referanslar

Bazı Otomasyon kod örnekleri nereden EDINEBILIRIM?

Şu ana kadar sunulan bilgiler, otomasyon kod yazmak için iyi groundwork sağlar. Microsoft Bilgi Bankası, otomasyon kod örnekleri Visual Basic, Visual C++ ve MFC bulmak için mükemmel bir kaynaktır. Birkaç şunlardır:

Visual Basic geliştiricileri için

Daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleleri görüntülemek üzere aşağıdaki makale numaralarını tıklatın:
220595Outlook, Visual Basic kullanarak otomatikleştirme
219151Microsoft Excel Visual Basic kullanarak otomatikleştirme
147650Excel'in nasıl Visual Basic'den nesneleri
142387Excel grafiği w/OLE Otomasyon Visual Basic'den oluşturma hakkında
184974Word'le (OLE) otomasyonunu nasıl kullanılır
220607Microsoft Word'ün Visual Basic'den adres-mektup birleştirmeyi gerçekleştirdiğinizde otomatikleştirme
222929PowerPoint, Office 2003, Office XP Developer ve Office 2000 Developer Visual Basic kullanarak otomatikleştirme

(MFC kullanarak), visual C++ geliştiricileri

Daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleleri görüntülemek üzere aşağıdaki makale numaralarını tıklatın:
178749MFC ve bir tür kitaplığı'nı kullanarak bir Otomasyon Proje oluşturma
179706Excel'in otomatikleştirmek oluşturmak ve yeni bir çalışma kitabı biçimlendirmek için MFC nasıl kullanılır
186120Excel'in otomatikleştirmek ve aralığı ile ilgili bir dizi doldurmak için MFC nasıl kullanılır
186122Excel 2000 ve Excel 2002 otomatikleştirmek ve Excel 2000 ve Excel 2002'de bir aralıktan bir dizi MFC nasıl kullanılır
220911Visual C++ MFC ile adres mektup birleştirme gerçekleştirmek için Microsoft Word otomatikleştirme
222960PowerPoint, Visual C++ 5.0 veya Visual C++ 6.0 ile Microsoft Foundation Sınıf kullanarak otomatikleştirme

C/C++ geliştiricileri olmadan (MFC)

Daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleleri görüntülemek üzere aşağıdaki makale numaralarını tıklatın:
216686Excel'den, C++ MFC veya alma kullanmadan otomatikleştirme
181473Bir C uygulama yerine C++ OLE Otomasyonu kullanma

Visual J ++ geliştiriciler

Daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleleri görüntülemek üzere aşağıdaki makale numaralarını tıklatın:
219430Visual J ++ Otomasyon kullanarak bir Excel çalışma kitabı oluşturun/biçimi hakkında
215484PowerPoint, Visual J ++ 6.0 kullanarak otomatikleştirme

Visual FoxPro geliştiriciler

Daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleleri görüntülemek üzere aşağıdaki makale numaralarını tıklatın:
142193Excel sayfaya veri eklemek için OLE Otomasyonu kullanma
180901Visual FoxPro için Windows 5.0 ve sonraki sürümlerinde, Office Word 2003 veya Word 97'de, kategorilere ayrılan tablo oluşturma hakkında
181926OLE ve ODBC kullanarak Word'e adres-mektup birleştirme otomatikleştirme
194306Word, Visual FoxPro gelen OLE otomasyonunu kullanarak çift yönlü yazdırmayı nasıl
230154PowerPoint, Visual FoxPro kullanarak otomatikleştirme
241942Word yazdırma hata BackgroundPrintingStatus özelliğiyle engelleme
Örnek kod ve Microsoft Office'i otomatikleştirme kaynakları da dahil olmak üzere, ek bilgi için aşağıdaki Microsoft Web sitesini ziyaret edin:
http://support.microsoft.com/gp/ofd

Özellikler

Makale numarası: 222101 - Last Review: 22 Kasım 2005 Salı - Gözden geçirme: 6.4
Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Office 2003, All Editions
  • Microsoft Visual Basic 4.0 Professional Edition
  • Microsoft Visual Basic 5.0 Professional Edition
  • Microsoft Visual Basic 6.0 Professional Edition
  • Microsoft Visual Basic 4.0 Enterprise Edition
  • Microsoft Visual Basic 5.0 Enterprise Edition
  • Microsoft Visual Basic Enterprise Edition for Windows 6.0
  • Microsoft Visual C++ 4.0 Professional Edition
  • Microsoft Visual C++ 5.0 Professional Edition
  • Microsoft Visual C++ 6.0 Professional Edition
  • Microsoft Visual J++ 6.0 Standard Edition
  • Microsoft Visual Studio .NET 2002 Professional Edition
  • Microsoft Visual Studio .NET 2003 Professional Edition
  • Microsoft Access 2002 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Access 97 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft Outlook 2000
  • Microsoft Outlook 97 Standard Edition
  • Microsoft Outlook 98 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft PowerPoint 97 Standard Edition
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
  • Microsoft Word 97 Standard Edition
  • Microsoft Visual FoxPro 5.0a
  • Microsoft Visual FoxPro 6.0 Professional Edition
  • Microsoft MapPoint 2002 Standard Edition
  • Microsoft MapPoint 2001 Standard Edition
Anahtar Kelimeler: 
kbmt _ik11561 _ik11593 kbautomation kbgrpdso kbhowto kbvba kbvbp400 kbvbp500 kbvbp600 KB222101 KbMttr
Machine-translated Article
ÖNEMLİ: Bu makale, bir kişi tarafından çevrilmek yerine, Microsoft makine-çevirisi yazılımı ile çevrilmiştir. Microsoft size hem kişiler tarafından çevrilmiş, hem de makine-çevrisi ile çevrilmiş makaleler sunar. Böylelikle, bilgi bankamızdaki tüm makalelere, kendi dilinizde ulaşmış olursunuz. Bununla birlikte, makine tarafından çevrilmiş makaleler mükemmel değildir. Bir yabancının sizin dilinizde konuşurken yapabileceği hatalar gibi, makale; kelime dağarcığı, söz dizim kuralları veya dil bilgisi açısından yanlışlar içerebilir. Microsoft, içeriğin yanlış çevrimi veya onun müşteri tarafından kullanımından doğan; kusur, hata veya zarardan sorumlu değildir. Microsoft ayrıca makine çevirisi yazılımını sıkça güncellemektedir.
Makalenin İngilizcesi aşağıdaki gibidir:222101

Geri Bildirim Ver

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com