Ppt2000: Introducción a la programación de macros en PowerPoint 2000

Seleccione idioma Seleccione idioma
Id. de artículo: 222771 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Resumen

En este artículo explica los pasos para crear una sencilla de Microsoft Visual Basic para Aplicaciones de macro de Microsoft PowerPoint. La macro crear will agregar una diapositiva a la presentación, establezca una textura de fondo para una diapositiva, establecer los intervalos de diapositiva y ejecutar una presentación con diapositivas.

En este artículo está diseñado para presentarle algunas de las herramientas y conceptos tiene que ser un programador de macros.

Más información

Microsoft proporciona ejemplos de programación fines ilustrativos únicamente, sin ninguna garantía tanto expresa como implícita. Esto incluye, pero no se limita a, las garantías implícitas de comerciabilidad o idoneidad para un fin determinado. Este artículo se supone que está familiarizado con el lenguaje de programación que se muestra y con las herramientas que se utilizan para crear y depurar procedimientos. Los ingenieros de soporte técnico de Microsoft pueden explicarle la funcionalidad de un determinado procedimiento, pero no modificarán estos ejemplos para ofrecer mayor funcionalidad ni crearán procedimientos adaptados a sus requerimientos específicos. NOTA: Los siguientes ejemplos de macro sólo funcionan en PowerPoint. Visual Basic para Aplicaciones, las macros no son compatibles con Microsoft PowerPoint Viewer. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

Crear una nueva presentación

  1. En el Archivo menú, haga clic en Nuevo. Esto abre el Nueva presentación cuadro de diálogo.
  2. Seleccione el Presentación en blanco icono en el Ficha general y haga clic en ACEPTAR. Esto abre el Nueva diapositiva cuadro de diálogo.
  3. Haga clic para seleccionar la Autodiseño en blanco, situado en la esquina inferior derecha y haga clic en ACEPTAR.
Ahora tiene una presentación en blanco abierto, preparado para crear la macro.

Crear una Macro

  1. En el Herramientas menú, elija Macroy, a continuación, haga clic en Macros. Esto abre el Macro cuadro de diálogo.
  2. En el Macro cuadro Nombre, escriba un nombre para la macro. El nombre debe comenzar con una letra y puede contener hasta 80 caracteres. Visual Basic para aplicaciones de palabras clave es nombres válidos para las macros. El nombre no puede contener espacios. Por lo general, los programadores utilizan un character(_) de carácter de subrayado para separar palabras.

    No se preocupe tratar de recordar todas las reglas para asignar nombres a las macros. Si escribe un nombre no válido, PowerPoint mostrará un cuadro de diálogo cuadro con un mensaje similar al siguiente:
    nombre de la macro no es un nombre válido para una macro
    Si ve este mensaje, siga intentándolo hasta que encuentre un nombre PowerPoint aceptará.
  3. Haga clic en Crear. Se abrirá el Editor de Visual Basic. El objeto Visual Editor básico es una aplicación donde puede crear, editar y depurar las macros.

Agregar código a una nueva Macro

Ahora piense en un cursor parpadeante en la ventana de código. La ventana de código es donde realmente escribir comandos de Visual Basic. A macro grabada también puede verse en la ventana de código. En su mayor parte, la ventana de código actúa como un editor de texto habitual, lo que le permite cortar, copiar y pegar texto. Sin embargo, existen algunas diferencias que lo hacen más fácil de crear macros. Se detallan las diferencias más importantes a continuación.
  1. Escriba la siguiente línea de código entre las Sub y End Sub:
    Dim MySlide As Slide
    						
    Cuando se escribe en el código, habrá notado algunas interesantes ocurren cosas. Después de presionar espacio después de la palabra "como", aparecía una lista de los tipos de datos disponibles en la pantalla. Esto es sólo una de las formas en el Editor de Visual Basic hace un poco de programación más fácil.

    ¿Qué hace este código?

    Dim

    Indicates to the Visual Basic Editor you are about to declare a variable. There are several other methods available to declare variables, but this article discusses only the Dim method.

    MySlide

    Is the name you provide the variable. It is a good idea to give your variables meaningful descriptive names. X is an example of a poor variable name. Meaningful names make your code easier to read.

    As Slide

    Specifies the type of data the variable will contain. Inthis case, MySlide will have the data type Slide.

  2. Vamos a agregar más código. Escriba la siguiente línea de código después de la declaración de variable:
    Set MySlide = ActivePresentation.Slides.Add(1, ppLayoutTitle)
    						
    Este código agrega una nueva diapositiva a la presentación activa. La diapositiva es decir creado utiliza el título sólo auto layout.

    Set MySlide

    Assigns an object reference to a variable or property. Using Set makes it easier to refer to that same object later in your code.

    ActivePresentation

    Tells the Visual Basic Editor you are referring to the presentation that is open in the active window.

    Add(1, ppLayoutTitle)

    Creates a new slide and adds it to the collection of slides in the presentation. The Add method takes two parameters:

    The first parameter, the slide index, is the number 1 in this case. The slide index is the position where PowerPoint creates the slide. When the index is set to 1, PowerPoint creates the new slide at the beginning of the presentation.

    The second parameter specifies the type of AutoLayout.

    Para obtener más información acerca de cómo crear mediante programación de diapositivas, haga clic en Ayuda de Microsoft PowerPoint En la página Ayuda menú, escriba Agregar diapositivas en el Ayudante de Office o el Asistente para Ayuda y haga clic en Búsqueda Para ver el tema.
    Para obtener más información acerca de la diapositiva autodiseños disponibles, haga clic en Ayuda de Microsoft PowerPoint En la página Ayuda menú, escriba Tipo de PpPlaceHolder en el Ayudante de Office o el Asistente para Ayuda y haga clic en Búsqueda Para ver el tema.
    SUGERENCIA: Cuando se escribe código, si aparece la lista de propiedades y métodos, puede seleccionar el elemento que desee y, a continuación, presione la tecla TAB, que agrega el objeto a su petición y sitúe el cursor en la misma línea. El código de macro debería parecerse ahora al siguiente:
          Sub YourMacro ()
             '
             ' Macro created 1/7/97 by You
             '
             Dim MySlide As Slide
             Set MySlide = ActivePresentation.Slides.Add(1, ppLayoutTitle)
    
          End Sub
    NOTA: El texto siguiente ' apóstrofo (en la misma línea) es un comentario. Los comentarios se ignoran por el Editor de Visual Basic. Se agregan al código para que sea más fácil de entender.

    Ahora que la macro hace realmente algo, pruebe a ejecutar el macro.

Ejecutar la Macro

Existen varios métodos para ejecutar una macro. Sólo un método se describe en en este artículo.
  1. Haga clic en Cerrar y volver a Microsoft PowerPoint desde el Archivo menú. El Cierra el Editor de Visual Basic y volver a PowerPoint.
  2. En el Herramientas menú, elija Macroy, a continuación, haga clic en Macros. Se abrirá el cuadro de diálogo Macro.
  3. Seleccione la macro en la lista y, a continuación, haga clic en Ejecutar.
PowerPoint agregará una nueva diapositiva al principio de la presentación.

Ver el código de Macro

Para ver el código fuente de una macro específica, siga estos pasos:
  1. En el Herramientas menú, elija Macroy, a continuación, haga clic en Macros. Aparecerá el cuadro de diálogo Macro.
  2. Haga clic en la macro que desea editar. El nombre de la macro debe aparecer resaltado.
  3. Haga clic en Editar Botón. Esto abre la macro en el Editor de Visual Basic. El Editor de Visual Basic es donde realizar las correcciones, quitar los pasos innecesarios, o agregue instrucciones no se pueden grabar en PowerPoint.

Agregar más código

Ahora estamos preparados agregar el resto de los comandos para completar la macro.
  1. Agregue la siguiente línea de código a la macro:
    ActiveWindow.ViewType = ppViewSlideSorter
    						
    Esto cambia la presentación a la vista Clasificador de diapositivas. Agregue lo siguiente para que pueda seleccionar toda la diapositiva.
    Para obtener más información acerca de las vistas de PowerPoint, haga clic en Ayuda de Microsoft PowerPoint En la página Ayuda menú, escriba vistas en el Ayudante de Office o el Asistente para Ayuda y haga clic en Búsqueda Para ver el tema.
  2. Agregue la siguiente línea de código a la macro:
    MySlide.Select
    						
    Este código selecciona la diapositiva que se ha creado. MySlide es el objeto referencia que se ha creado con la instrucción Dim.
  3. Agregue la siguiente sección de código a la macro:
          With ActiveWindow.Selection.SlideRange
             .FollowMasterBackground = msoFalse
             .Background.Fill.PresetTextured msoTextureRecycledPaper
          End With
    						
    Estos comandos indicarle a PowerPoint que no la diapositiva concreta siguen el patrón y, a continuación, establezca el fondo ajuste preestablecido de textura para el papel reciclado. La instrucción With permite a los comandos de grupo que tengan comunes hace referencia. Si utiliza con para agrupar varios comandos, puede mejorar el rendimiento de la macro, así como ahorrar mucha escritura.
    Si no utiliza la instrucción With, el código tendría un aspecto similar al siguiente:
          ActiveWindow.Selection.SlideRange.FollowMasterBackground = msoFalse
          ActiveWindow.Selection.SlideRange.Background.Fill.PresetTextured _
             msoTextureRecycledPaper
    						
    El carácter de subrayado en la segunda línea es un carácter de continuación. Indica a el Editor de Visual Basic que no se ajustaba el comando específico en una línea y sigue las instrucciones en la línea siguiente. Puede ver la ventaja de utilizar con instrucciones; escribir menos y código más rápido. La única desventaja de la instrucción With es a veces hace que el código sea más difícil de leer, especialmente, si anida r con dentro de otra declaración.
  4. Agregue la siguiente línea de código a la macro:
    MySlide.Shapes.Title.TextFrame.TextRange.Text = "Look What I Did!"
    						
    Este comando agrega el texto "Mire lo que hice!" en el cuadro Título de la diapositiva creada.
  5. Agregue la siguiente sección de código a la macro:
          With ActivePresentation.Slides.Range.SlideShowTransition
             .AdvanceTime = 5
             .EntryEffect = ppEffectCheckerboardAcross
          End With
    						
  6. Agregar la última línea de código a la macro:
    ActivePresentation.SlideShowSettings.Run
    						
    Este código inicia la presentación con diapositivas.

El código de la Macro completa



   Sub YourMacro()
      '
      ' Macro created <Date> by <You>
      '
      Dim MySlide As Slide

      ' Add a new slide to the presentation.
      Set MySlide = ActivePresentation.Slides.Add(1, ppLayoutTitle)

      ' Change the presentation to slide sorter view.
      ActiveWindow.ViewType = ppViewSlideSorter

      ' Select your slide.
      MySlide.Select

      ' Apply a preset texture to the slide.
      With ActiveWindow.Selection.SlideRange
         .FollowMasterBackground = msoFalse
         .Background.Fill.PresetTextured msoTextureRecycledPaper
      End With

      ' Add text into title of the slide.
      MySlide.Shapes.Title.TextFrame.TextRange.Text = "Look What I Did!"

      ' Set the slide timing and transition effect.
      With ActivePresentation.Slides.Range.SlideShowTransition
         .AdvanceTime = 5
         .EntryEffect = ppEffectCheckerboardAcross
      End With

      ' Start the slide show.
      ActivePresentation.SlideShowSettings.Run

   End Sub
				

Referencias

Para obtener más información acerca de cómo utilizar el código de ejemplo en este artículo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
212536OFF2000: Cómo ejecutar el código de ejemplo de artículos de Knowledge Base

Propiedades

Id. de artículo: 222771 - Última revisión: domingo, 10 de marzo de 2013 - Versión: 4.0
La información de este artículo se refiere a:
  • Microsoft PowerPoint 2000 Standard Edition
Palabras clave: 
kbcode kbdtacode kbmacro kbprogramming kbmt KB222771 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 222771

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com