Article ID: 223420 - Last Review: November 3, 2008 - Revision: 4.1

When printing in Word 2000, you receive the error message "Windows cannot print due to a problem with the current printer setup"

This article was previously published under Q223420

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SYMPTOMS

When you try to print a document in Word, you receive the following error message:
Windows cannot print due to a problem with the current printer setup.

Try one or more of the following:
*Check the printer by printing a test page from Windows.
*Make sure the printer is turned on and online.
*Reinstall the printer driver.

CAUSE

You may receive this error message for one or more of the following reasons:
  • The printer driver contains damaged printer files.
  • The Windows Registry section that contains your printer information is damaged.
  • There is a device conflict between your printer port and Windows.
  • The Windows printing subsystem is damaged.
  • There is a problem with your fax setup.

RESOLUTION

This section describes two methods to resolve the issue. The steps in this section are intended for beginning to intermediate computer users. Follow the methods in the order in which they are presented.

Method 1: Check whether the printer driver is damaged

To determine whether the printer driver is damaged, remove and reinstall the printer driver.

Note You must have your Windows installation CD or the disc that was provided with your printer to complete this procedure.

To remove and reinstall the printer driver, follow these steps:
  1. Exit all programs.
  2. Click Start, and then click Run.
  3. Copy and paste (or type) control printers in the Open box, and then click OK.
  4. Right-click your installed printer, and then click Delete. If you are prompted to remove additional files that remain on the system, click Yes. The printer driver is removed.
  5. To reinstall the printer driver, double-click Add Printer, and then follow the instructions to reinstall the printer driver.

    Note If you are running Windows XP, click Add a printer under Printer Tasks.
Note If you are on a network, you may have to install the correct printer driver from a network printer share. For information about how to do this, contact your network administrator. For information about how to contact your printer manufacturer for an updated driver, visit the following Microsoft Web site:
http://support.microsoft.com/gp/vendors (http://support.microsoft.com/gp/vendors)
If this method resolves the error message and if you can print successfully, the printer driver was likely damaged and is now replaced. You are finished.

If this method did not resolve the issue, go to method 2.

Method 2: Check whether the Windows registry has a damaged default printer entry

The Windows registry may have a damaged default printer entry. To resolve the issue, reset the Windows registry.

To reset the Windows registry, first change your default printer temporarily, and then reselect your original printer as the default printer.

If you do not have a second printer set up on your computer, go to step 1 to add a new printer. You do not have to have an additional printer to complete this step.

If you already have another printer set up on your computer, skip step 1 and go to step 2.

Step 1: Add a new printer

To add a new printer, follow the steps for the version of Windows that is running on your computer:
Windows XP
To add a new printer in Windows XP, follow these steps:
  1. Click Start, and then click Run.
  2. Copy and paste (or type) control printers in the Open box, and then click OK.
  3. In the left navigation pane under Printer Tasks, click Add a printer.
  4. In the Add Printer Wizard, click Next.
  5. Click Local printer attached to this computer, clear the Automatically detect and install my Plug and Play check box, and then click Next.
  6. Click Use the following port: LPT1 (Recommended Printer Port), and then click Next.
  7. In the Manufacturers list, click Generic.
  8. In the Make/Model or Printers list, click Generic / Text Only, and then click Next.
  9. Type the name that you want to use for the printer, and then click Next.
  10. Click Do not share this printer, and then click Next.
  11. When you are prompted to print a test page, click No, and then click Next.
  12. Click Finish to close the Add Printer Wizard.
When you are finished adding a new printer, go to step 2.
Earlier versions of Windows
To add a new printer in an earlier version of Windows, follow these steps:
  1. Click Start, and then click Run.
  2. Copy and paste (or type) control printers in the Open box, and then click OK.
  3. In the Printers dialog box, double-click Add Printer. The Add Printer Wizard opens.
  4. Click Next.
  5. In the Add Printer Wizard, click to select the Local, Local Printer, or My Computer option, and then click Next.
  6. In the Manufacturers list, click Generic.
  7. In the Make/Model or Printers list, click Generic / Text Only, and then click Next.
  8. Click the LPT1 port, and then click Next.
  9. Click Next again, and then click Finish.
When you are finished adding a new printer, go to step 2.

Step 2: Change your default printer driver, and then reselect the original printer driver as the default

To change your default printer to the second printer or the new printer that you set up in step 1, follow these steps:
  1. Click Start, and then click Run.
  2. Copy and paste (or type) control printers in the Open box, and then click OK.
  3. In the Printers and Faxes dialog box, right-click Generic/Text Only printer (or your other existing printer), and then click Set as Default Printer.

    The printer default is changed.
  4. To set the original printer as the default printer, right-click the original printer, and then click Set as Default. The original printer is set as the default.
  5. Try to print.
If this method resolved the error message and if you can print successfully, the Windows registry likely had a damaged default printer entry and is now corrected. You are finished.

If this method did not resolve the error message and if you still cannot print, go to the "Advanced Troubleshooting" section. If you are not comfortable with advanced troubleshooting, you may want to ask someone you know for help, or you may want to contact Support. For information about how to contact Support, go to the "Next Steps" section.

Advanced Troubleshooting

This section has three advanced troubleshooting methods. The steps in this section are intended for advanced computer users. Follow these methods in the order in which they are presented.

Method 1: Check the Printer port status and if there is a problem, remove and reinstall the Printer port

Check the Device status to make sure that there is no a problem with the printer port. If there is a problem with the printer port, remove and reinstall it.

Step 1: Check the Device status of the Printer port

To check the Device status, follow these steps:
  1. Click Start, and then click Run.
  2. Copy and paste (or type) sysdm.cpl in the Open box, and then click OK. The System Properties dialog box opens.
  3. Select the port to which your printer is connected. To do this, follow the steps for the version of Windows that is running on your computer:
    Windows XP or Windows 2000
    To select the port in Windows XP or Windows 2000, follow these steps:
    1. In the System Properties dialog box, click the Hardware tab.
    2. In the Device Manager section, click Device Manager.
    3. Double-click to expand the Ports (COM & LPT).
    4. Double-click the port to which your printer is connected.

      The Communications Port (COM1) Properties dialog box opens.
    Windows Millennium Edition (Me), Windows NT 4.0, Windows 98, or Windows 95
    To select the port in Windows Me, Windows NT 4.0, Windows 98, or Windows 95, follow these steps:
    1. In the System Properties dialog box, click the Device Manager tab.
    2. Double-click to expand the Ports (COM & LPT).
    3. Double-click the port to which your printer is connected.

      The Communications Port (COM1) Properties dialog box opens.
  4. In the Communications Port (COM1) Properties dialog box, check the status under the Device status section.
  5. If the status indicates that the device is working correctly, your computer may have another system problem. Go to method 2.
If the Device status box indicates a problem, go to step 2.

Step 2: If there is a problem with the Printer port, remove and reinstall it

To remove and reinstall the printer port, follow these steps:
  1. If the Device status box indicates a problem, click OK, and then click Remove.
  2. Click OK, and then restart your computer.
  3. After your computer restarts, click Start, click Run, type control, and then click OK. Control Panel is displayed.
  4. Double-click Add New Hardware, and then let Windows detect the hardware in your computer.
  5. Try to print.
If this method resolves the error message and if you can print successfully, you are finished.

If the port still does not work after you remove it and reinstall it, examine the printer cable to make sure that it is not damaged. Then, check the BIOS settings on your computer to make sure that the port is turned on. For information about how to check the BIOS settings, refer to your computer documentation.

If this method did not resolve the issue, go to method 2.

Method 2: Check for and repair any damaged files in the Windows printing subsystem

The System File Checker verifies the integrity of system files. If the System File Checker finds a damaged system file, you can restore the file. To check whether there are damaged system files, follow the steps for the version of Windows that is running on your computer.

Note The System File Checker is available only in Windows 98, Windows 2000, and Windows XP.

Note You must be logged on to the computer as an administrator or as a member of the Administrators group to run System File Checker for Windows 2000 or Windows XP. To verify that you are logged on to Windows with a user account that is a computer administrator, visit the following Microsoft Web site:
http://support.microsoft.com/gp/admin (http://support.microsoft.com/gp/admin)

Windows XP or Windows 2000

To check system files in Windows XP or Windows 2000, follow these steps:
  1. Click Start, and then click Run.
  2. Copy and paste (or type) cmd in the Open box, and then click OK.
  3. At the command prompt, type sfc /scannow, and then press ENTER.
  4. If the System File Checker finds any damaged files, follow the instructions to reinstall them.
  5. Try to print.

    If this method resolves the error message and if you can print successfully, you are finished.
If the System File Checker finds and repairs damaged files, and this does not resolve the issue, your computer may have a more serious system problem and you may have to reinstall your operating system. For more information about the System File Checker for Windows 2000, click the following article number to view the article in the Microsoft Knowledge Base:
222471  (http://support.microsoft.com/kb/222471/ ) Description of the Windows 2000 System File Checker Tool

Windows 98

To check system files in Windows 98, follow these steps:
  1. Click Start, and then click Run.
  2. Copy and paste (or type) msinfo32 in the Open box, and then click OK.
  3. On the Tools menu, click System File Checker.
  4. Click Scan for altered files, and then click Settings.
  5. Select the configuration that you want to use, and then click OK.
  6. Click Start.
  7. If the System File Checker finds any damaged files, follow the instructions to reinstall them.
  8. Try to print.
If this method resolves the error message and if you can print successfully, you are finished. If the System File Checker finds and repairs damaged files, and this does not resolve the issue, your computer may have a more serious system problem and you may have to reinstall your operating system. For additional information about the System File Checker, click the article number below to view the article in the Microsoft Knowledge Base:
185836  (http://support.microsoft.com/kb/185836/EN-US/ ) Description of the System File Checker Tool (Sfc.exe)
If the System File Checker does not find any damaged files, and if you have fax software installed on your computer, go to method 3. If you do not have fax software on your computer, go to the "Next Steps" section for information about how to contact Support.

Method 3: Check whether your fax software is set up correctly

If you receive this error message when you try to send a fax, a problem may exist with your fax software setup. Troubleshoot the fax setup on your computer to try to resolve the issue.For additional information, click the article numbers below to view the articles in the Microsoft Knowledge Base:
211473  (http://support.microsoft.com/kb/211473/EN-US/ ) WD2000: Troubleshooting Fax Problems from Word
199043  (http://support.microsoft.com/kb/199043/EN-US/ ) WD2000: Error When Faxing from WinFax
If this method does not resolve the issue, you may want to review the articles in the "More Information" section. If these articles do resolve the error message and you still cannot print, go to the "Next Steps" section for information about how to contact Support.

MORE INFORMATION

Microsoft Office 2000 has built-in functionality that you can use to obtain more information about difficult-to-troubleshoot alerts or error messages. If you want to enable the functionality for this and other error messages in Microsoft Office 2000, download the Microsoft Office 2000 Customizable Alerts file from the Microsoft Office Update Web site at the following address:
http://www.microsoft.com/downloads/details.aspx?FamilyID=8FBEE1D3-C5BB-4A36-A2F7-DC63DE2A818C (http://www.microsoft.com/downloads/details.aspx?FamilyID=8FBEE1D3-C5BB-4A36-A2F7-DC63DE2A818C)
Note If you reached this article by clicking the Web Info button in an error message, Customizable Alerts are already enabled.

REFERENCES

For additional information if you are unable to resolve this problem, click the article numbers below to view the articles in the Microsoft Knowledge Base:
128345  (http://support.microsoft.com/kb/128345/EN-US/ ) Troubleshooting Printing Problems in Windows 95/98/Millennium Ed
243075  (http://support.microsoft.com/kb/243075/EN-US/ ) How to Troubleshoot Network Printing Problems
304422  (http://support.microsoft.com/kb/304422/EN-US/ ) WD2000: How to Troubleshoot Print Failure in Word 2000
304433  (http://support.microsoft.com/kb/304433/EN-US/ ) WD2000: Troubleshooting Printer Output Issues in Word 2000
211526  (http://support.microsoft.com/kb/211526/EN-US/ ) WD2000: Cannot Print After Canceling Using HPDJ820CXi Driver

NEXT STEPS

If these methods did not resolve your issue, you may want to ask someone you know for help, or you may want to contact Support. You can also use the Microsoft Customer Support Services Web site to find other solutions to your problem. Some services that the Microsoft Customer Support Services Web site provides include the following:
  • Searchable Knowledge Base (http://support.microsoft.com/search/?adv=1) : Search technical support information and self-help tools for Microsoft products.
  • Solution Centers (http://support.microsoft.com/select/?target=hub) : View product-specific frequently asked questions and support highlights.
  • Microsoft Customer Support Newsgroups (http://www.microsoft.com/communities/newsgroups/default.mspx) : Contact counterparts, peers, and Microsoft Most Valuable Professionals (MVPs).
  • Other Support Options (http://support.microsoft.com/default.aspx?pr=csshome) : Use the Web to ask a question, contact Microsoft Customer Support Services, or provide feedback.
If you continue to have problems after you use these Microsoft Web sites or if you cannot find a solution to the problem on the Microsoft Support Services Web site, click the following link to contact Support.
http://support.microsoft.com/contactus (http://support.microsoft.com/contactus)


For help with printer problems in Windows Vista, visit the following Microsoft web page:

APPLIES TO
  • Microsoft Word 2000
Keywords: 
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