OL2000: Error Message "A program error occurred. Quit Outlook and Microsoft Windows and then start again."

Article translations Article translations
Article ID: 223456 - View products that this article applies to.
This article was previously published under Q223456

ERROR MESSAGE

When using Outlook you may receive the following error message:
A program error occurred. Quit Outlook and Microsoft Windows and then start again.

NOTE: Microsoft Office 2000 has built-in functionality that allows you to get more information about difficult-to-troubleshoot alerts or error messages. If you want to enable this functionality for this and other error messages in Microsoft Office 2000, please download the Microsoft Office 2000 Customizable Alerts file from the Microsoft Office Update Web site at the following address:
http://www.microsoft.com/downloads/details.aspx?FamilyID=8FBEE1D3-C5BB-4A36-A2F7-DC63DE2A818C


NOTE: If you reached this article by clicking the Web Info button in an error message, you already have Customizable Alerts enabled.

CAUSES

WHAT TO TRY

Not Enough Available RAM

You can make more memory available by quitting all programs, restarting Windows and then only starting those programs that you require. You can use the Windows Task Manager to view and selectively shut down programs that you do not need.

To view all running programs press CTRL+ALT+DELETE. Click the program you want to shut down and click End Task.

Not Enough Available Swap File Hard Disk Space

When Windows runs out of RAM, it uses hard drive space to free more RAM. It does this by swapping information from RAM to the swap file on your hard drive. Normally Windows manages this process without user intervention, however, if you run too low on hard drive space on the drive that contains your swap file, Windows cannot free enough RAM for normal program operation.

If you have multiple disk drives, you can use the My Computer Properties to determine which disk drive contains your swap file.
  1. Right-click My Computer and then click Properties.
  2. Click the Performance tab, and then click Virtual Memory.
The recommended setting is to Let Windows manage my virtual memory settings. Beside the Hard disk setting you can see the name of the disk drive that contains your swap file. This is the disk drive that must have enough free space.

To make more disk space available empty the Recycle Bin and then use Windows Explorer to delete any files you do not need.

Invalid Extension Information

Outlook may have problems with incompatible or invalid extension information. Extensions may cause Outlook to not start or generate errors while running.

To troubleshoot extension problems, do the following.

If Outlook Does Not Start

If Outlook does not start, try replacing the Extend.dat file. This file caches extension information gathered from the Windows registry. To replace the Extend.dat file, follow these steps:
  1. Quit all programs.
  2. Click Start, point to Find, and then click Files Or Folders.
  3. In the Named box, type extend.dat.
  4. In the Look In list, click to select your hard drive drive.
  5. Click to select Include Subfolders and click Find Now.
  6. In the Name list, right-click the file Extend.dat, and on the shortcut menu, click Rename. Change the file extension from "dat" to "old," and press ENTER.
  7. On the File menu, click Close to quit Find File.
  8. Restart Outlook. Restarting Outlook creates a new Extend.dat file.

If Outlook Does Start

If you can start Outlook and you suspect an extension problem, you can test it by turning off extensions.

To turn off extensions, follow these steps:
  1. Start Outlook.
  2. On the Tools menu, click Options, and click the Other tab.
  3. Click Advanced Options, and then click Add-In Manager.
  4. In the Add-In list, click to clear the check box for the add-in you suspect.
  5. Click OK three times to close all dialog boxes.


Damaged Profile

If you suspect that your profile information is damaged, you can create a new profile without deleting the old one. How you accomplish this depends on what type of Outlook installation you chose, (Internet Mail Only (IMO), or Corporate or Workgroup (CW). To determine your installation option, click About Microsoft Outlook on the Help menu.

Create a New Profile and PST File (CW)

To create a new profile, follow these steps:
  1. In Windows Control Panel, double-click the Mail And Fax icon. (The icon is a Mail icon if you did not install fax services.)
  2. On the Services tab, click Show Profiles to list your profiles.
  3. Click Add to start the Inbox Setup Wizard.
  4. Check that the default is set to Use the following information services.
  5. Click to clear all services except the one you are troubleshooting. For troubleshooting purposes, add only one service at a time.
  6. Click Next and in the Profile Name box, type a name for the new profile.
  7. Follow the Inbox Setup Wizard prompts, answering the questions for your service. Make sure you specify a new Personal Folders file (*.pst) and do not use the existing file when prompted by the wizard.
NOTE: Because you are not using the old .pst file while troubleshooting, you will not see any of your old .pst folders or files.

Create a New Internet Mail Only (IMO) Profile

If you have installed the Internet Mail Only version of Outlook, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click the Mail icon.
  3. Select and remove each Internet mail account from the Internet Accounts Manager. Be sure you know all the properties for each account before removing it.

    NOTE: Do not remove fax accounts.
  4. Add the accounts back one at a time.

Create a New Personal Folders File (IMO)

  1. Start Outlook.
  2. On the File menu, point to New, and then click Personal Folders File (.pst).
  3. Select a location, type a name, and then click Create. Select any options you wish to use, and click OK.

    NOTE: Do not use the name "mailbox.pst."
  4. On the View menu, click Folder List if it is not already displayed.
  5. Right-click the new personal folders file, and click Properties.
  6. On the General tab, click to select Deliver POP mail to this personal folders file, and click OK.


Damaged Outlook Installation

Rename the Outllib.dll file and reinstall to repair the Outlook installation.

Rename the Outllib.dll File

  1. Click Start, point to Find, and then click Files Or Folders.
  2. In the Name box, type Outllib.dll and in the Look In list, click to select the hard disk drive that contains Outlook. Click to select Include Subfolders.
  3. In the Name list, right-click Outllib.dll and on the shortcut menu, click Rename. Rename the file to Outllib.old, and press ENTER.

Reinstall Outlook

  1. Click Start, point to Settings, and then click Control Panel.
  2. In Control Panel, double-click Add/Remove Programs.
  3. On the Install/Uninstall tab, click to select Office 2000 <product> where <product> is one of the versions of Office, and click Add/Remove.
  4. In the Maintenance Wizard, click Repair Office.
  5. Click Repair errors in my Office 2000 <product> installation, and click Finish.
  6. Click OK, and restart Outlook.


Expand all | Collapse all

Properties

Article ID: 223456 - Last Review: August 16, 2012 - Revision: 4.0
Applies to
  • Microsoft Outlook 2000 Standard Edition
Keywords: 
kbdownload kbprb KB223456

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com