[OL2000] "プログラム エラーが発生しました" エラーが発生する

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文書番号: 223456 - 対象製品
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目次

概要

この資料は、Outlook 2000 を使用中にプログラム エラーが表示される場合について説明したものです。

詳細

Outlook 2000 を使用してる際に、以下のようなエラーメッセージが表示される場合があります。
プログラム エラーが発生しました。Outlook および Microsoft Windows を終了し、再起動してください。

原因

このエラー メッセージは、以下のいずれかの理由によって発生します。
  • ランダム アクセス メモリ (RAM) の空き領域が不足している場合。
  • ハード ドライブの空き領域が不足し、スワップ ファイルを利用できない場合。
  • Outlook 2000 の拡張機能に問題がある場合。互換性がないか、不正な情報が含まれています。
  • プロファイルが壊れている場合。
  • Outlook 2000 のインストールに異常がある場合。

解決方法

メモリが不足している場合

すべてのプログラムを終了し、Windows を再起動してから、必要なプログラムだけを実行すると、メモリの空き領域を増やすことができます。Windows タスク マネージャを使用すると、必要のないプログラムを一覧から選択して終了することができます。

実行中のすべてのプログラムを表示するには、[Ctrl] + [Alt] + [Delete] キーを押します。終了したいプログラムをクリックし、[タスクの終了] ボタンをクリックします。

ハード ディスクにスワップ ファイルのための空き領域がない場合

メモリが不足すると、空き領域を増やすため、Windows はハード ドライブを使用 します。 Windows は、メモリ 上の情報をハード ドライブのスワップ ファイルに移動します。この処理は一般に、ユーザーの操作を必要とせず、Windows によって管理されますが、スワップ ファイルのあるハード ドライブの空き領域が少なすぎる場合には、Windows は、通常のプログラム処理に必要なメモリ領域を確保できません。

複数のディスク ドライブをお使いの場合は、マイ コンピュータのプロパティで、スワップ ファイルを作成するドライブを指定することができます。
  1. [マイ コンピュータ] を右クリックし、[プロパティ] をクリックします。
  2. [パフォーマンス] タブをクリックし、[仮想メモリ] ボタンをクリックします。
仮想メモリの設定は、Windows に管理させることを推奨します。ハード ディスクの設定を見ると、スワップ ファイルのあるディスク ドライブ名を確認できます。このドライブに十分な空き領域がなければいけません。

ディスクの空き領域を増やすには、ごみ箱を空にするとともに、Windows エクスプローラで不要なファイルを削除してください。

拡張機能情報が正しくない場合

Outlook 2000 の拡張機能に問題があり、互換性がないか、不正な情報が含まれている可能性があります。拡張機能は、Outlook 2000 の起動を妨げたり、実行中にエラーを発行する場合があります。

拡張機能の問題のトラブルシューティングは、以下の操作手順を参照してください。

Outlook 2000 が起動しない場合

Outlook 2000 が起動しない場合、Extend.dat ファイルを置き換えてみてください。このファイルには、Windows のレジストリから収集された拡張機能情報がキャッシュされています。Extend.dat ファイルを置き換えるには、以下の手順を行います。
  1. すべてのプログラムを終了します。
  2. [スタート] ボタンをクリックし、[検索] をポイントして [ファイルやフォルダ] をクリックします。
  3. [名前] ボックスに " extend.dat " と入力します (クォーテーション マークは除きます)
  4. [探す場所] ボックスの一覧で、ハード ドライブをクリックして選択します。
  5. [サブフォルダも探す] チェック ボックスをオンにし、[検索開始] ボタンをクリックします。
  6. 検索結果に表示された Extend.dat を右クリックし、ショートカット メニューの[名前の変更] をクリックします。拡張子を "dat" から "old" に変更して、[Enter]キーを押します。
  7. [ファイル] メニューの [閉じる] をクリックし、検索を終了します。
  8. Outlook 2000 を再起動します。

Outlook 2000 が起動する場合

Outlook 2000 が実行でき、拡張機能に問題があると思われる場合は、拡張機能をオフにしてテストします。拡張機能をオフにするには、以下の操作手順を参照してください。
  1. Outlook 2000 を起動します。
  2. [ツール] メニューの [オプション] をクリックし、[その他] タブをクリックします。
  3. [詳細オプション] ボタンをクリックし、[アドイン マネージャ] ボタンをクリックします。
  4. アドインの一覧で、疑わしいアドインのチェック ボックスをクリックしてオフにします。
  5. [OK] ボタンを 3 回クリックし、すべてのダイアログ ボックスを閉じます。

プロファイルが壊れている場合

プロファイル情報が破損していると思われる場合は、現在のプロファイルを残したまま、新しいプロファイルを作成します。この方法は、Outlook 2000 のインストール オプションで、[インターネット メールのみ] または [企業/ワークグループ] のいずれが選択されたかによって異なります。インストール オプションを確認するには、[ヘルプ] メニューの [バージョン情報] をクリックします。

新しいプロファイルと PST ファイルの作成 (企業/ワークグループ)

新しいプロファイルを作成するには、以下の操作手順を参照してください。
  1. Windows のコントロール パネルで [メール] アイコンをダブルクリックします
  2. [サービス] タブで [プロファイルの表示] ボタンをクリックし、プロファイルの一覧を表示します。
  3. [追加] ボタンをクリックし、[Microsoft Outlook セットアップ ウィザード] を開きます。
  4. [次のインフォメーション サービスを利用する] がオンになっていることを確認します。
  5. クリックして、問題を解決したいサービスだけをチェックし、そのほかのサービスのチェックを外します。トラブルシューティングでは、一度に追加するサービスは 1 つだけにします。
  6. [次へ] ボタンをクリックします。[プロファイル名] ボックスに、新しいプロファイルの名前を入力します。
  7. [Microsoft Outlook セットアップ ウィザード] のメッセージに従って、セットアップが完了するまで、サービスに必要な情報を入力します。
注意:トラブルシューティングの間は、以前の .pst ファイルを使用しないため、個人用フォルダにはフォルダやファイルが保存されていません。

新しい個人用フォルダ ファイルの作成 (インターネット メールのみ)

  1. Outlook 2000 を起動します。
  2. [ファイル] メニューの [新規作成] をポイントし、[個人用フォルダ ファイル] をクリックします。
  3. 保存する場所を選択してファイル名を入力し、[作成] ボタンをクリックします。使用するオプションを選択して、[OK] ボタンをクリックします。

    注意: "mailbox.pst" という名前は使用しないでください。
  4. フォルダ一覧が表示されていない場合は、[表示] メニューの [フォルダ一覧] をクリックします。
  5. 作成した個人用フォルダ ファイルを右クリックし、[プロパティ] をクリックします。
  6. [全般] タブで [この個人用フォルダに POP メールを配信する] チェック ボックスをオンにします。[OK] ボタンをクリックします。

Outlook 2000 のインストールに異常がある場合

Outllib.dll ファイルの名前を変更し、Outlook 2000 のインストール状態を修復するために、再インストールしてください。

Outllib.dll ファイルの名前を変更する

  1. [スタート] ボタンをクリックし、[検索] をポイントして [ファイルやフォルダ] をクリックします。
  2. [名前] ボックスに " outllib.dll " と入力します (クォーテーション マークは除きます) [探す場所] ボックスの一覧で、Outlook をインストールしたディスクドライブをクリックして選択します。[サブフォルダも探す] チェック ボックスをオンにします。
  3. 検索結果に表示された outllib.dll を右クリックし、[名前の変更] をクリックします。ファイル名を "outllib.old" に変更して (クォーテーション マークは除きます)、[Enter] キーを押します。

Outlook 2000 の再インストール

  1. [スタート] ボタンをクリックし、[設定] をポイントして [コントロール パネル]をクリックします。
  2. コントロール パネルで [アプリケーションの追加と削除] をダブルクリックします。
  3. [インストールと削除] タブで、[Office 2000 <製品>] をクリックして選択します。<製品> には、Office のバージョンの 1 つが入ります。[追加と削除] ボタンをクリックします。
  4. メンテナンス ウィザードで [Office の修復] をクリックします。
  5. [OK] ボタンをクリックし、Outlook 2000 を再起動します。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 223456 (最終更新日 1999-07-16) をもとに作成したものです。

プロパティ

文書番号: 223456 - 最終更新日: 2003年11月12日 - リビジョン: 1.0
この資料は以下の製品について記述したものです。
  • Microsoft Outlook 2000 Standard Edition
キーワード:?
kbinfo outlook 2000 9.0 KB223456
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