如何在 Excel 活頁簿中的中繼資料最小化

文章翻譯 文章翻譯
文章編號: 223789 - 檢視此文章適用的產品。
全部展開 | 全部摺疊

在此頁中

結論

本文將告訴您各種方法您可以用來在您的活頁簿中的中繼資料總量縮到最小。

當您建立、 開啟,或在 Microsoft Excel 中儲存的活頁簿時,活頁簿可能包含不想與其他人共用,當您以電子方式散發活頁簿的內容。這項資訊稱為中繼資料。中繼資料用於各種用途,以增強編輯、 檢視、 歸檔和擷取的 Office 文件。

透過 Excel 的使用者介面輕易地存取某些中繼資料。其他中繼資料則只能透過特別方法存取例如藉由在低階二進位檔案編輯器中開啟活頁簿。

以下是一些可能儲存您的活頁簿中的中繼資料的範例:
  • 您的名稱
  • 您的姓名縮寫
  • 您的公司或組織名稱
  • 您的電腦名稱
  • 網路伺服器或硬碟儲存活頁簿的名稱
  • 其他檔案屬性和摘要資訊
  • 內嵌的 OLE 物件的不可見部份
  • 文件修訂
  • 隱藏的文字或儲存格
  • 個人化的檢視
  • 註解

其他相關資訊

中繼資料以各種方式在 Excel 中建立的活頁簿。如此一來沒有單一方法可以從您的活頁簿移除所有這類內容。下列章節描述中繼資料可能儲存在 Excel 活頁簿中的區域。

安裝最新的更新

下列更新都可以。 如需有關這些更新的詳細資訊,按一下 [下列面的文件編號,檢視 「 Microsoft 知識庫 」 中 「 文件]:
305095Office XP 更新程式的歷程記錄
269356概觀與 Excel 2000 更新的歷程記錄
232652概觀和 Excel 修補程式的歷程記錄

如何刪除您的使用者名稱從您的程式

若要檢視或變更您的使用者名稱,請依照下列步驟執行:
  1. 按一下 [工具] 功能表 選項。按一下 [一般] 索引標籤。您會看到 使用者名稱] 編輯方塊。
  2. 如果您不想此資訊以出現在您的活頁簿中的任何,輸入 [無法辨識的資訊或空格],請在 [編輯] 方塊中,然後再按一下 [確定] 以接受變更。
此資訊,而不是您所輸入第一次安裝 Office 時的預設值,會包含您建立任何新的活頁簿。不過,現有的活頁簿可能已經包含此資訊。

如何移除個人摘要資訊

當您建立或儲存活頁簿在 Microsoft Excel 中時,摘要資訊可能會儲存在活頁簿內。有數種您可以使用來存取此資訊的方法:
  • 開啟活頁簿。按一下 [檔案] 功能表 內容]摘要]、 [統計資料]、 [內容],] 和 [自訂] 索引標籤可能包含您的姓名、 您的專案經理名稱和您的公司名稱等這類的各種屬性。
  • 在 [Windows 檔案總管] 中活頁簿] 上按一下滑鼠右鍵,然後按一下 [快顯功能表上的 [內容]。[屬性] 對話方塊中的索引標籤可能會包含您想要移除的資訊。
  • 您可以使用的應用程式的巨集或其他程式碼的 Microsoft Visual Basic 來讀取 屬性] 對話方塊中顯示的內容。
如果要移除現有的活頁簿或範本的摘要資訊,請依照下列步驟執行:
  1. 開啟活頁簿或範本。
  2. 按一下 [檔案] 功能表 內容]
  3. 在 [摘要] 索引標籤上刪除 作者管理員公司 和其他不想散佈的編輯方塊中的任何文字。
  4. 在 [自訂] 索引標籤上刪除 [包含您不要散佈資訊的任何內容]。
  5. 完成,按一下 [確定]。在 [檔案] 功能表上按一下 [儲存]。
  6. 在 [檔案] 功能表上, 按一下 [關閉]。
完成這些步驟之後,活頁簿將不會包含摘要內容。

當您連線到網路時移除個人摘要資訊

如果您登入到一個網路您網路的使用者名稱可能會出現在 作者 編輯方塊在 [摘要] 索引標籤上,以及在 統計資料] 索引標籤的 [上次儲存者] 欄位中,當您儲存活頁簿。即使從您的電腦中移除所有其他個人資訊,這可能發生。

當您在網路上,請取消活頁簿的摘要資訊,請依照下列步驟執行:
  1. 如果活頁簿儲存在網路伺服器上,將活頁簿複製到您的本機硬碟。
  2. 開始您的電腦,但並 登入您的網路。當您看到網路登入對話方塊時,按一下 [取消],或按 ESC 鍵。

    附註如果您無法啟動 Windows 藉由按下 ESC 鍵 (比方說您的電腦正在執行 Microsoft Windows NT),您無法繼續執行這些步驟。
  3. 開啟活頁簿。
  4. 按一下 [檔案] 功能表 內容]
  5. 在 [摘要] 索引標籤上刪除 作者管理員公司 及其他包含您不要散佈資訊的編輯方塊中的任何文字。
  6. 在 [自訂] 索引標籤上刪除 [包含您不要散佈資訊的任何內容]。
  7. 當您完成按一下 [確定]。在 [檔案] 功能表上按一下 [儲存]。
  8. 在 [檔案] 功能表上, 按一下 [關閉]。
當您登入到網路上 不要開啟檔案。如果您這麼做您的網路使用者名稱可能會寫入到檔案。 但是,您可以使用 Windows 檔案總管將檔案複製到網路伺服器或磁片。

如何移除活頁簿中的註解

Microsoft Excel 提供了能夠將註解加入至活頁簿。 通常,註解包含建立者之人的名稱。

在 Microsoft Excel 中的註解會顯示為小的紅色三角形右上角的儲存格。若要檢視註解、 在儲存格上按一下滑鼠右鍵,然後按一下快顯功能表上的 [刪除註解

因為您刪除它從您 選項] 對話方塊本文稍早 」 如何以刪除使用者名稱從您程式 」 一節所述,您所建立的任何新註解不應包含您的使用者名稱。

刪除資訊如何從頁首和頁尾

活頁簿中的頁首及頁尾可能包含識別資訊。若要刪除頁首及頁尾的資訊,請依照下列步驟執行:
  1. 開啟活頁簿。
  2. 在 [檔案] 功能表上按一下 [版面設定]。按一下 [頁首/頁尾] 索引標籤,然後再變更 [頁首及頁尾使它們包含沒有識別資訊。
  3. 當您完成時按一下 [確定]
請注意一個活頁簿的每個工作表包含它自己的頁首及頁尾,所以您必須重複執行此程序,每個工作表上。

如何移除活頁簿中的超連結

活頁簿可能包含連結至其他文件或網頁內部網路或網際網路上的超連結。超連結通常會顯示成藍色加底線的文字字串。

若要手動方式從一個活頁簿中刪除單一超連結,在超連結上按一下滑鼠右鍵,指向快顯] 功能表上的 [超連結],然後再按一下 [移除超連結]。

若要刪除活頁簿中的所有超連結,您可以使用 Visual Basic 應用程式的巨集。 如需有關如何撰寫這類的巨集的詳細資訊,按一下 [下列面的文件編號,檢視 「 Microsoft 知識庫 」 中 「 文件]:
213790若要選取工作表內的所有超連結沒有功能表指令
156353若要選取所有的超連結沒有功能表選擇

如何移除活頁簿中的樣式

在 Microsoft Excel 活頁簿可能包括包含中繼資料的樣式。您可以移除這些樣式或重新命名它們。要這麼做,請您執行下列步驟:
  1. 開啟活頁簿之樣式所在。
  2. 按一下 [格式] 功能表 樣式
  3. 選取您想要刪除或重新命名的樣式。按一下 [刪除此樣式,或按一下 [樣式名稱 中的 [刪除] 方塊,並鍵入新的樣式名稱,若要重新命名樣式。

如何在 Excel 活頁簿中顯示隱藏的儲存格、 列和資料行

在 Microsoft Excel 中很可能隱藏整個資料列和工作表中的儲存格的資料行。

若要取消所有工作表中的儲存格,請依照下列步驟執行:
  1. 按一下工作表的左上角中的 [全選] 按鈕。或按 CTRL + SHIFT + 空白鍵。
  2. 在 [格式] 功能表上指向 [資料列,然後按一下 [取消隱藏]。
  3. 在 [格式] 功能表上指向 [資料行,然後按一下 [取消隱藏]。
此時會顯示所有儲存格。

請注意儲存格可能仍然有其高度或寬度設定讓儲存格難以看到為極小值。如果是這種情況,請依照下列步驟執行:
  1. 按一下工作表的左上角中的 [全選] 按鈕。或按 CTRL + SHIFT + 空白鍵。
  2. 在 [格式] 功能表上指向 [,然後再按一下 [自動調整大小
  3. 在 [格式] 功能表上指向 [直欄,然後 再按一下 [自動調整
這會強制所有的儲存格調整大小以顯示其內容。

請注意它是仍然儲存格內容,很難看到的可能 ; 的例如色彩如果儲存格的內容已格式化為在儲存格中以背景使用白色字型也是白色。若要變更選取儲存格的字型屬性,按一下 [格式] 功能表上的 [儲存格],然後再按一下 [字型] 索引標籤。

如何取消隱藏隱藏的工作表在 Excel 活頁簿中

在 Microsoft Excel 活頁簿可能包含隱藏的工作表包含的資訊。要取消隱藏工作表、 將游標指向 工作表 在 [格式] 功能表上再按一下 [取消隱藏。如果隱藏的工作表可以選取工作表,然後按一下 [確定]

附註如果 [取消隱藏] 命令無法使用,有任一沒有隱藏的工作表,或者您活頁簿保護。在 [工具] 功能表上指向 [保護],然後按一下 [取消保護活頁簿]。如果提示您輸入密碼,請輸入要取消保護活頁簿。

如何從 Excel 活頁簿中移除連結

Microsoft Excel 活頁簿可能包含連結至其他活頁簿中的儲存格的儲存格的公式。如果您在傳送包含連結至另一位使用者的活頁簿他們可使用 [連結] 對話方塊來決定其他活頁簿名稱。

若要從一個活頁簿中移除連結,您必須在您的活頁簿中移除其他活頁簿從公式的所有參考。如果要執行這項操作的一個方法是請依照下列步驟執行:
  1. 按一下 [編輯] 功能表 連結
  2. 選取您不再想要連結,活頁簿的名稱,然後按一下 [變更來源
  3. 選取您目前編輯的活頁簿 ; 比方說如果您正在編輯 C:\Data\Test.xls,選取 C:\Data\Test.xls。然後,按一下 [確定]
  4. 重複步驟 2-3 為此活頁簿連結任何其他活頁簿。
  5. 當您完成時按一下 [確定]
附註藉由執行這些步驟,您可能會影響公式的結果在您的活頁簿中 ; 您甚至可能會造成某些公式,以傳回不正確的結果。

移除連結至其他活頁簿的另一種方法,就是將公式轉換成它們的結果。要這麼做,請您執行下列步驟:
  1. 選取包含公式連結至另一個活頁簿的儲存格。
  2. 編輯] 功能表上按一下 [複製]。
  3. 在 [編輯] 功能表上按一下 [選擇性貼上]。按一下 [值],然後再按一下 [確定]
公式現在已消失但公式會保持結果。

如何從共用 Microsoft Excel 活頁簿移除追蹤的修訂

Excel 中提供了追蹤修訂功能,可讓您追蹤由使用者對共用活頁簿所做的變更。如果要取消活頁簿的修訂請依照下列步驟執行:
  1. 開啟活頁簿。
  2. 在 [工具] 功能表上指向 [追蹤修訂],然後按一下 [反白提示修訂處]。
  3. 按一下以清除 (取消選取) [編輯時追蹤修訂] 核取方塊。按一下 [確定]
  4. 請按一下 [是] 將活頁簿回復成獨佔使用模式 (不會再共用活頁簿)。

如何從 Microsoft Excel 活頁簿刪除檢視

在 Excel 活頁簿中的自訂檢視可能包含您的名稱,特別是如果您使用共用活頁簿。

若要從活頁簿刪除檢視,請依照下列步驟執行:
  1. 按一下 [檢視] 功能表 自訂檢視模式
  2. 選取包含您的姓名或其他識別資訊的檢視,然後按一下 [刪除]。
請注意刪除檢視可能影響您的活頁簿會列印當您使用報表管理員 」 來列印報表。

如何刪除從活頁簿的傳閱名單資訊

如果您在使用傳閱名單傳送活頁簿透過電子郵件路由資訊可能會附加至活頁簿。若要從活頁簿中移除此資訊,您必須以不保留傳閱名單資訊的格式儲存活頁簿。

在 Microsoft Excel 中儲存活頁簿時的較舊的檔案格式,例如 SYLK、 Excel 4.0 或 Lotus 1-2-3 格式。關閉活頁簿,然後重新開啟新的檔案。因為傳閱名單資訊不再存在,您現在可以將檔案儲存為 Microsoft Excel 活頁簿。

您也可以依照下列步驟執行:
  1. 在 [檔案] 功能表上指向 [傳送到,] 然後按一下 [其他傳閱名單收件者]。
  2. 按一下 [清除 刪除傳閱名單。然後,按一下 [確定]
  3. 在 [檔案] 功能表上按一下 [儲存]。
活頁簿現在儲存但不含任何傳閱名單資訊。

如何從一個活頁簿刪除電子郵件地址資訊

在 Microsoft Office XP 中使用 檔案傳送 選項傳送郵件時,郵件收件者資訊會保留在 Office 文件中。Excel 2002 會保留的 TO 副本收件者,並為文件就地啟動 BCC 電子郵件地址當您使用 檔案傳送收件者 選項和電子郵件標頭。

若要將此資訊,請依照下列步驟執行:
  1. 檔案] 開啟選取 選項 [工具] 功能表上的 []。
  2. 選取 [安全性] 索引標籤,然後按一下以選取 自上的屬性儲存的檔案中移除個人資訊] 核取方塊。
  3. 按一下 [確定] 按鈕來關閉 [選項] dialiog 方塊,然後儲存您的檔案。
儲存檔案沒有保留電子郵件地址。

如何刪除您的名稱從 Visual Basic 程式碼

您在 Microsoft Excel 中錄製 Visual Basic 巨集時錄製的巨集的開頭與下列類似的標頭:
   ' Macro1 Macro
   ' Macro recorded 3/11/1999 by J. Doe
				
從任何您所錄製的巨集移除您的名稱,請依照下列步驟執行:
  1. 開啟包含巨集的活頁簿。
  2. 在 [工具] 功能表上指向 [巨集,然後按一下 [Visual Basic 編輯器]。或按下 ALT + F11。
  3. 在 [專案] 視窗中,按兩下包含巨集的模組。
  4. 從已錄製的巨集程式碼中刪除您的名稱。
當您完成時按 ALT + Q,傳回程式。然後,按一下 儲存檔案] 功能表上。

如何刪除 Visual Basic 參照到其他檔案

在 Visual Basic 編輯器] 中,您可以建立另一個檔案的參考。如果使用者開啟的活頁簿包含其他檔案的參考使用者可以看到參照檔案的名稱。

若要刪除這些參照,請依照下列步驟執行:
  1. 開啟包含參照活頁簿。
  2. 在 [工具] 功能表上指向 [巨集,然後按一下 [Visual Basic 編輯器]。或按下 ALT + F11。
  3. 按一下 [工具] 功能表 引用項目
  4. 按一下以清除參照檔案旁核取方塊。 當您完成時按一下 [確定] 關閉 [設定 引用項目-VBAProject] 對話方塊。
  5. 按 ALT + Q。
  6. 在 [檔案] 功能表上按一下 [儲存]。
附註刪除其他檔案的參考,可能會影響您的活頁簿中的巨集的能力,才能正確運作。

如何從一個活頁簿刪除網路或硬碟的資訊

當您儲存活頁簿,您的本機硬碟或網路伺服器時,識別本機硬碟或網路伺服器的資訊可能會寫入到活頁簿中。

若要從活頁簿中刪除此資訊,請依照下列步驟執行:
  1. 開啟活頁簿。
  2. 在 [檔案] 功能表上按一下 [另存]。將活頁簿儲存到軟碟機 (通常,A:)。
  3. 在 [檔案] 功能表上, 按一下 [關閉]。
  4. 移除該磁片從軟式磁碟機。
您現在可以使用 Windows 檔案總管將活頁簿從軟式磁碟複製到任何硬碟或網路伺服器。

附註因為的磁片 (通常 1.44 MB) 的 [空間] 限制活頁簿檔案大小超過磁碟片上的可用空間數量如果無法使用這個方法。

在活頁簿中的內嵌的物件可能包含中繼資料

如果您在活頁簿中嵌入物件,該物件仍會保留請在您怎麼做才能活頁簿而不考慮自己的屬性。例如,若在 Microsoft Excel 活頁簿中嵌入 Microsoft Word 文件,文件和活頁簿各有它們自己的屬性。

您可以刪除中繼資料中內嵌的物件開啟該物件移除任何中繼資料重新啟動容器文件 (在前一個範例這即是在 Excel 活頁簿),並再儲存容器文件。

附註當您在活頁簿中開啟內嵌的物件時,部分內嵌物件就會顯示在活頁簿中。物件可能包含未出現的其他資訊。視活頁簿,包含內嵌的物件和不是實際的內容的呈現請依照下列步驟執行:
  1. 選取該物件。在 [檔案] 功能表上按一下 [剪下]。
  2. 編輯] 功能表上按一下 [選擇性貼上], 將物件貼到活頁簿,藉由使用一個中繼檔格式。
您執行這項操作之後您不能編輯內嵌的物件 ; 不過,物件將不包含任何中繼資料。

如何移除 Office 97 文件中的唯一識別項

由於隨附於 Microsoft Office 97 程式的設計,建立或儲存在 Office 97 程式中的文件可能包含唯一識別項。 如其他有關這些識別項,以及如何將它們移除,按一下下面的文件編號,檢視 「 Microsoft 知識庫 」 中的發行項:
222180如何及為何在 Office 文件中建立唯一識別項
附註這個唯一識別項不存在於較新版本的 Microsoft Office 程式。

關於安全性的一般建議

您可以使用來增加您的電腦環境的安全性層級一些一般建議如下:
  • 您未正常在您的電腦保護安全有密碼保護的螢幕保護裝置、 電源上密碼或 Windows NT 鎖定功能的電腦]。
  • 如果您的電腦任何共用的資料夾確定製作您將密碼套用到共用的資料夾如此只有授權的使用者可以存取您的共用。更好的安全性使用使用者層級存取控制,讓您可以控制誰可以存取您的電腦共用的完全。
  • 當您刪除檔案時,請立即清空 「 資源回收筒。 您可能要考慮公用程式,完全清除或刪除的檔案會覆寫。
  • 當您備份您的資料時,將備份檔案存放在安全的位置,例如保險箱、 貴重物品保管箱或上鎖的檔案櫃。 萬一主要位置就會變成無法使用,請儲存一份較安全的離線位置您備份檔。
  • 重要文件應該有密碼保護,以確保只有經過授權的使用者才能開啟它們。您的密碼應該存放在安全的不同位置。請注意是否您無法想起密碼,沒有任何方式可以修復受密碼保護的文件的內容。
  • 散發文件以電子形式。而是,列印它們。不使用識別元素 (如特殊字型、 浮水印、 標誌或特殊紙張,除非所需 (比方說的簡報)。
  • 電子郵件是 匿名。不要以電子郵件傳送文件如果您擔心您附加至文件的任何方式的身分。
  • 不要透過網際網路傳送文件,藉由使用 HTTP 或 FTP 通訊協定。以 「 純文字 」,這表示它是技術上傳送跨這些通訊協定傳送的資訊越好 (然而不太可能) 的資訊被攔截。

如需詳細資訊

如其他有關本文所討論的主題的資訊,按一下下面的文件編號,檢視 「 Microsoft 知識庫 」 中 「 文件:
223396如何以最小化於 Office 文件的中繼資料
222180如何及為何在 Office 文件中建立唯一識別項
314800如何在 PowerPoint 2002 簡報中的中繼資料總量縮到最小
314797如何以最小化在 Microsoft PowerPoint 簡報中的中繼資料
223793如何以最小化在 Microsoft PowerPoint 簡報中的中繼資料
290945如何以最小化 Microsoft Word 2002 中的中繼資料
237361如何以最小化 Microsoft Word 2000 文件中的中繼資料
223790如何以最小化 Word 文件中的中繼資料

屬性

文章編號: 223789 - 上次校閱: 2007年1月24日 - 版次: 5.1
這篇文章中的資訊適用於:
  • Microsoft Office Excel 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
關鍵字:?
kbmt kbhowto kbofficeupdate KB223789 KbMtzh
機器翻譯
重要:本文是以 Microsoft 機器翻譯軟體翻譯而成,而非使用人工翻譯而成。Microsoft 同時提供使用者人工翻譯及機器翻譯兩個版本的文章,讓使用者可以依其使用語言使用知識庫中的所有文章。但是,機器翻譯的文章可能不盡完美。這些文章中也可能出現拼字、語意或文法上的錯誤,就像外國人在使用本國語言時可能發生的錯誤。Microsoft 不為內容的翻譯錯誤或客戶對該內容的使用所產生的任何錯誤或損害負責。Microsoft也同時將不斷地就機器翻譯軟體進行更新。
按一下這裡查看此文章的英文版本:223789
Microsoft及(或)其供應商不就任何在本伺服器上發表的文字資料及其相關圖表資訊的恰當性作任何承諾。所有文字資料及其相關圖表均以「現狀」供應,不負任何擔保責任。Microsoft及(或)其供應商謹此聲明,不負任何對與此資訊有關之擔保責任,包括關於適售性、適用於某一特定用途、權利或不侵權的明示或默示擔保責任。Microsoft及(或)其供應商無論如何不對因或與使用本伺服器上資訊或與資訊的實行有關而引起的契約、過失或其他侵權行為之訴訟中的特別的、間接的、衍生性的損害或任何因使用而喪失所導致的之損害、資料或利潤負任何責任。

提供意見

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com